libgmpxx-devel-6.1.2-alt2.i586.rpm


Advertisement

Description

libgmpxx-devel - Development C++ bindings for the GNU MP arbitrary precision arithmetic library

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package name libgmpxx-devel
Package version 6.1.2
Package release alt2
Package architecture i586
Package type rpm
Installed size 113.87 KB
Download size 113.87 KB
Official Mirror ftp.altlinux.org
This package contains libraries, header files and documentation required
for development C++ applications with the GNU MP arbitrary precision
arithmetic library.

Alternatives

Package Version Architecture Repository
libgmpxx-devel-6.1.2-alt2.x86_64.rpm 6.1.2 x86_64 Classic
libgmpxx-devel - - -

Requires

Name Value
libgmp-devel = 6.1.2-alt2
libgmpxx4 = 6.1.2-alt2
rpmlib(PayloadIsLzma) -

Provides

Name Value
libgmp_cxx-devel = 6.1.2
libgmpxx-devel = 6.1.2-alt2

Obsoletes

Name Value
libgmp_cxx-devel -

Download

Type URL
Binary Package libgmpxx-devel-6.1.2-alt2.i586.rpm
Source Package gmp-6.1.2-alt2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libgmpxx-devel rpm package:
    # sudo apt-get install libgmpxx-devel

Files

Path
/usr/include/gmpxx.h
/usr/lib/libgmpxx.so

Changelog

2017-04-13 - Anton Farygin <rider@altlinux.ru> 6.1.2-alt2
- Enabled visibility for __gmpn_divexact, which is used in ocaml-zarith.
2017-01-12 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.1.2-alt1
- Updated to 6.1.2.
2015-12-16 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.1.0-alt1
- Updated to 6.1.0.
2015-05-08 - Gleb F-Malinovskiy <glebfm@altlinux.org> 6.0.0a-alt1
- Updated to 6.0.0a.
2013-10-02 - Dmitry V. Levin <ldv@altlinux.org> 5.1.3-alt1
- Updated to 5.1.3.
2013-07-08 - Dmitry V. Levin <ldv@altlinux.org> 5.1.2-alt2
- libgmp10 shouldn't formally obsolete older libgmp (closes: #29152).
2013-05-29 - Dmitry V. Levin <ldv@altlinux.org> 5.1.2-alt1
- Updated to 5.1.2.
2013-04-09 - Dmitry V. Levin <ldv@altlinux.org> 5.1.1-alt1
- Updated to 5.1.1.
- Dropped libmp (it has been removed in 5.1.0).
2012-06-06 - Dmitry V. Levin <ldv@altlinux.org> 5.0.5-alt2
- Renamed libgmp_cxx-devel to libgmpxx-devel.
2012-06-06 - Dmitry V. Levin <ldv@altlinux.org> 5.0.5-alt1
- Updated to 5.0.5.
- Packaged libmp.so.3 in separate libmp subpackage.
- Renamed libgmp to libgmp10.
- Renamed libgmp_cxx to libgmpxx4.

See Also

Package Description
libgmpxx-devel-static-6.1.2-alt2.i586.rpm Static C++ bindings for the GNU MP arbitrary precision arithmetic library
libgmpxx4-6.1.2-alt2.i586.rpm C++ bindings for the GNU MP arbitrary precision arithmetic library
libgmtk-1.0.7-alt1.i586.rpm a set of gtk widgets to use with gnome-mplayer
libgmtk-devel-1.0.7-alt1.i586.rpm development files for gmtk library
libgnat-devel-7-alt6.i586.rpm Dependency package for libgnat-devel
libgnat-devel-static-7-alt6.i586.rpm Dependency package for libgnat-devel-static
libgnat7-7.3.1-alt5.i586.rpm Ada 95 runtime libraries
libgnat7-devel-7.3.1-alt5.i586.rpm Header files and libraries for Ada 95 development
libgnat7-devel-static-7.3.1-alt5.i586.rpm Static libraries for Ada 95 development
libgnet-2.0.8-alt4.1.i586.rpm GNet is a simple network library
libgnet-devel-2.0.8-alt4.1.i586.rpm Header files for the Gnet library
libgnokii-0.6.31-alt1.i586.rpm Library for gnokii
libgnokii-devel-0.6.31-alt1.i586.rpm Development files for gnokii
libgnome-2.32.1-alt4.i586.rpm GNOME base library
libgnome-autoar-0.2.3-alt1.i586.rpm Automatic archives creating and extracting library
Advertisement
Advertisement