libgnutlsxx28-3.6.10-alt1.i586.rpm


Advertisement

Description

libgnutlsxx28 - Transport Layer Security C++ library

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libgnutlsxx28-3.6.10-alt1.i586.rpm
Package name libgnutlsxx28
Package version 3.6.10
Package release alt1
Package architecture i586
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 62.03 KB
Installed size 62.03 KB
GnuTLS is a project that aims to develop a library which provides a
secure  layer, over a reliable transport layer.  Currently the GnuTLS
library implements the proposed standards by the IETF's TLS working
group.
This package contains the GnuTLS C++ runtime library.

Alternatives

Package Version Architecture Repository
libgnutlsxx28-3.6.10-alt1.x86_64.rpm 3.6.10 x86_64 Classic
libgnutlsxx28 - - -

Requires

Name Value
libgcc_s.so.1(GCC_3.0) -
libgnutls30 = 3.6.10-alt1:sisyphus+238398.100.1.1
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
libgnutlsxx = 3.6.10
libgnutlsxx.so.28 -
libgnutlsxx28 = 3.6.10-alt1:sisyphus+238398.100.1.1

Obsoletes

Name Value
libgnutls-newxx < 3.6.10
libgnutlsxx < 3.6.10

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libgnutlsxx28-3.6.10-alt1.i586.rpm
Source Package gnutls30-3.6.10-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libgnutlsxx28 rpm package:
    # sudo apt-get install libgnutlsxx28

Files

Path
/usr/lib/libgnutlsxx.so.28
/usr/lib/libgnutlsxx.so.28.1.0

Changelog

2019-09-30 - Mikhail Efremov <sem@altlinux.org> 3.6.10-alt1
- Drop fix-i586-textrel patch.
- Updated to 3.6.10.
2019-08-09 - Mikhail Efremov <sem@altlinux.org> 3.6.9-alt1
- Fix LTS on 32bit architectures
- Fix TEXTREL on i586
- Updated to 3.6.9.
2019-05-28 - Mikhail Efremov <sem@altlinux.org> 3.6.8-alt1
- Drop obsoleted patch.
- Updated to 3.6.8.
2019-03-28 - Mikhail Efremov <sem@altlinux.org> 3.6.7-alt1
- Updated to 3.6.7 (fixes: CVE-2019-3836, CVE-2019-3829).
- Don't make check in parallel mode.
2019-01-25 - Mikhail Efremov <sem@altlinux.org> 3.6.6-alt1
- Updated to 3.6.6.
2018-12-25 - Ivan Zakharyaschev <imz@altlinux.org> 3.6.5-alt3
- Fixed build with lcc-1.23 (on E2K) with a gnulib patch (inspired by MCST).
2018-12-10 - Ivan Zakharyaschev <imz@altlinux.org> 3.6.5-alt2
- (.spec) Adapted %check to older build environments (useful for E2K)
or put the corresponding Buildrequires (on the new version of utils).
2018-12-06 - Mikhail Efremov <sem@altlinux.org> 3.6.5-alt1
- Updated to 3.6.5 (fixes: CVE-2018-16868).
2018-09-26 - Mikhail Efremov <sem@altlinux.org> 3.6.4-alt1
- tests: Use IPv4 only in s_server.
- Drop test-hash-large.patch.
- Updated to 3.6.4 (closes: #35414).
2018-07-16 - Mikhail Efremov <sem@altlinux.org> 3.5.19-alt1
- Use %e2k macro.
- Updated to 3.5.19.

See Also

Package Description
libgo0-4.7.2-alt13.i586.rpm Go runtime libraries
libgo11-7.3.1-alt9.i586.rpm Go runtime libraries
libgo13-8.3.1-alt7.i586.rpm Go runtime libraries
libgo14-9.2.1-alt1.i586.rpm Go runtime libraries
libgo4.7-devel-4.7.2-alt13.i586.rpm Header files and libraries for Go development
libgo4.7-devel-static-4.7.2-alt13.i586.rpm Static libraries for Go development
libgo7-devel-7.3.1-alt9.i586.rpm Header files and libraries for Go development
libgo7-devel-static-7.3.1-alt9.i586.rpm Static libraries for Go development
libgo8-devel-8.3.1-alt7.i586.rpm Header files and libraries for Go development
libgo8-devel-static-8.3.1-alt7.i586.rpm Static libraries for Go development
libgo9-devel-9.2.1-alt1.i586.rpm Header files and libraries for Go development
libgo9-devel-static-9.2.1-alt1.i586.rpm Static libraries for Go development
libgom-0.3.3-alt1.i586.rpm A GObject to SQLite object mapper
libgom-devel-0.3.3-alt1.i586.rpm Development files for libgom
libgom-gir-0.3.3-alt1.i586.rpm GObject introspection data for the libgom
Advertisement
Advertisement