libgtk+2-2.24.32-alt2.i586.rpm


Advertisement

Description

libgtk+2 - The GIMP ToolKit (GTK+), a library for creating GUIs

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package name libgtk+2
Package version 2.24.32
Package release alt2
Package architecture i586
Package type rpm
Installed size 6.08 MB
Download size 6.08 MB
Official Mirror ftp.altlinux.org
GTK+ is a multi-platform toolkit for creating graphical user interfaces.
Offering a complete set of widgets, GTK+ is suitable for projects
ranging from small one-off projects to complete application suites.

Alternatives

Package Version Architecture Repository
libgtk+2-2.24.32-alt2.x86_64.rpm 2.24.32 x86_64 Classic
libgtk+2 - - -

Requires

Name Value
/lib/ld-linux.so.2 -
grep -
gtk-update-icon-cache -
icon-theme-hicolor -
libX11.so.6 -
libXcomposite.so.1 -
libXcursor.so.1 -
libXdamage.so.1 -
libXext.so.6 -
libXfixes.so.3 -
libXi.so.6 -
libXinerama.so.1 -
libXrandr.so.2 -
libXrender.so.1 -
libatk-1.0.so.0 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libcairo.so.2 -
libcups.so.2 -
libfontconfig.so.1 -
libgdk_pixbuf-2.0.so.0 -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgmodule-2.0.so.0 -
libgobject-2.0.so.0 -
libgtk+2-locales = 2.24.32-alt2
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libpango-1.0.so.0 -
libpangocairo-1.0.so.0 -
libpangoft2-1.0.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
rpmlib(PayloadIsLzma) -
rpmlib(PosttransFiletriggers) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
gtk+2 = 2.24.32
gtk-engines-pixmap = 2.24.32
gtk2 = 2.24.32
libgdk-x11-2.0.so.0 -
libgdk-x11-2.0.so.0(GDK_2.10) -
libgdk-x11-2.0.so.0(GDK_2.12) -
libgdk-x11-2.0.so.0(GDK_2.14) -
libgdk-x11-2.0.so.0(GDK_2.15) -
libgdk-x11-2.0.so.0(GDK_2.17.11) -
libgdk-x11-2.0.so.0(GDK_2.21.8) -
libgdk-x11-2.0.so.0(GDK_2.8) -
libgdk-x11-2.0.so.0(GDK_PRIVATE) -
libgtk+2 = 2.24.32-alt2
libgtk+2-common = 2.24.32
libgtk-x11-2.0.so.0 -
libgtk-x11-2.0.so.0(GTK_2.10) -
libgtk-x11-2.0.so.0(GTK_2.12) -
libgtk-x11-2.0.so.0(GTK_2.14) -
libgtk-x11-2.0.so.0(GTK_2.15.0) -
libgtk-x11-2.0.so.0(GTK_2.15.1) -
libgtk-x11-2.0.so.0(GTK_2.15.2) -
libgtk-x11-2.0.so.0(GTK_2.15.5) -
libgtk-x11-2.0.so.0(GTK_2.16.0) -
libgtk-x11-2.0.so.0(GTK_2.17.11) -
libgtk-x11-2.0.so.0(GTK_2.17.6) -
libgtk-x11-2.0.so.0(GTK_2.19.5) -
libgtk-x11-2.0.so.0(GTK_2.21.8) -
libgtk-x11-2.0.so.0(GTK_2.8) -
libgtk2 = 2.24.32

Obsoletes

Name Value
gtk+2 < 2.24.32
gtk-engines-pixmap < 2.24.32
gtk2 < 2.24.32
libgtk+2-common <= 2.24.32
libgtk2 < 2.24.32

Download

Type URL
Binary Package libgtk+2-2.24.32-alt2.i586.rpm
Source Package libgtk+2-2.24.32-alt2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libgtk+2 rpm package:
    # sudo apt-get install libgtk+2

Files

Path
/etc/gtk-2.0/gtkrc
/etc/gtk-2.0/im-multipress.conf
/usr/bin/gtk-query-immodules-2.0
/usr/lib/libgdk-x11-2.0.so.0
/usr/lib/libgdk-x11-2.0.so.0.2400.32
/usr/lib/libgtk-x11-2.0.so.0
/usr/lib/libgtk-x11-2.0.so.0.2400.32
/usr/lib/gtk-2.0/modules
/usr/lib/gtk-2.0/2.10.0/immodules.cache
/usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so
/usr/lib/gtk-2.0/2.10.0/immodules/im-am-et.so
/usr/lib/gtk-2.0/2.10.0/immodules/im-cedilla.so
/usr/lib/gtk-2.0/2.10.0/immodules/im-cyrillic-translit.so
/usr/lib/gtk-2.0/2.10.0/immodules/im-inuktitut.so
/usr/lib/gtk-2.0/2.10.0/immodules/im-ipa.so
/usr/lib/gtk-2.0/2.10.0/immodules/im-multipress.so
/usr/lib/gtk-2.0/2.10.0/immodules/im-thai.so
/usr/lib/gtk-2.0/2.10.0/immodules/im-ti-er.so
/usr/lib/gtk-2.0/2.10.0/immodules/im-ti-et.so
/usr/lib/gtk-2.0/2.10.0/immodules/im-viqr.so
/usr/lib/gtk-2.0/2.10.0/immodules/im-xim.so
/usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-cups.so
/usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-file.so
/usr/lib/gtk-2.0/2.10.0/printbackends/libprintbackend-lpr.so
/usr/lib/rpm/gtk-2.0-immodules-cache.filetrigger
/usr/share/gtk-2.0
/usr/share/doc/libgtk+2-2.24.32/AUTHORS
/usr/share/doc/libgtk+2-2.24.32/NEWS.bz2
/usr/share/doc/libgtk+2-2.24.32/README
/usr/share/man/man1/gtk-query-immodules-2.0.1.xz
/usr/share/themes/
/usr/share/themes/Default/
/usr/share/themes/Default/gtk-2.0-key/gtkrc
/usr/share/themes/Emacs/
/usr/share/themes/Emacs/gtk-2.0-key/gtkrc
/usr/share/themes/Raleigh/
/usr/share/themes/Raleigh/gtk-2.0/gtkrc

Changelog

2018-02-15 - Yuri N. Sedunov <aris@altlinux.org> 2.24.32-alt2
- moved gtk-update-icon-cache subpackage to gtk+3
2018-01-09 - Yuri N. Sedunov <aris@altlinux.org> 2.24.32-alt1
- 2.24.32
2016-09-07 - Yuri N. Sedunov <aris@altlinux.org> 2.24.31-alt1
- 2.24.31 (CVE-2013-7447)
2016-03-08 - Yuri N. Sedunov <aris@altlinux.org> 2.24.30-alt1
- 2.24.30
2015-12-16 - Yuri N. Sedunov <aris@altlinux.org> 2.24.29-alt1
- 2.24.29
2015-05-13 - Yuri N. Sedunov <aris@altlinux.org> 2.24.28-alt1
- 2.24.28
2015-03-03 - Yuri N. Sedunov <aris@altlinux.org> 2.24.27-alt1
- 2.24.27
2015-02-16 - Yuri N. Sedunov <aris@altlinux.org> 2.24.26-alt1
- 2.24.26
2014-10-10 - Yuri N. Sedunov <aris@altlinux.org> 2.24.25-alt1
- 2.24.25
2014-06-24 - Yuri N. Sedunov <aris@altlinux.org> 2.24.24-alt1
- 2.24.24

See Also

Package Description
libgtk+2-devel-2.24.32-alt2.i586.rpm Development files and tools for GTK+ applications
libgtk+2-gir-2.24.32-alt2.i586.rpm GObject introspection data for the GTK+ library
libgtk+3-3.22.30-alt3.i586.rpm The GIMP ToolKit (GTK+)
libgtk+3-devel-3.22.30-alt3.i586.rpm Development files and tools for GTK+ applications
libgtk+3-gir-3.22.30-alt3.i586.rpm GObject introspection data for the GTK+ library
libgtk+3-tests-3.22.30-alt3.i586.rpm Tests for the GTK+3 packages
libgtk+4-3.94.0-alt1.i586.rpm The GIMP ToolKit (GTK+)
libgtk+4-devel-3.94.0-alt1.i586.rpm Development files and tools for GTK+ applications
libgtk+4-gir-3.94.0-alt1.i586.rpm GObject introspection data for the GTK+ library
libgtk+4-tests-3.94.0-alt1.i586.rpm Tests for the GTK+3 packages
libgtk+extra2-2.1.2-alt3.i586.rpm GtkExtra Widget Set
libgtk+extra2-devel-2.1.2-alt3.i586.rpm GtkExtra Widget Set header files
libgtk-engine-anachron-0.1-alt1.qa1.i586.rpm Anachron GTK2 engine
libgtk-engine-aurora-1.5.1-alt1.2.i586.rpm Aurora GTK2 engine
libgtk-engine-candido-0.9.1-alt1.1.i586.rpm Candido GTK2 engine
Advertisement
Advertisement