libltdl3-devel-1.5.26-alt12.i586.rpm


Advertisement

Description

libltdl3-devel - Development files for libltdl3

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libltdl3-devel-1.5.26-alt12.i586.rpm
Package name libltdl3-devel
Package version 1.5.26
Package release alt12
Package architecture i586
Package type rpm
Category Development/C
Homepage -
License -
Maintainer -
Download size 24.69 KB
Installed size 24.69 KB
Development files for libltdl, a system independent
dlopen wrapper for GNU libtool.

Alternatives

Package Version Architecture Repository
libltdl3-devel-1.5.26-alt12.x86_64.rpm 1.5.26 x86_64 Classic
libltdl3-devel - - -

Requires

Name Value
libltdl3 = 3:1.5.26-alt12
libtool_1.5 = 3:1.5.26-alt12
rpmlib(PayloadIsLzma) -

Provides

Name Value
libltdl-devel = 3:1.5.26-alt12
libltdl3-devel = 3:1.5.26-alt12

Conflicts

Name Value
libltdl7-devel -

Obsoletes

Name Value
libltdl-devel < 3:1.5.26-alt12

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libltdl3-devel-1.5.26-alt12.i586.rpm
Source Package libtool_1.5-1.5.26-alt12.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libltdl3-devel rpm package:
    # sudo apt-get install libltdl3-devel

Files

Path
/usr/include/ltdl.h
/usr/lib/libltdl.so
/usr/share/aclocal/ltdl.m4

Changelog

2018-08-04 - Dmitry V. Levin <ldv@altlinux.org> 3:1.5.26-alt12
- Dropped alternatives in favour of libtool-defaults setup.
2015-12-14 - Dmitry V. Levin <ldv@altlinux.org> 3:1.5.26-alt11
- Changed compress method to xz.
2012-09-06 - Dmitry V. Levin <ldv@altlinux.org> 3:1.5.26-alt10
- Fixed libltdl3-devel interpackage requirements.
2010-11-12 - Dmitry V. Levin <ldv@altlinux.org> 3:1.5.26-alt9
- Rebuilt for soname set-versions.
2009-11-30 - Dmitry V. Levin <ldv@altlinux.org> 3:1.5.26-alt8
- Applied upstream's backport of libltdl changes from the 2.26b
release (fixes CVE-2009-3736).
2009-09-09 - Dmitry V. Levin <ldv@altlinux.org> 3:1.5.26-alt7
- Moved "make check" to %check section.
2009-05-19 - Dmitry V. Levin <ldv@altlinux.org> 3:1.5.26-alt6
- Removed obsolete %install_info/%uninstall_info calls.
2009-04-28 - Dmitry V. Levin <ldv@altlinux.org> 3:1.5.26-alt5
- Changed for better co-existence with libtool-2.2.x.
2008-11-21 - Dmitry V. Levin <ldv@altlinux.org> 3:1.5.26-alt4
- Switched to alternatives-0.4.
- Removed obsolete %post_ldconfig/%postun_ldconfig call.
- Packaged -demos subpackage as noarch.

See Also

Package Description
libltdl3-devel-static-1.5.26-alt12.i586.rpm Static libltdl3 library
libltdl7-2.4.6-alt1.i586.rpm dlopen wrapper for GNU libtool
libltdl7-devel-2.4.6-alt1.i586.rpm Development files for libltdl7
libltdl7-devel-static-2.4.6-alt1.i586.rpm Static libltdl7 library
liblttng-ust-2.10.4-alt1.i586.rpm Linux Trace Toolkit Userspace Tracer library
liblttng-ust-devel-2.10.4-alt1.i586.rpm Linux Trace Toolkit Userspace Tracer library
liblttng-ust-docs-2.10.4-alt1.i586.rpm Linux Trace Toolkit Userspace Tracer Documentation
liblua5.1-5.1.5-alt15.i586.rpm Embeddable programming language
liblua5.1-compat-devel-5.1.5-alt15.i586.rpm Embeddable programming language
liblua5.1-devel-5.1.5-alt15.i586.rpm Embeddable programming language
liblua5.1-devel-static-5.1.5-alt15.i586.rpm Embeddable programming language
liblua5.1-preinstall-5.1.5-alt15.i586.rpm preinstall package for liblua5.1
liblua5.3-5.3.5-alt2.i586.rpm Libraries for lua
liblua5.3-devel-5.3.5-alt2.i586.rpm Development files for lua
liblua5.3-devel-static-5.3.5-alt2.i586.rpm Static library for lua
Advertisement
Advertisement