liblucene++-3.0.7-alt5.i586.rpm


Advertisement

Description

liblucene++ - A high-performance, full-featured text search engine written in C++

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package name liblucene++
Package version 3.0.7
Package release alt5
Package architecture i586
Package type rpm
Installed size 9.74 MB
Download size 9.74 MB
Official Mirror ftp.altlinux.org
An up to date C++ port of the popular Java Lucene library,
a high-performance, full-featured text search engine.

Alternatives

Package Version Architecture Repository
liblucene++-3.0.7-alt5.x86_64.rpm 3.0.7 x86_64 Classic
liblucene++ - - -

Requires

Name Value
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
libboost_filesystem.so.1.67.0 -
libboost_iostreams.so.1.67.0 -
libboost_regex.so.1.67.0 -
libboost_system.so.1.67.0 -
libboost_thread.so.1.67.0 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.17) -
libc.so.6(GLIBC_2.3.2) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.8) -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_7.0.0) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.3.2) -
libpthread.so.0(GLIBC_2.3.3) -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -
rtld(GNU_UNIQUE) -

Provides

Name Value
liblucene++ = 3.0.7-alt5
liblucene++-contrib.so.0 -
liblucene++.so.0 -

Download

Type URL
Binary Package liblucene++-3.0.7-alt5.i586.rpm
Source Package liblucene++-3.0.7-alt5.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install liblucene++ rpm package:
    # sudo apt-get install liblucene++

Files

Path
/usr/lib/liblucene++-contrib.so.0
/usr/lib/liblucene++-contrib.so.3.0.7
/usr/lib/liblucene++.so.0
/usr/lib/liblucene++.so.3.0.7
/usr/share/doc/liblucene++-3.0.7/AUTHORS
/usr/share/doc/liblucene++-3.0.7/COPYING
/usr/share/doc/liblucene++-3.0.7/README.PACKAGE
/usr/share/doc/liblucene++-3.0.7/README.rst
/usr/share/doc/liblucene++-3.0.7/REQUESTS

Changelog

2018-06-01 - Yuri N. Sedunov <aris@altlinux.org> 3.0.7-alt5
- rebuilt with boost-1.67
2018-04-18 - Yuri N. Sedunov <aris@altlinux.org> 3.0.7-alt4
- rebuilt with boost-1.66
2017-09-13 - Yuri N. Sedunov <aris@altlinux.org> 3.0.7-alt3
- rebuilt with boost-1.65
2017-01-17 - Yuri N. Sedunov <aris@altlinux.org> 3.0.7-alt2
- updated to 3.0.7-7-gcf9b9d9
2015-08-06 - Yuri N. Sedunov <aris@altlinux.org> 3.0.7-alt1
- first build for Sisyphus

See Also

Package Description
liblucene++-devel-3.0.7-alt5.i586.rpm Development files for lucene++
liblur-0.9.901-alt0.2.i586.rpm Logitech Unifying Receiver library
liblur-devel-0.9.901-alt0.2.i586.rpm Development files for liblur
liblvm2-2.02.181-alt1.i586.rpm LVM2 shared libraries
liblvm2-devel-2.02.181-alt1.i586.rpm LVM2 development libraries and headers
liblwp-2.6-alt1_16.i586.rpm C library for user-mode threading
liblwp-devel-2.6-alt1_16.i586.rpm Development files for lwp
liblxqt-0.13.0-alt1.1.i586.rpm Core utility library for LXDE-Qt components
liblxqt-devel-0.13.0-alt1.1.i586.rpm Development headers for LXQt library
liblz4-1.8.2-alt2.i586.rpm Fast LZ compression algorithm shared library
liblz4-devel-1.8.2-alt2.i586.rpm Fast LZ compression algorithm development files
liblzf-3.6-alt2_14.i586.rpm Small data compression library
liblzf-devel-3.6-alt2_14.i586.rpm Development files for liblzf
liblzma-5.2.3-alt2.i586.rpm LZMA/XZ compression library
liblzma-devel-5.2.3-alt2.i586.rpm API headers and other development files related to liblzma
Advertisement
Advertisement