libmp4v2-3-2.0-alt4.i586.rpm


Advertisement

Description

libmp4v2-3 - This library provides functions to read, create, and modify mp4 files

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libmp4v2-3-2.0-alt4.i586.rpm
Package name libmp4v2-3
Package version 2.0
Package release alt4
Package architecture i586
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 1.44 MB
Installed size 1.44 MB
The MP4v2 library provides an API to create and modify mp4 files
as defined by ISO-IEC:14496-1:2001 MPEG-4 Systems.
This file format is derived from Apple's QuickTime file format
that has been used as a multimedia file format in a variety of platforms and applications.
It is a very powerful and extensible format that can accommodate practically any type of media.
MP4v2 was originally bundled with mpeg4ip library, but has been moved into its own maintained library
due to a combination of the cessation of support of mpeg4ip and the usefulness of this library on its own.

Alternatives

Package Version Architecture Repository
libmp4v2-3-2.0-alt4.x86_64.rpm 2.0 x86_64 Classic
libmp4v2-3 - - -

Requires

Name Value
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6(GLIBC_2.0) -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.20) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.9) -
rpmlib(PayloadIsLzma) -
rtld(GNU_HASH) -

Provides

Name Value
libmp4v2-3 = 2.0-alt4
libmp4v2.so.2 -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libmp4v2-3-2.0-alt4.i586.rpm
Source Package libmp4v2-3-2.0-alt4.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libmp4v2-3 rpm package:
    # sudo apt-get install libmp4v2-3

Files

Path
/usr/lib/libmp4v2.so.2
/usr/lib/libmp4v2.so.2.1.0
/usr/share/doc/libmp4v2-3-2.0/COPYING

Changelog

2018-09-17 - Aleksei Nikiforov <darktemplar@altlinux.org> 2.0-alt4
- Fixed build.
2018-01-09 - Aleksei Nikiforov <darktemplar@altlinux.org> 2.0-alt3
- Fixed build.
2016-01-01 - Terechkov Evgenii <evg@altlinux.org> 2.0-alt2
- Fix FTBFS
2015-09-05 - Terechkov Evgenii <evg@altlinux.org> 2.0-alt1
- 2.0 (upstream git commit cc17ffe)
- Packet renamed to libmp4v2-3
2015-09-05 - Terechkov Evgenii <evg@altlinux.org> 1.9.1-alt2
- Rebuilt as compat package without subpackages (devel,utils)
2012-12-06 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 1.9.1-alt1.1
- Fixed build
2011-01-17 - Alexey Shabalin <shaba@altlinux.ru> 1.9.1-alt1
- initial build for ALT Linux Sisyphus

See Also

Package Description
libmp4v2-devel-2.0-alt4.i586.rpm Development files for the mp4v2 library
libmpack-1.0.5-alt1.i586.rpm small binary serialization/RPC library
libmpack-devel-1.0.5-alt1.i586.rpm Devel package for libmpack
libmpb-1.5-alt3.i586.rpm Shared libraries of MIT Photonic Bands (MPB)
libmpb-devel-1.5-alt3.i586.rpm Development files of MIT Photonic Bands (MPB)
libmpc-devel-1.1.0-alt1.i586.rpm Header files for the GNU MPC library
libmpc3-1.1.0-alt1.i586.rpm C library for multiple precision complex arithmetic
libmpcdec-1.2.2-alt2.1.qa1.i586.rpm Portable Musepack decoder library
libmpcdec-devel-1.2.6-alt4.i586.rpm Development part of libmpcdec5
libmpcdec0-devel-r475-alt2.i586.rpm Development files of libmpcdec
libmpcdec0-r475-alt2.i586.rpm Library that decodes musepack compressed audio data
libmpcdec5-1.2.6-alt4.i586.rpm Portable Musepack decoder library
libmpd-devel-11.8.17-alt1_9.i586.rpm Header files for developing programs with libmpd
libmpd1-11.8.17-alt1_9.i586.rpm Music Player Daemon Library
libmpdclient-2.15-alt1.i586.rpm MPD client library
Advertisement
Advertisement