libnDPI-devel-2.2-alt1.i586.rpm


Advertisement

Description

libnDPI-devel - Header files and libraries for developing applications for nDPI

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package name libnDPI-devel
Package version 2.2
Package release alt1
Package architecture i586
Package type rpm
Installed size 157.66 KB
Download size 157.66 KB
Official Mirror ftp.altlinux.org
These are the header files and libraries for developing applications for nDPI.

Alternatives

Package Version Architecture Repository
libnDPI-devel-2.2-alt1.x86_64.rpm 2.2 x86_64 Classic
libnDPI-devel - - -

Requires

Name Value
/usr/lib/pkgconfig -
libnDPI = 2.2-alt1
rpmlib(PayloadIsLzma) -

Provides

Name Value
libnDPI-devel = 2.2-alt1
pkgconfig(libndpi) = 2.2.0

Download

Type URL
Binary Package libnDPI-devel-2.2-alt1.i586.rpm
Source Package nDPI-2.2-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libnDPI-devel rpm package:
    # sudo apt-get install libnDPI-devel

Files

Path
/usr/include/libndpi/ndpi_api.h
/usr/include/libndpi/ndpi_define.h
/usr/include/libndpi/ndpi_includes.h
/usr/include/libndpi/ndpi_main.h
/usr/include/libndpi/ndpi_protocol_ids.h
/usr/include/libndpi/ndpi_protocols.h
/usr/include/libndpi/ndpi_typedefs.h
/usr/lib/libndpi.so
/usr/lib/pkgconfig/libndpi.pc
/usr/share/doc/libnDPI-devel-2.2/CHANGELOG.md
/usr/share/doc/libnDPI-devel-2.2/COPYING
/usr/share/doc/libnDPI-devel-2.2/INSTALL
/usr/share/doc/libnDPI-devel-2.2/README.md
/usr/share/doc/libnDPI-devel-2.2/README.nDPI
/usr/share/doc/libnDPI-devel-2.2/README.protocols

Changelog

2017-12-04 - Alexei Takaseev <taf@altlinux.org> 2.2-alt1
- 2.2
2017-02-15 - Alexei Takaseev <taf@altlinux.org> 1.8.0-alt1
- 1.8.0
2016-11-11 - Alexei Takaseev <taf@altlinux.org> 1.7.0-alt6
- Re-merge with 1.7-stable, drop i586 compatable patches
2016-08-03 - Alexei Takaseev <taf@altlinux.org> 1.7.0-alt5
- Revert "Fix detect http/https"
2016-03-15 - Alexei Takaseev <taf@altlinux.org> 1.7.0-alt4
- Add missing include file
2016-03-15 - Alexei Takaseev <taf@altlinux.org> 1.7.0-alt3
- Fix detect http/https
2016-02-18 - Alexei Takaseev <taf@altlinux.org> 1.7.0-alt2
- Fix memory allocator type compatible with C++ on x686 platforms.
- Fix detect ssl on ipv6
- Fix detect ssl as tor.
2015-09-30 - Alexei Takaseev <taf@altlinux.org> 1.7.0-alt1
- Initial build for ALT

See Also

Package Description
libnanomsg-1.1.5-alt1.i586.rpm nanomsg is a socket library that provides several common communication patterns
libnanomsg-devel-1.1.5-alt1.i586.rpm Development files for libnanomsg
libnatpmp-20150609-alt1_1.i586.rpm Direct concurrent to the UPnP IGD specification
libnatpmp-devel-20150609-alt1_1.i586.rpm Header files, libraries and development documentation for libnatpmp
libnatpmp1-20150609-alt1_1.i586.rpm Direct concurrent to the UPnP IGD specification
libnatspec-0.3.1-alt2.i586.rpm Library for national and language-specific issues
libnatspec-devel-0.3.1-alt2.i586.rpm Development package of library for national and language-specific issues
libnautilus-3.30.3-alt1.i586.rpm Shared libraries needed to run Nautilus
libnautilus-devel-3.30.3-alt1.i586.rpm Libraries and include files for developing Nautilus components
libnautilus-gir-3.30.3-alt1.i586.rpm GObject introspection data for the nautilus-extension library
libncp-2.2.6-alt9.qa2.i586.rpm Shared library for access the ncpfs filesystem
libncp-devel-2.2.6-alt9.qa2.i586.rpm Development environmnt for the ncpfs filesystem
libncurses++-6.1.20180407-alt2.i586.rpm C++ interface to libncurses
libncurses++-devel-6.1.20180407-alt2.i586.rpm Development files for applications which use libncurses++
libncurses++-devel-static-6.1.20180407-alt2.i586.rpm Development static libncurses++ library
Advertisement
Advertisement