libncursesxx-0.0.1-alt17.i586.rpm


Advertisement

Description

libncursesxx - C++ bindings for ncurses library

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libncursesxx-0.0.1-alt17.i586.rpm
Package name libncursesxx
Package version 0.0.1
Package release alt17
Package architecture i586
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 47.23 KB
Installed size 47.23 KB
C++ bindings for ncurses library

Alternatives

Package Version Architecture Repository
libncursesxx-0.0.1-alt17.x86_64.rpm 0.0.1 x86_64 Classic
libncursesxx - - -

Requires

Name Value
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libgcc_s.so.1(GCC_3.0) -
libpanel.so.5 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.9) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -
rtld(GNU_UNIQUE) -

Provides

Name Value
libncursesxx = 0.0.1-alt17
libncursesxx.so.1 -

Conflicts

Name Value
libcolorifer <= 1.0.1-alt7

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libncursesxx-0.0.1-alt17.i586.rpm
Source Package libncursesxx-0.0.1-alt17.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libncursesxx rpm package:
    # sudo apt-get install libncursesxx

Files

Path
/usr/lib/libncursesxx.so.0.0.1beta4
/usr/lib/libncursesxx.so.1
/usr/share/doc/libncursesxx-0.0.1/ChangeLog

Changelog

2012-10-16 - Denis Smirnov <mithraen@altlinux.ru> 0.0.1-alt17
- fix build with gcc 4.7 (Ivan A. Melnikov)
- re-enable build with -pedantic
2012-10-16 - Denis Smirnov <mithraen@altlinux.ru> 0.0.1-alt16
- fix build (disable -pedantic)
2012-05-22 - Denis Smirnov <mithraen@altlinux.ru> 0.0.1-alt15
- fix build
2010-10-24 - Denis Smirnov <mithraen@altlinux.ru> 0.0.1-alt14
- rebuild
2009-10-27 - Denis Smirnov <mithraen@altlinux.ru> 0.0.1-alt13
- add Url tag
2008-12-03 - Denis Smirnov <mithraen@altlinux.ru> 0.0.1-alt12
- fixed build

See Also

Package Description
libncursesxx-devel-0.0.1-alt17.i586.rpm Development part of libncursesxx
libncursesxx-devel-static-0.0.1-alt17.i586.rpm Static libraries for libncursesxx
libndctl-66-alt1.i586.rpm Management library for "libnvdimm" subsystem devices (Non-volatile Memory)
libndctl-devel-66-alt1.i586.rpm Development files for libndctl
libndp-1.7-alt1.i586.rpm Library for Neighbor Discovery Protocol
libndp-devel-1.7-alt1.i586.rpm Development files for libndp
libndp-utils-1.7-alt1.i586.rpm Utils for libndp
libneXtaw-0.15.1-alt8.i586.rpm Modified version of the Athena Widgets with N*XTSTEP appearance
libneXtaw-devel-0.15.1-alt8.i586.rpm Header files for neXtaw library
libneko-2.2.0-alt4.gitb68336c.i586.rpm The Neko Programming Language
libneko-devel-2.2.0-alt4.gitb68336c.i586.rpm The Neko Programming Language
libnemesi-0.7.0-alt3_0.5.20110215git.i586.rpm RTSP/RTP client library
libnemesi-devel-0.7.0-alt3_0.5.20110215git.i586.rpm Nemesi development library and headers
libnemesi-tools-0.7.0-alt3_0.5.20110215git.i586.rpm Simple dump/info programs that use libnemesi
libnemo-4.2.3-alt1.i586.rpm Shared libraries needed to run Nemo
Advertisement
Advertisement