libopensc-0.19.0-alt3.i586.rpm


Advertisement

Description

libopensc - OpenSC library - for accessing SmartCard devices using PC/SC Lite

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libopensc-0.19.0-alt3.i586.rpm
Package name libopensc
Package version 0.19.0
Package release alt3
Package architecture i586
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 2.69 MB
Installed size 2.69 MB
libopensc is a library for accessing SmartCard devices using PC/SC
Lite middleware package. It is also the core library of the OpenSC
project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
using private keys on the SmartCard is at the moment possible only
with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
IDentity) card manufactured by Setec.

Alternatives

Package Version Architecture Repository
libopensc-0.19.0-alt3.x86_64.rpm 0.19.0 x86_64 Classic
libopensc - - -

Requires

Name Value
libc.so.6(ALT_2.24) -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libcrypto.so.1.1 -
libcrypto.so.1.1(OPENSSL_1_1_0) -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.0) -
libz.so.1 -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
libopensc = 0.19.0-alt3:sisyphus+222960.100.1.2
libopensc.so.6 -
libsmm-local.so.6 -
onepin-opensc-pkcs11.so -
opensc-pkcs11.so -
pkcs11-spy.so -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libopensc-0.19.0-alt3.i586.rpm
Source Package opensc-0.19.0-alt3.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libopensc rpm package:
    # sudo apt-get install libopensc

Files

Path
/etc/opensc.conf
/usr/lib/libopensc.so.6
/usr/lib/libopensc.so.6.0.0
/usr/lib/libsmm-local.so.6
/usr/lib/libsmm-local.so.6.0.0
/usr/lib/onepin-opensc-pkcs11.so
/usr/lib/opensc-pkcs11.so
/usr/lib/pkcs11-spy.so
/usr/lib/pkcs11/onepin-opensc-pkcs11.so
/usr/lib/pkcs11/opensc-pkcs11.so
/usr/lib/pkcs11/pkcs11-spy.so
/usr/share/opensc/asepcos.profile
/usr/share/opensc/authentic.profile
/usr/share/opensc/cardos.profile
/usr/share/opensc/cyberflex.profile
/usr/share/opensc/entersafe.profile
/usr/share/opensc/epass2003.profile
/usr/share/opensc/flex.profile
/usr/share/opensc/gids.profile
/usr/share/opensc/gpk.profile
/usr/share/opensc/ias_adele_admin1.profile
/usr/share/opensc/ias_adele_admin2.profile
/usr/share/opensc/ias_adele_common.profile
/usr/share/opensc/iasecc.profile
/usr/share/opensc/iasecc_admin_eid.profile
/usr/share/opensc/iasecc_generic_oberthur.profile
/usr/share/opensc/iasecc_generic_pki.profile
/usr/share/opensc/incrypto34.profile
/usr/share/opensc/isoApplet.profile
/usr/share/opensc/jcop.profile
/usr/share/opensc/miocos.profile
/usr/share/opensc/muscle.profile
/usr/share/opensc/myeid.profile
/usr/share/opensc/oberthur.profile
/usr/share/opensc/openpgp.profile
/usr/share/opensc/pkcs15.profile
/usr/share/opensc/rutoken.profile
/usr/share/opensc/rutoken_ecp.profile
/usr/share/opensc/sc-hsm.profile
/usr/share/opensc/setcos.profile
/usr/share/opensc/starcos.profile
/usr/share/opensc/westcos.profile

Changelog

2018-12-10 - Paul Wolneykien <manowar@altlinux.org> 0.19.0-alt3
- New release version 0.19.0.
2018-09-14 - Paul Wolneykien <manowar@altlinux.org> 0.19.0-alt2.rc1
- Workaround format-truncation error in card-gids.c using a larger
buffer (patch).
2018-09-13 - Paul Wolneykien <manowar@altlinux.org> 0.19.0-alt1.rc1
- New pre-release version 0.19.0-rc1.
- Fixed multiple security problems due to out of bound writes/reads
(Fixes: CVE-2018-16391, CVE-2018-16392, CVE-2018-16393, CVE-2018-16418,
CVE-2018-16419, CVE-2018-16420, CVE-2018-16421, CVE-2018-16422,
CVE-2018-16423, CVE-2018-16424, CVE-2018-16425, CVE-2018-16426,
CVE-2018-16427).
2018-08-29 - Grigory Ustinov <grenka@altlinux.org> 0.17.0-alt1.1
- NMU: Rebuild with new openssl 1.1.0.
2018-06-08 - Paul Wolneykien <manowar@altlinux.org> 0.18.0-alt1
- Freshed up to the upstream version 0.18.0.
- New opensc-notify desktop util.
2017-09-12 - Paul Wolneykien <manowar@altlinux.org> 0.17.0-alt1
- Fresh up to v0.17.0.
2017-06-26 - Paul Wolneykien <manowar@altlinux.org> 0.17.0-alt0.rc1
- Remove the usused patches.
- Fresh up to v0.17.0-rc1.
2016-11-09 - Dmitry Derjavin <dd@altlinux.org> 0.16.0-alt3
- opensc.conf moved to library package
- (closes: 32735)
2016-10-13 - Dmitry Derjavin <dd@altlinux.org> 0.16.0-alt2
- Reqs and configure params cleanup.
2016-10-12 - Dmitry Derjavin <dd@altlinux.org> 0.16.0-alt1
- 0.16.0

See Also

Package Description
libopensc-devel-0.19.0-alt3.i586.rpm OpenSC development files
libopenscada-0.9.0-alt5.i586.rpm Open SCADA development
libopenshot-0.2.2-alt1.i586.rpm OpenShot Video Library
libopenshot-audio-0.1.7-alt1.i586.rpm OpenShot Audio Library
libopenshot-audio-devel-0.1.7-alt1.i586.rpm OpenShot Audio Library development package
libopenshot-devel-0.2.2-alt1.i586.rpm OpenShot Video Library development package
libopenslide-3.4.1-alt1.i586.rpm Shared library for openslide
libopenslide-devel-3.4.1-alt1.i586.rpm Development files for openslide
libopenslp-2.0.0-alt2.i586.rpm openslp project libraries
libopenslp-devel-2.0.0-alt2.i586.rpm openslp project development headers
libopensm-3.3.21-alt1.i586.rpm Libraries from the opensm package
libopensm-devel-3.3.21-alt1.i586.rpm Development files for OpenSM
liboping-1.6.2-alt2.i586.rpm Liboping library
liboping-devel-1.6.2-alt2.i586.rpm Header files for liboping library
libopm-0.1-alt3_21.20050731cvs.i586.rpm Blitzed open proxy monitor library
Advertisement
Advertisement