libopensc4-0.16.0.0.git0362439-alt4.i586.rpm


Advertisement

Description

libopensc4 - OpenSC library - for accessing SmartCard devices using PC/SC Lite (compat version)

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libopensc4-0.16.0.0.git0362439-alt4.i586.rpm
Package name libopensc4
Package version 0.16.0.0.git0362439
Package release alt4
Package architecture i586
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 1.96 MB
Installed size 1.96 MB
libopensc is a library for accessing SmartCard devices using PC/SC
Lite middleware package. It is also the core library of the OpenSC
project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
using private keys on the SmartCard is at the moment possible only
with PKCS#15 compatible cards, such as the FINEID (Finnish Electronic
IDentity) card manufactured by Setec.

Alternatives

Package Version Architecture Repository
libopensc4-0.16.0.0.git0362439-alt4.x86_64.rpm 0.16.0.0.git0362439 x86_64 Classic
libopensc4 - - -

Requires

Name Value
libc.so.6(ALT_2.24) -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libcrypto.so.1.1 -
libcrypto.so.1.1(OPENSSL_1_1_0) -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.0) -
libz.so.1 -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
libopensc.so.4 -
libopensc4 = 0.16.0.0.git0362439-alt4:sisyphus+236063.100.1.1
libsmm-local.so.4 -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libopensc4-0.16.0.0.git0362439-alt4.i586.rpm
Source Package opensc-compat-0.16.0.0.git0362439-alt4.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libopensc4 rpm package:
    # sudo apt-get install libopensc4

Files

Path
/usr/lib/libopensc.so.4
/usr/lib/libopensc.so.4.0.0
/usr/lib/libsmm-local.so.4
/usr/lib/libsmm-local.so.4.0.0

Changelog

2019-08-14 - Grigory Ustinov <grenka@altlinux.org> 0.16.0.0.git0362439-alt4
- Build compat package only with libopensc.so.4. (thx to cas@) (Closes: #37108).
2016-11-09 - Dmitry Derjavin <dd@altlinux.org> 0.16.0-alt3
- opensc.conf moved to library package
- (closes: 32735)
2016-10-13 - Dmitry Derjavin <dd@altlinux.org> 0.16.0-alt2
- Reqs and configure params cleanup.
2016-10-12 - Dmitry Derjavin <dd@altlinux.org> 0.16.0-alt1
- 0.16.0
2012-06-13 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 0.12.2-alt2.1
- Fixed build
2012-04-20 - Vitaly Kuznetsov <vitty@altlinux.ru> 0.12.2-alt2
- Repair build with automake >= 1.11.4
2011-10-27 - Vitaly Kuznetsov <vitty@altlinux.ru> 0.12.2-alt1
- 0.12.2
- build with pcsc-lite
2011-01-25 - Timur Aitov <timonbl4@altlinux.org> 0.12.0-alt1
- New version
2010-12-08 - Igor Vlasenko <viy@altlinux.ru> 0.11.13-alt1.1
- rebuild with new openssl and/or boost by request of git.alt administrator
2010-06-27 - Alexey I. Froloff <raorn@altlinux.org> 0.11.13-alt1
- [0.11.13]

See Also

Package Description
libopenscada-0.9.0-alt6.i586.rpm Open SCADA development
libopenshot-0.2.2-alt1.i586.rpm OpenShot Video Library
libopenshot-audio-0.1.7-alt1.i586.rpm OpenShot Audio Library
libopenshot-audio-devel-0.1.7-alt1.i586.rpm OpenShot Audio Library development package
libopenshot-devel-0.2.2-alt1.i586.rpm OpenShot Video Library development package
libopenslide-3.4.1-alt1.i586.rpm Shared library for openslide
libopenslide-devel-3.4.1-alt1.i586.rpm Development files for openslide
libopenslp-2.0.0-alt2.i586.rpm openslp project libraries
libopenslp-devel-2.0.0-alt2.i586.rpm openslp project development headers
libopensm-3.3.22-alt1.i586.rpm Libraries from the opensm package
libopensm-devel-3.3.22-alt1.i586.rpm Development files for OpenSM
libopenspecfun-devel-0.5.3-alt1_3.i586.rpm Library providing a collection of special mathematical functions
libopenspecfun1-0.5.3-alt1_3.i586.rpm Library providing a collection of special mathematical functions
liboping-1.6.2-alt2.i586.rpm Liboping library
liboping-devel-1.6.2-alt2.i586.rpm Header files for liboping library
Advertisement
Advertisement