libopensm-3.3.21-alt1.i586.rpm


Advertisement

Description

libopensm - Libraries from the opensm package

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libopensm-3.3.21-alt1.i586.rpm
Package name libopensm
Package version 3.3.21
Package release alt1
Package architecture i586
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 185.43 KB
Installed size 185.43 KB
Shared libraries that are part of the opensm package but are also used
by other applications. If you don't need opensm itself installed, these
libraries can be installed to satisfy dependencies of other
applications.

Alternatives

Package Version Architecture Repository
libopensm-3.3.21-alt1.x86_64.rpm 3.3.21 x86_64 Classic
libopensm - - -

Requires

Name Value
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libibumad.so.3 -
libibumad.so.3(IBUMAD_1.0) -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.3.2) -
libpthread.so.0(GLIBC_2.3.3) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
libopensm = 3.3.21-alt1:sisyphus+219574.100.2.1
libopensm.so.8 -
libopensm.so.8(OPENSM_1.5) -
libopensm2 = 3.3.21-alt1
libosmcomp.so.4 -
libosmcomp.so.4(OSMCOMP_2.3) -
libosmvendor.so.4 -
libosmvendor.so.4(OSMVENDOR_2.0) -

Obsoletes

Name Value
libopensm2 < 3.3.21-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libopensm-3.3.21-alt1.i586.rpm
Source Package opensm-3.3.21-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libopensm rpm package:
    # sudo apt-get install libopensm

Files

Path
/usr/lib/libopensm.so.8
/usr/lib/libopensm.so.8.0.0
/usr/lib/libosmcomp.so.4
/usr/lib/libosmcomp.so.4.0.0
/usr/lib/libosmvendor.so.4
/usr/lib/libosmvendor.so.4.0.3

Changelog

2019-01-17 - Alexey Shabalin <shaba@altlinux.org> 3.3.21-alt1
- 3.3.21
2018-04-12 - Alexey Shabalin <shaba@altlinux.ru> 3.3.20-alt1
- 3.3.20
- disable static build
2011-03-24 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 3.3.7-alt2
- Rebuilt for debuginfo
2010-12-07 - Andriy Stepanov <stanv@altlinux.ru> 3.3.7-alt1
- New version
2010-10-25 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 3.3.6-alt2
- Rebuilt for soname set-versions
- Fixed underlinking of libraries
2010-09-02 - Andriy Stepanov <stanv@altlinux.ru> 3.3.6-alt1
- New version
2010-09-01 - Andriy Stepanov <stanv@altlinux.ru> 3.3.5-alt2
- Rebuild with new libibumad
2010-08-18 - Andriy Stepanov <stanv@altlinux.ru> 3.3.5-alt1
- 3.3.5 (OFED 1.5.1)
2009-07-09 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 3.3.2-alt3
- Rebuild from upstream git repository
- Fixed libraries linking
2009-06-15 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 3.3.2-alt2
- Rename opensm -> opensm2

See Also

Package Description
libopensm-devel-3.3.21-alt1.i586.rpm Development files for OpenSM
liboping-1.6.2-alt2.i586.rpm Liboping library
liboping-devel-1.6.2-alt2.i586.rpm Header files for liboping library
libopm-0.1-alt3_21.20050731cvs.i586.rpm Blitzed open proxy monitor library
libopm-devel-0.1-alt3_21.20050731cvs.i586.rpm Headers and development libraries for libopm
liboprofile-devel-0.9.9-alt3.i586.rpm Header files and libraries for developing apps which will use OProfile
libopts-5.18.12-alt2.i586.rpm Command line option parser based on AutoGen
libopts-devel-5.18.12-alt2.i586.rpm AutoGen development files and libraries
libopus-1.2.1-alt1.1.i586.rpm Opus Audio Codec library
libopus-devel-1.2.1-alt1.1.i586.rpm Development files for libopus
libopusfile-0.9-alt1.i586.rpm A high-level API for decoding and seeking within .opus files
libopusfile-devel-0.9-alt1.i586.rpm Development package for libopusfile
libopusfile-devel-static-0.9-alt1.i586.rpm Static libraries for libopusfile
liborc-0.4.29-alt1.i586.rpm The Oil Runtime Compiler library
liborc-devel-0.4.29-alt1.i586.rpm Development files for liborc
Advertisement
Advertisement