libp11-kit-devel-0.23.15-alt1.i586.rpm


Advertisement

Description

libp11-kit-devel - Development files for p11-kit

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libp11-kit-devel-0.23.15-alt1.i586.rpm
Package name libp11-kit-devel
Package version 0.23.15
Package release alt1
Package architecture i586
Package type rpm
Category Development/C
Homepage -
License -
Maintainer -
Download size 90.68 KB
Installed size 90.68 KB
p11-kit provides a way to load and enumerate PKCS#11 modules, as well
as a standard configuration setup for installing PKCS#11 modules in
such a way that they're discoverable.
The p11-kit-devel package provides libraries and headers for developing
applications that use p11-kit library.

Alternatives

Package Version Architecture Repository
libp11-kit-devel-0.23.15-alt1.x86_64.rpm 0.23.15 x86_64 Classic
libp11-kit-devel - - -

Requires

Name Value
/usr/lib/pkgconfig -
libp11-kit = 0.23.15-alt1:sisyphus+226408.100.2.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
libp11-kit-devel = 0.23.15-alt1:sisyphus+226408.100.2.1
pkgconfig(p11-kit-1) = 0.23.15

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libp11-kit-devel-0.23.15-alt1.i586.rpm
Source Package p11-kit-0.23.15-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libp11-kit-devel rpm package:
    # sudo apt-get install libp11-kit-devel

Files

Path
/usr/include/p11-kit-1/
/usr/include/p11-kit-1/p11-kit/deprecated.h
/usr/include/p11-kit-1/p11-kit/iter.h
/usr/include/p11-kit-1/p11-kit/p11-kit.h
/usr/include/p11-kit-1/p11-kit/pin.h
/usr/include/p11-kit-1/p11-kit/pkcs11.h
/usr/include/p11-kit-1/p11-kit/pkcs11x.h
/usr/include/p11-kit-1/p11-kit/remote.h
/usr/include/p11-kit-1/p11-kit/uri.h
/usr/lib/libp11-kit.so
/usr/lib/pkgconfig/p11-kit-1.pc

Changelog

2019-04-02 - Mikhail Efremov <sem@altlinux.org> 0.23.15-alt1
- Changes from upstream:
+ modules: Fix index used in call to p11_dict_remove().
+ Fix Win32 p11_dl_error crash.
+ modules: check gl.modules before iterates on it when freeing.
+ trust: Ignore unreadable content in anchors.
+ extract-jks: Prefer _p11_extract_jks_timestamp to SOURCE_DATE_EPOCH.
- Drop proxy-refresh-slots.patch.
- 0.23.15.
2018-05-08 - Mikhail Efremov <sem@altlinux.org> 0.23.9-alt5
- Fix alternatives file.
2018-04-04 - Michael Shigorin <mike@altlinux.org> 0.23.9-alt4
- Fix doc knob.
2018-01-09 - Mikhail Efremov <sem@altlinux.org> 0.23.9-alt3
- Simplify checkinstall.
- Fix checkinstall group and description.
- Require p11-kit bundle instead of ca-certificates.
2017-12-29 - Mikhail Efremov <sem@altlinux.org> 0.23.9-alt2
- Rename and package alternative file for libnssckbi.so.
- Add checkinstall subpackage.
- Use ca-certificates with p11-kit support.
- p11-kit-extract-trust: Run update-ca-trust.
- Don't use libfreebl3 for hashes.
- Re-split and rename package.
2017-10-16 - Paul Wolneykien <manowar@altlinux.org> 0.23.9-alt1
- Exclude the alteranatives file for libnssckbi.so.
- Patch the sources just after unpacking them.
- Release 0.23.9 (thx Daiki Ueno).
2017-09-06 - Paul Wolneykien <manowar@altlinux.org> 0.23.8-alt2
- Refresh the slot list each time C_GetSlotList() is called (patch).
2017-08-24 - Yuri N. Sedunov <aris@altlinux.org> 0.23.8-alt1
- 0.23.8 (0.23.7-24-g26312a8)
2017-06-18 - Yuri N. Sedunov <aris@altlinux.org> 0.23.7-alt1
- 0.23.7
2017-03-06 - Yuri N. Sedunov <aris@altlinux.org> 0.23.5-alt1
- 0.23.5

See Also

Package Description
libpacemaker-2.0.2-alt1.i586.rpm Core Pacemaker libraries
libpacemaker-devel-2.0.2-alt1.i586.rpm Pacemaker development package
libpackagekit-glib-1.1.12-alt12.i586.rpm GLib libraries for accessing PackageKit
libpackagekit-glib-devel-1.1.12-alt12.i586.rpm GLib Libraries and headers for PackageKit
libpackagekit-gtk3-module-1.1.12-alt12.i586.rpm Install fonts automatically using PackageKit
libpackagekitqt5_1-1.0.1-alt4.i586.rpm packagekit-qt library
libpacoxx-0.2.beta-alt6.i586.rpm Shared libraries of PaCO++
libpagemaker-0.0.4-alt1.i586.rpm A library for import of Adobe PageMaker documents
libpagemaker-devel-0.0.4-alt1.i586.rpm Development files for libpagemaker
libpagemaker-tools-0.0.4-alt1.i586.rpm Tools to transform Adobe PageMaker documents into other formats
libpagemap-0.0.1-alt1_25.i586.rpm Pagemap interface library
libpagemap-devel-0.0.1-alt1_25.i586.rpm Development files for libpagemap
libpala0.1-19.04.0-alt1.i586.rpm kde5-palapeli library
libpala4-15.4.3-alt1.i586.rpm KDE 4 library
libpam-google-authenticator-1.06-alt1.i586.rpm One-time passcode support using open standards
Advertisement
Advertisement