libpjsip-2.8-alt1.i586.rpm


Advertisement

Description

libpjsip - Libraries for building embedded/non-embedded VoIP applications

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libpjsip-2.8-alt1.i586.rpm
Package name libpjsip
Package version 2.8
Package release alt1
Package architecture i586
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 2.49 MB
Installed size 2.49 MB
This package provides the Open Source, comprehensive, high performance,
small footprint multimedia communication libraries written in C
language for building embedded/non-embedded VoIP applications.
It contains:
- PJSIP - Open Source SIP Stack
- PJMEDIA - Open Source Media Stack
- PJNATH - Open Source NAT Traversal Helper Library
- PJLIB-UTIL - Auxiliary Library
- PJLIB - Ultra Portable Base Framework Library
- PJSUA2 - Object Oriented abstractions layer for PJSUA

Alternatives

Package Version Architecture Repository
libpjsip-2.8-alt1.x86_64.rpm 2.8 x86_64 Classic
libpjsip - - -

Requires

Name Value
libasound.so.2 -
libasound.so.2(ALSA_0.9) -
libasound.so.2(ALSA_0.9.0rc4) -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.2) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libcrypto.so.1.1 -
libcrypto.so.1.1(OPENSSL_1_1_0) -
libgcc_s.so.1(GCC_3.0) -
libgsm.so.1 -
libm.so.6(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.3.2) -
librt.so.1(GLIBC_2.2) -
libspeex.so.1 -
libspeexdsp.so.1 -
libsrtp2.so.1 -
libssl.so.1.1 -
libssl.so.1.1(OPENSSL_1_1_0) -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libuuid.so.1 -
libuuid.so.1(UUID_1.0) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
libpj.so.2 -
libpjlib-util.so.2 -
libpjmedia-audiodev.so.2 -
libpjmedia-codec.so.2 -
libpjmedia-videodev.so.2 -
libpjmedia.so.2 -
libpjnath.so.2 -
libpjsip = 2.8-alt1:sisyphus+222633.100.1.1
libpjsip-simple.so.2 -
libpjsip-ua.so.2 -
libpjsip.so.2 -
libpjsua.so.2 -
libpjsua2.so.2 -
libresample.so.2 -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libpjsip-2.8-alt1.i586.rpm
Source Package libpjsip-2.8-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libpjsip rpm package:
    # sudo apt-get install libpjsip

Files

Path
/usr/lib/libpj.so.2
/usr/lib/libpjlib-util.so.2
/usr/lib/libpjmedia-audiodev.so.2
/usr/lib/libpjmedia-codec.so.2
/usr/lib/libpjmedia-videodev.so.2
/usr/lib/libpjmedia.so.2
/usr/lib/libpjnath.so.2
/usr/lib/libpjsip-simple.so.2
/usr/lib/libpjsip-ua.so.2
/usr/lib/libpjsip.so.2
/usr/lib/libpjsua.so.2
/usr/lib/libpjsua2.so.2
/usr/lib/libresample.so.2
/usr/share/doc/libpjsip-2.8/README.txt

Changelog

2018-09-27 - Sergey Bolshakov <sbolshakov@altlinux.ru> 2.8-alt1
- 2.8 released
2017-02-10 - Vitaly Lipatov <lav@altlinux.ru> 2.5.5-alt1
- new version 2.5.5 (with rpmrb script)
2015-11-30 - Igor Vlasenko <viy@altlinux.ru> 2.4.5-alt4.1
- NMU: added BR: libspeexdsp-devel
2015-11-20 - Vitaly Lipatov <lav@altlinux.ru> 2.4.5-alt4
- cleanup spec
- build with internal resample from http://ccrma.stanford.edu/~jos/resample/
- enable sound
2015-11-08 - Denis Smirnov <mithraen@altlinux.ru> 2.4.5-alt2
- rebuild with libsrtp-devel
2015-08-20 - Vitaly Lipatov <lav@altlinux.ru> 2.4.5-alt1
- new version 2.4.5 (with rpmrb script)
2015-08-20 - Vitaly Lipatov <lav@altlinux.ru> 2.4-alt1
- initial build for ALT Linux Sisyphus
2015-06-18 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
2015-05-05 - Peter Robinson <pbrobinson@fedoraproject.org> 2.4-1
- Upstream 2.4 release
2015-05-02 - Kalev Lember <kalevlember@gmail.com> - 2.3-8
- Rebuilt for GCC 5 C++11 ABI change

See Also

Package Description
libpjsip-devel-2.8-alt1.i586.rpm Development files to use pjproject
libpkcs11-helper-1.25.1-alt7.i586.rpm A library for using PKCS#11 providers
libpkcs11-helper-devel-1.25.1-alt7.i586.rpm Development files for pkcs11-helper
libpki-0.8.9-alt3.git20180603.i586.rpm Library for PKI enabled application development
libpki-devel-0.8.9-alt3.git20180603.i586.rpm Header files and library for development with LibPKI
libpki-devel-static-0.8.9-alt3.git20180603.i586.rpm The PKI static library
libpki-tools-0.8.9-alt3.git20180603.i586.rpm Auxiliary tools for LibPKI
libplank-0.11.4-alt1.i586.rpm Library to build a elegant, simple, clean dock
libplank-devel-0.11.4-alt1.i586.rpm Library to build a elegant, simple, clean dock (development files)
libplankundo216-3.1.0-alt7.i586.rpm calligraplan library
libplanmain16-3.1.0-alt7.i586.rpm calligraplan library
libplanner-0.14.6-alt2.i586.rpm Libraries for planner
libplanner-devel-0.14.6-alt2.i586.rpm Libraries needed to develop for planner
libplanodf16-3.1.0-alt7.i586.rpm calligraplan library
libplanplugin16-3.1.0-alt7.i586.rpm calligraplan library
Advertisement
Advertisement