libpng16-1.6.29-alt1.i586.rpm


Advertisement

Description

libpng16 - A library of functions for manipulating PNG image format files

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package name libpng16
Package version 1.6.29
Package release alt1
Package architecture i586
Package type rpm
Installed size 321.53 KB
Download size 321.53 KB
Official Mirror ftp.altlinux.org
libpng is a library implementing an interface for reading and writing
PNG (Portable Network Graphics) format files.
This package contains the runtime library files needed to run software
using libpng.

Alternatives

Package Version Architecture Repository
libpng16-1.6.29-alt1.x86_64.rpm 1.6.29 x86_64 Classic
libpng16 - - -

Requires

Name Value
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.11) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libm.so.6(GLIBC_2.0) -
libz.so.1 -
libz.so.1(ZLIB_1.2.3.4) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
libpng = 1.6.29
libpng16 = 1.6.29-alt1
libpng16.so.16 -
libpng16.so.16(PNG16_0) -

Conflicts

Name Value
libpng15 < 1.5.28-alt2

Download

Type URL
Binary Package libpng16-1.6.29-alt1.i586.rpm
Source Package libpng16-1.6.29-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libpng16 rpm package:
    # sudo apt-get install libpng16

Files

Path
/usr/lib/libpng16.so.16
/usr/lib/libpng16.so.16.29.0
/usr/share/doc/libpng-1.6.29/CHANGES.xz
/usr/share/doc/libpng-1.6.29/LICENSE
/usr/share/doc/libpng-1.6.29/README
/usr/share/man/man5/png.5.xz

Changelog

2017-06-20 - Sergey Bolshakov <sbolshakov@altlinux.ru> 1.6.29-alt1
- 1.6.29
2016-12-29 - Dmitry V. Levin <ldv@altlinux.org> 1.5.28-alt1
- 1.5.27 -> 1.5.28.
2016-05-26 - Dmitry V. Levin <ldv@altlinux.org> 1.5.27-alt1
- 1.5.26 -> 1.5.27.
2015-12-21 - Dmitry V. Levin <ldv@altlinux.org> 1.5.26-alt1
- Updated to 1.5.26.
2015-12-03 - Dmitry V. Levin <ldv@altlinux.org> 1.5.25-alt1
- Updated to 1.5.25.
2015-11-18 - Dmitry V. Levin <ldv@altlinux.org> 1.5.24-alt1
- Updated to 1.5.24.
2014-12-24 - Dmitry V. Levin <ldv@altlinux.org> 1.5.21-alt1
- Updated to 1.5.21.
2012-10-03 - Dmitry V. Levin <ldv@altlinux.org> 1.5.13-alt1
- Updated to 1.5.13.
2012-09-14 - Dmitry V. Levin <ldv@altlinux.org> 1.5.12-alt1
- Updated to 1.5.12.
- Activated chunk size limits by default.
2012-07-11 - Dmitry V. Levin <ldv@altlinux.org> 1.2.50-alt1
- Updated to 1.2.50.
- Disabled build and packaging of libpng-devel-static.

See Also

Package Description
libpng3-1.2.50-alt2.i586.rpm PNG runtime legacy library
libpnglite-0.1.17-alt3.i586.rpm Lightweight PNG C library
libpnglite-devel-0.1.17-alt3.i586.rpm Files needed to build and link programs with pnglite
libpoco-1.9.0-alt2.i586.rpm POrtable COmponents C++ Libraries
libpoco-crypto-1.9.0-alt2.i586.rpm POrtable COmponents C++ Libraries (crypto)
libpoco-data-1.9.0-alt2.i586.rpm POrtable COmponents C++ Libraries (data)
libpoco-devel-1.9.0-alt2.i586.rpm Development files of POrtable COmponents C++ Libraries
libpoco-mongodb-1.9.0-alt2.i586.rpm POrtable COmponents C++ Libraries (mongodb)
libpoco-mysql-1.9.0-alt2.i586.rpm POrtable COmponents C++ Libraries (mysql)
libpoco-net-1.9.0-alt2.i586.rpm POrtable COmponents C++ Libraries (net)
libpoco-odbc-1.9.0-alt2.i586.rpm POrtable COmponents C++ Libraries (odbc)
libpoco-redis-1.9.0-alt2.i586.rpm POrtable COmponents C++ Libraries (redis)
libpoco-sqlite-1.9.0-alt2.i586.rpm POrtable COmponents C++ Libraries (sqlite)
libpoco-ssl-1.9.0-alt2.i586.rpm POrtable COmponents C++ Libraries (ssl)
libpoco-util-1.9.0-alt2.i586.rpm POrtable COmponents C++ Libraries (util)
Advertisement
Advertisement