libpostproc54-3.3.9-alt2.i586.rpm


Advertisement

Description

libpostproc54 - FFmpeg postprocessing library

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libpostproc54-3.3.9-alt2.i586.rpm
Package name libpostproc54
Package version 3.3.9
Package release alt2
Package architecture i586
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 113.41 KB
Installed size 113.41 KB
FFmpeg is a collection of libraries and tools to process multimedia content
such as audio, video, subtitles and related metadata.
The libpostproc library implements video postprocessing routines.

Alternatives

Package Version Architecture Repository
libpostproc54-3.3.9-alt2.x86_64.rpm 3.3.9 x86_64 Classic
libpostproc54 - - -

Requires

Name Value
libavutil55 = 2:3.3.9-alt2:sisyphus+236632.100.1.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
libpostproc.so.54 -
libpostproc.so.54(LIBPOSTPROC_54) -
libpostproc54 = 2:3.3.9-alt2:sisyphus+236632.100.1.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libpostproc54-3.3.9-alt2.i586.rpm
Source Package ffmpeg3.3-3.3.9-alt2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libpostproc54 rpm package:
    # sudo apt-get install libpostproc54

Files

Path
/usr/lib/libpostproc.so.54
/usr/lib/libpostproc.so.54.5.100

Changelog

2019-08-26 - Anton Farygin <rider@altlinux.ru> 2:3.3.9-alt2
- added information about closed CVE's to the changelog
2018-12-18 - Anton Farygin <rider@altlinux.ru> 2:3.3.9-alt1
- up to 3.3.9 (compatability package)
- build without librtmp
- fixes:
* CVE-2018-14394 by commit 3a2d21
* CVE-2018-14395 by commit fa19fb
* CVE-2018-1999010 by commit cced03
2018-06-19 - Anton Farygin <rider@altlinux.ru> 2:3.3.6-alt4
- build as compat library without devel packages and tools
2018-05-30 - Anton Farygin <rider@altlinux.ru> 2:3.3.6-alt3
- rebuilt in new environment
2018-03-15 - Vladimir D. Seleznev <vseleznv@altlinux.org> 2:3.3.6-alt2
- built with new de/encoder: libopus
- built with new encoders:
+ libtwolame
+ libwavpack
+ libwebp
- built with new external libraries:
+ libass
+ libbluray
+ libcaca
+ libfontconfig
+ libfribidi
+ libopenjpeg
+ librubberband
+ libsnappy
+ libsoxr
+ libzmq
+ libzvbi
+ openal
+ opengl
- disabled some optimizations on MIPS arch family (by glebfm@)
- disabled devel-static subpackage build
2018-01-23 - Anton Farygin <rider@altlinux.ru> 2:3.3.6-alt1
- new version
2018-01-14 - Yuri N. Sedunov <aris@altlinux.org> 2:3.3.5-alt1.1
- rebuild against libcdio.so.18
2017-10-28 - Anton Farygin <rider@altlinux.ru> 2:3.3.5-alt1
- 3.3.4
- fixes:
* CVE-2017-15186 double free when ffmpeg parsing an craft AVI file to MKV file using ffvhuff decoder.
2017-10-06 - Anton Farygin <rider@altlinux.ru> 2:3.3.4-alt3
- rebuild for libx265 2.5
2017-10-03 - Anton Farygin <rider@altlinux.ru> 2:3.3.4-alt2
- rebuild for recent libvpx4 1.6.1

See Also

Package Description
libpostproc55-4.2.1-alt1.i586.rpm FFmpeg postprocessing library
libpotrace-1.16-alt1.i586.rpm Potrace library
libpotrace-devel-1.16-alt1.i586.rpm Potrace development files
libpowerdevilconfigcommonprivate5-5.16.5-alt1.i586.rpm KF5 library
libpowerdevilcore2-5.16.5-alt1.i586.rpm KF5 library
libpowerdevilui5-5.16.5-alt1.i586.rpm KF5 library
libpq5-12.0-alt2.i586.rpm The shared libraries required for any PostgreSQL clients
libpqxx-4.0.1-alt2_13.i586.rpm C++ client API for PostgreSQL
libpqxx-devel-4.0.1-alt2_13.i586.rpm Development tools for libpqxx
libprelude-5.0.0-alt2.i586.rpm Secure Connections between all Sensors and the Prelude Manager
libprelude-devel-5.0.0-alt2.i586.rpm Libraries and headers for developing Prelude sensors
libpreludedb-5.0.0-alt1_3.i586.rpm Framework for easy access to the IDMEF database
libpreludedb-devel-5.0.0-alt1_3.i586.rpm Libraries and headers for PreludeDB
libprimme-1.1-alt13.i586.rpm Shared libraries of PRIMME
libprimme-devel-1.1-alt13.i586.rpm Development files of PRIMME
Advertisement
Advertisement