libprotobuf-compat9-lite-2.6.1-alt2.i586.rpm


Advertisement

Description

libprotobuf-compat9-lite - Protocol Buffers LITE_RUNTIME libraries

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package name libprotobuf-compat9-lite
Package version 2.6.1
Package release alt2
Package architecture i586
Package type rpm
Installed size 190.26 KB
Download size 190.26 KB
Official Mirror ftp.altlinux.org
Protocol Buffers built with optimize_for = LITE_RUNTIME.
The "optimize_for = LITE_RUNTIME" option causes the compiler to generate code
which only depends libprotobuf-lite, which is much smaller than libprotobuf but
lacks descriptors, reflection, and some other features.

Alternatives

Package Version Architecture Repository
libprotobuf-compat9-lite-2.6.1-alt2.x86_64.rpm 2.6.1 x86_64 Classic
libprotobuf-compat9-lite - - -

Requires

Name Value
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1(GCC_3.0) -
libpthread.so.0(GLIBC_2.0) -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.18) -
libstdc++.so.6(GLIBCXX_3.4.21) -
rpmlib(PayloadIsLzma) -
rtld(GNU_HASH) -

Provides

Name Value
libprotobuf-compat9-lite = 2.6.1-alt2
libprotobuf-lite = 2.6.1-alt2
libprotobuf-lite.so.9 -

Download

Type URL
Binary Package libprotobuf-compat9-lite-2.6.1-alt2.i586.rpm
Source Package protobuf-compat-2.6.1-alt2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libprotobuf-compat9-lite rpm package:
    # sudo apt-get install libprotobuf-compat9-lite

Files

Path
/usr/lib/libprotobuf-lite.so.9
/usr/lib/libprotobuf-lite.so.9.0.1

Changelog

2017-11-06 - Anton Midyukov <antohami@altlinux.org> 2.6.1-alt2
- build only library package for compat and java package
2017-06-26 - Aleksei Nikiforov <darktemplar@altlinux.org> 2.6.1-alt1.2
- Fixed build with gcc-6
2016-03-17 - Ivan Zakharyaschev <imz@altlinux.org> 2.6.1-alt1.1
- (NMU) rebuild with python3-3.5 & rpm-build-python3-0.1.10
(for ABI dependence and new python3(*) reqs)
2016-02-10 - Igor Vlasenko <viy@altlinux.ru> 2.6.1-alt1
- 2.6.1
2016-02-10 - Igor Vlasenko <viy@altlinux.ru> 2.6.0-alt1.2
- NMU: java is built according to new policy (using xmvn)
2015-06-10 - Gleb F-Malinovskiy <glebfm@altlinux.org> 2.6.0-alt1.1
- Rebuilt for gcc5 C++11 ABI.
2014-08-29 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 2.6.0-alt1
- Version 2.6.0
- Added module for Python 3
2014-08-08 - Igor Vlasenko <viy@altlinux.ru> 2.5.0-alt2
- NMU: added BuildReq: maven-local
2013-09-06 - Alexey Shabalin <shaba@altlinux.ru> 2.5.0-alt1
- 2.5.0
2012-09-09 - Igor Vlasenko <viy@altlinux.ru> 2.4.1-alt2
- added protobuf-java subpackage (required for maven dependencies)

See Also

Package Description
libprotobuf-devel-3.5.2-alt1.i586.rpm Development files for protobuf
libprotobuf-lite-devel-3.5.2-alt1.i586.rpm Protocol Buffers LITE_RUNTIME development libraries
libprotobuf14-3.4.1-alt2.i586.rpm Protocol Buffer c++ library
libprotobuf14-lite-3.4.1-alt2.i586.rpm Protocol Buffers LITE_RUNTIME libraries
libprotobuf15-3.5.2-alt1.i586.rpm Protocol Buffer c++ library
libprotobuf15-lite-3.5.2-alt1.i586.rpm Protocol Buffers LITE_RUNTIME libraries
libprotobuf7-2.4.1-alt5.i586.rpm Protocol Buffer c++ library
libprotobuf7-lite-2.4.1-alt5.i586.rpm Protocol Buffers LITE_RUNTIME libraries
libproxy-0.4.15-alt2.i586.rpm A library handling all the details of proxy configuration
libproxy-devel-0.4.15-alt2.i586.rpm Development files for libproxy
libproxy-gnome3-0.4.15-alt2.i586.rpm Libproxy module for gnome3 configuration
libproxy-kde-0.4.15-alt2.i586.rpm Libproxy module for kde configuration
libproxy-mozjs-0.4.15-alt2.i586.rpm Libproxy module to support wpad/pac parsing via Mozilla JavaScript Engine
libproxy-networkmanager-0.4.15-alt2.i586.rpm Libproxy module for networkmanager configuration
libproxy-tools-0.4.15-alt2.i586.rpm A sample & test application to test what libproxy will reply
Advertisement
Advertisement