libprotobuf7-lite-2.4.1-alt5.i586.rpm


Advertisement

Description

libprotobuf7-lite - Protocol Buffers LITE_RUNTIME libraries

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package name libprotobuf7-lite
Package version 2.4.1
Package release alt5
Package architecture i586
Package type rpm
Installed size 166.19 KB
Download size 166.19 KB
Official Mirror ftp.altlinux.org
Protocol Buffers built with optimize_for = LITE_RUNTIME.
The "optimize_for = LITE_RUNTIME" option causes the compiler to generate code
which only depends libprotobuf-lite, which is much smaller than libprotobuf but
lacks descriptors, reflection, and some other features.

Alternatives

Package Version Architecture Repository
libprotobuf7-lite-2.4.1-alt5.x86_64.rpm 2.4.1 x86_64 Classic
libprotobuf7-lite - - -

Requires

Name Value
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1(GCC_3.0) -
libpthread.so.0(GLIBC_2.0) -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.8) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.18) -
libstdc++.so.6(GLIBCXX_3.4.21) -
rpmlib(PayloadIsLzma) -
rtld(GNU_HASH) -

Provides

Name Value
libprotobuf-compat77-lite = 2.4.1-alt5
libprotobuf-lite = 2.4.1-alt5
libprotobuf-lite.so.7 -
libprotobuf7-lite = 2.4.1-alt5

Obsoletes

Name Value
libprotobuf-compat77-lite < 2.4.1-alt5

Download

Type URL
Binary Package libprotobuf7-lite-2.4.1-alt5.i586.rpm
Source Package protobuf-compat7-2.4.1-alt5.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libprotobuf7-lite rpm package:
    # sudo apt-get install libprotobuf7-lite

Files

Path
/usr/lib/libprotobuf-lite.so.7
/usr/lib/libprotobuf-lite.so.7.0.0

Changelog

2017-06-26 - Aleksei Nikiforov <darktemplar@altlinux.org> 2.4.1-alt5
- Fixed build with gcc-6
2014-07-31 - Alexey Shabalin <shaba@altlinux.ru> 2.4.1-alt4
- fixed package name
2013-09-09 - Alexey Shabalin <shaba@altlinux.ru> 2.4.1-alt3
- build only library package for compat
2012-09-09 - Igor Vlasenko <viy@altlinux.ru> 2.4.1-alt2
- added protobuf-java subpackage (required for maven dependencies)
2011-11-24 - Alexey Shabalin <shaba@altlinux.ru> 2.4.1-alt1
- 2.4.1
2011-10-22 - Vitaly Kuznetsov <vitty@altlinux.ru> 2.3.0-alt1.1.1
- Rebuild with Python-2.7
2011-03-27 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 2.3.0-alt1.1
- Rebuilt for debuginfo
2010-09-20 - Alexey Shabalin <shaba@altlinux.ru> 2.3.0-alt1
- 2.3.0
- changed soname
2010-04-30 - Alexey Shabalin <shaba@altlinux.ru> 2.2.0a-alt1
- 2.2.0a
- changed soname
- added export PTHREAD_LIBS="-lpthread"
- add libprotobuf-lite subpackage
2010-04-30 - Alexey Shabalin <shaba@altlinux.ru> 2.2.0-alt1
- 2.2.0

See Also

Package Description
libproxy-0.4.15-alt1.i586.rpm A library handling all the details of proxy configuration
libproxy-devel-0.4.15-alt1.i586.rpm Development files for libproxy
libproxy-gnome3-0.4.15-alt1.i586.rpm Libproxy module for gnome3 configuration
libproxy-kde-0.4.15-alt1.i586.rpm Libproxy module for kde configuration
libproxy-mozjs-0.4.15-alt1.i586.rpm Libproxy module to support wpad/pac parsing via Mozilla JavaScript Engine
libproxy-networkmanager-0.4.15-alt1.i586.rpm Libproxy module for networkmanager configuration
libproxy-tools-0.4.15-alt1.i586.rpm A sample & test application to test what libproxy will reply
libproxy-webkit-0.4.15-alt1.i586.rpm Libproxy module to support webkit
libps-0.4.5-alt1.1.i586.rpm Library for creating PostScript files
libps-devel-0.4.5-alt1.1.i586.rpm Libraries, includes, etc. to develop PostScript applications
libpsl-0.20.2-alt1.i586.rpm C library for the Public Suffix List
libpsl-devel-0.20.2-alt1.i586.rpm Development files for libpsl
libpsrp-1.4.1-alt1.i586.rpm PowerShell WS-Man PSRP Client for Linux
libpst-0.6.68-alt2.1.i586.rpm Tools for conversion of Outlook files to mailbox and other formats
libpst-devel-0.6.68-alt2.1.i586.rpm Development files for libpst
Advertisement
Advertisement