libpugixml-1.9-alt1.i586.rpm


Advertisement

Description

libpugixml - A light-weight C++ XML processing library

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package name libpugixml
Package version 1.9
Package release alt1
Package architecture i586
Package type rpm
Installed size 240.21 KB
Download size 240.21 KB
Official Mirror ftp.altlinux.org
pugixml is a light-weight C++ XML processing library.
It features:
- DOM-like interface with rich traversal/modification capabilities
- Extremely fast non-validating XML parser which constructs the DOM tree
from an XML file/buffer
- XPath 1.0 implementation for complex data-driven tree queries
- Full Unicode support with Unicode interface variants and automatic
encoding conversions

Alternatives

Package Version Architecture Repository
libpugixml-1.9-alt1.x86_64.rpm 1.9 x86_64 Classic
libpugixml - - -

Requires

Name Value
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6(GLIBC_2.0) -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.21) -
rpmlib(PayloadIsLzma) -
rtld(GNU_HASH) -

Provides

Name Value
libpugixml = 1.9-alt1
libpugixml.so.1 -
pugixml = 1.9-alt1

Download

Type URL
Binary Package libpugixml-1.9-alt1.i586.rpm
Source Package libpugixml-1.9-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libpugixml rpm package:
    # sudo apt-get install libpugixml

Files

Path
/usr/lib/libpugixml.so.1
/usr/lib/libpugixml.so.1.9
/usr/share/doc/libpugixml-1.9/readme.txt

Changelog

2018-04-05 - Andrey Cherepanov <cas@altlinux.org> 1.9-alt1
- New version.
2016-11-29 - Andrey Cherepanov <cas@altlinux.org> 1.8.1-alt1
- new version 1.8.1
2015-10-29 - Gleb F-Malinovskiy <glebfm@altlinux.org> 1.7-alt1
- Updated to 1.7.
2015-10-03 - Andrey Cherepanov <cas@altlinux.org> 1.6-alt1
- New version
2014-01-14 - Andrey Cherepanov <cas@altlinux.org> 1.0-alt3
- Make devel .so library as symlink to so-named library
2014-01-13 - Andrey Cherepanov <cas@altlinux.org> 1.0-alt2
- Build in Sisyphus under name libpugixml
2013-09-02 - Igor Vlasenko <viy@altlinux.ru> 1.0-alt1_6
- update to new release by fcimport
2013-04-26 - Igor Vlasenko <viy@altlinux.ru> 1.0-alt1_5
- initial fc import

See Also

Package Description
libpugixml-devel-1.9-alt1.i586.rpm Development files for libpugixml
libpulseaudio-12.2-alt1.i586.rpm PulseAudio shared libraries
libpulseaudio-devel-12.2-alt1.i586.rpm Development files for pulseaudio
libpurple-2.13.0-alt2.i586.rpm libpurple library for IM clients like Pidgin and Finch
libpurple-client-2.13.0-alt2.i586.rpm Client library for IM clients like Pidgin and Finch
libpurple-dbus-2.13.0-alt2.i586.rpm D-Bus client utilities for Pidgin
libpurple-devel-2.13.0-alt2.i586.rpm Development headers, documentation, and libraries for libpurple
libpuzzle-0.11-alt2.i586.rpm A library for finding visually similar bitmap pictures
libpuzzle-devel-0.11-alt2.i586.rpm Development tools for programs which will use the libpuzzle library
libpvm3-3.4.6-alt1.1.qa1.i586.rpm Parallel Virtual Machine - shared libraries
libpwquality-1.4.0-alt1.1.i586.rpm A library for password generation and password quality checking
libpwquality-devel-1.4.0-alt1.1.i586.rpm Develompent files for libpwquality
libpx-0.6.8-alt1.i586.rpm A library to read Paradox DB files
libpx-devel-0.6.8-alt1.i586.rpm Header files for pxlib
libpympi-devel-2.5.b6-alt18.cvs20141103.i586.rpm Static development files of pyMPI
Advertisement
Advertisement