libqtsingleapplication-qt5-2.6.1-alt3.i586.rpm


Advertisement

Description

libqtsingleapplication-qt5 - The QtSingleApplication component provides support for applications that can be only started once per user

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libqtsingleapplication-qt5-2.6.1-alt3.i586.rpm
Package name libqtsingleapplication-qt5
Package version 2.6.1
Package release alt3
Package architecture i586
Package type rpm
Category Development/C++
Homepage -
License -
Maintainer -
Download size 71.72 KB
Installed size 71.72 KB
For some applications it is useful or even critical that they are started
only once by any user. Future attempts to start the application should
activate any already running instance, and possibly perform requested
actions, e.g. loading a file, in that instance.
The QtSingleApplication class provides an interface to detect a running
instance, and to send command strings to that instance.
For console (non-GUI) applications, the QtSingleCoreApplication variant
is provided, which avoids dependency on QtGui.
This is a special build against Qt5.

Alternatives

Package Version Architecture Repository
libqtsingleapplication-qt5-2.6.1-alt3.x86_64.rpm 2.6.1 x86_64 Classic
libqtsingleapplication-qt5 - - -

Requires

Name Value
libQt5Core.so.5 -
libQt5Core.so.5(Qt_5) -
libQt5Core.so.5(Qt_5.11) -
libQt5Network.so.5 -
libQt5Network.so.5(Qt_5) -
libQt5Widgets.so.5 -
libQt5Widgets.so.5(Qt_5) -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libgcc_s.so.1(GCC_3.0) -
libpthread.so.0(GLIBC_2.0) -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
libQt5Solutions_SingleApplication-2.6.so.1 -
libQt5Solutions_SingleCoreApplication-2.6.so.1 -
libqtsingleapplication-qt5 = 2.6.1-alt3:sisyphus+222636.100.1.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libqtsingleapplication-qt5-2.6.1-alt3.i586.rpm
Source Package libqtsingleapplication-2.6.1-alt3.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libqtsingleapplication-qt5 rpm package:
    # sudo apt-get install libqtsingleapplication-qt5

Files

Path
/usr/lib/libQt5Solutions_SingleApplication-2.6.so.1
/usr/lib/libQt5Solutions_SingleApplication-2.6.so.1.0
/usr/lib/libQt5Solutions_SingleApplication-2.6.so.1.0.0
/usr/lib/libQt5Solutions_SingleCoreApplication-2.6.so.1
/usr/lib/libQt5Solutions_SingleCoreApplication-2.6.so.1.0
/usr/lib/libQt5Solutions_SingleCoreApplication-2.6.so.1.0.0

Changelog

2018-11-17 - Anton Midyukov <antohami@altlinux.org> 2.6.1-alt3
- new snapshot
- initial build libqtsingleapplication-qt5
2013-05-14 - Motsyo Gennadi <drool@altlinux.ru> 2.6.1-alt2
- fix build for Sisyphus
2013-05-14 - Motsyo Gennadi <drool@altlinux.ru> 2.6.1-alt1
- initial build for ALT Linux from OpenSUSE package

See Also

Package Description
libqtsingleapplication-qt5-devel-2.6.1-alt3.i586.rpm The QtSingleApplication component provides support for applications that can be only started once per user
libqtsoap-2.7-alt4.i586.rpm The Simple Object Access Protocol Qt-based client side library
libqtsoap5-2.7-alt4.i586.rpm The Simple Object Access Protocol Qt5-based client side library
libqtspell-qt4-0.8.5-alt2.i586.rpm Spell checking for Qt4 text widgets
libqtspell-qt4-devel-0.8.5-alt2.i586.rpm Development files for libqtspell-qt4
libqtspell-qt5-0.8.5-alt2.i586.rpm Spell checking for Qt5 text widgets
libqtspell-qt5-devel-0.8.5-alt2.i586.rpm Development files for libqtspell-qt5
libqtxdg-3.3.1-alt2.i586.rpm Qt implementation of freedesktop.org xdg specs
libqtxdg-devel-3.3.1-alt2.i586.rpm Development headers for QtXdg library
libquadmath-devel-8-alt2.i586.rpm Dependency package for libquadmath-devel
libquadmath0-8.3.1-alt5.i586.rpm GCC __float128 shared support library
libquadmath4.6-devel-4.6.3-alt13.i586.rpm GCC __float128 support files
libquadmath4.6-devel-static-4.6.3-alt13.i586.rpm GCC __float128 static support library
libquadmath4.7-devel-4.7.2-alt12.i586.rpm GCC __float128 support files
libquadmath4.7-devel-static-4.7.2-alt12.i586.rpm GCC __float128 static support library
Advertisement
Advertisement