libyaml-cpp-devel-0.6.2-alt2.i586.rpm


Advertisement

Description

libyaml-cpp-devel - YAML Development libraries

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename libyaml-cpp-devel-0.6.2-alt2.i586.rpm
Package name libyaml-cpp-devel
Package version 0.6.2
Package release alt2
Package architecture i586
Package type rpm
Category Development/Other
Homepage -
License -
Maintainer -
Download size 107.15 KB
Installed size 107.15 KB
Development libraries for YAML.
This package contains static development files for YAML.

Alternatives

Package Version Architecture Repository
libyaml-cpp-devel-0.6.2-alt2.x86_64.rpm 0.6.2 x86_64 Classic
libyaml-cpp-devel - - -

Requires

Name Value
/usr/lib/pkgconfig -
libyaml-cpp0 = 0.6.2-alt2:sisyphus+222677.100.1.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
libyaml-cpp-devel = 0.6.2-alt2:sisyphus+222677.100.1.1
libyaml-cpp0-devel = 0.6.2-alt2:sisyphus+222677.100.1.1
pkgconfig(yaml-cpp) = 0.6.2

Obsoletes

Name Value
libyaml-cpp0-devel < 0.6.2-alt2

Download

Type URL
Mirror ftp.altlinux.org
Binary Package libyaml-cpp-devel-0.6.2-alt2.i586.rpm
Source Package libyaml-cpp0-0.6.2-alt2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libyaml-cpp-devel rpm package:
    # sudo apt-get install libyaml-cpp-devel

Files

Path
/usr/include/yaml-cpp/anchor.h
/usr/include/yaml-cpp/binary.h
/usr/include/yaml-cpp/depthguard.h
/usr/include/yaml-cpp/dll.h
/usr/include/yaml-cpp/emitfromevents.h
/usr/include/yaml-cpp/emitter.h
/usr/include/yaml-cpp/emitterdef.h
/usr/include/yaml-cpp/emittermanip.h
/usr/include/yaml-cpp/emitterstyle.h
/usr/include/yaml-cpp/eventhandler.h
/usr/include/yaml-cpp/exceptions.h
/usr/include/yaml-cpp/mark.h
/usr/include/yaml-cpp/noncopyable.h
/usr/include/yaml-cpp/null.h
/usr/include/yaml-cpp/ostream_wrapper.h
/usr/include/yaml-cpp/parser.h
/usr/include/yaml-cpp/stlemitter.h
/usr/include/yaml-cpp/traits.h
/usr/include/yaml-cpp/yaml.h
/usr/include/yaml-cpp/contrib/anchordict.h
/usr/include/yaml-cpp/contrib/graphbuilder.h
/usr/include/yaml-cpp/node/convert.h
/usr/include/yaml-cpp/node/emit.h
/usr/include/yaml-cpp/node/impl.h
/usr/include/yaml-cpp/node/iterator.h
/usr/include/yaml-cpp/node/node.h
/usr/include/yaml-cpp/node/parse.h
/usr/include/yaml-cpp/node/ptr.h
/usr/include/yaml-cpp/node/type.h
/usr/include/yaml-cpp/node/detail/bool_type.h
/usr/include/yaml-cpp/node/detail/impl.h
/usr/include/yaml-cpp/node/detail/iterator.h
/usr/include/yaml-cpp/node/detail/iterator_fwd.h
/usr/include/yaml-cpp/node/detail/memory.h
/usr/include/yaml-cpp/node/detail/node.h
/usr/include/yaml-cpp/node/detail/node_data.h
/usr/include/yaml-cpp/node/detail/node_iterator.h
/usr/include/yaml-cpp/node/detail/node_ref.h
/usr/lib/libyaml-cpp.so
/usr/lib/cmake/yaml-cpp/yaml-cpp-config-version.cmake
/usr/lib/cmake/yaml-cpp/yaml-cpp-config.cmake
/usr/lib/cmake/yaml-cpp/yaml-cpp-targets-release.cmake
/usr/lib/cmake/yaml-cpp/yaml-cpp-targets.cmake
/usr/lib/pkgconfig/yaml-cpp.pc

Changelog

2018-10-22 - Aleksei Nikiforov <darktemplar@altlinux.org> 0.6.2-alt2
- Applied patches from Fedora (Fixes: CVE-2017-5950)
2018-09-11 - Aleksei Nikiforov <darktemplar@altlinux.org> 0.6.2-alt1
- Updated to upstream version 0.6.2.
2015-12-01 - Vladimir Didenko <cow@altlinux.ru> 0.5.1-alt4
- Rebuild with gcc5
2015-03-24 - Vladimir Didenko <cow@altlinux.ru> 0.5.1-alt3
- spec cleanup
- add dependency on corresponding library to devel package
2014-06-07 - Andrew Clark <andyc@altlinux.ru> 0.5.1-alt2
- spec file has been changed
2014-05-29 - Andrew Clark <andyc@altlinux.ru> 0.5.1-alt1
- initial build for ALT Linux

See Also

Package Description
libyaml-cpp0-0.6.2-alt2.i586.rpm A YAML parser and emitter for C++
libyaml-devel-0.2.2-alt1.i586.rpm Header files for the yaml library
libyaml2-0.2.2-alt1.i586.rpm A C library for parsing and emitting YAML
libyasm-devel-1.2.0-alt1.i586.rpm YASM Development libraries
libyaz-5.25.0-alt3.i586.rpm Z39.50 shared libraries
libyaz-devel-5.25.0-alt3.i586.rpm Development files for the Z39.50 library YAZ
libyelp-3.34.0-alt1.i586.rpm Shared library for Yelp
libyelp-devel-3.34.0-alt1.i586.rpm Development files for Yelp library
libyices-2.3.0-alt3.i586.rpm Shared libraries of yices
libyices-devel-2.3.0-alt3.i586.rpm Development files of yices
libyrmcds-1.2.1-alt1_3.i586.rpm A memcached client library written in C
libyrmcds-devel-1.2.1-alt1_3.i586.rpm Development library for libyrmcds
libyrmcds0-1.2.1-alt1_3.i586.rpm Shared memcached client library
libytnef-1.9.3-alt1.i586.rpm TNEF Stream Parser Library
libytnef-devel-1.9.3-alt1.i586.rpm Development files for libytnef
Advertisement
Advertisement