ltspfsd-0.3-alt0.2.2.qa1.i586.rpm


Advertisement

Description

ltspfsd - Tool used to mount local media on an Xterminal from the terminals server

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename ltspfsd-0.3-alt0.2.2.qa1.i586.rpm
Package name ltspfsd
Package version 0.3
Package release alt0.2.2.qa1
Package architecture i586
Package type rpm
Category Networking/Other
Homepage -
License -
Maintainer -
Download size 23.17 KB
Installed size 23.17 KB
ltspfs is a remote filesystem consisting of two parts:
1) A network server daemon that runs on the LTSP terminal.
2) A FUSE module that runs in user-space on the server, that connects
with the daemon on the client.
The goals of ltspfs are:
1. Provide a lightweight file access mechanism that will be feasable
on lower end hardware.
2. Provide a stateless file access method that will feature "atomic"
reads and writes to minimize impact from client network
disruptions.
3. Provide a network filesystem that handles client reboots and
disconnections in a manner that doesn't leave inaccesible,
unmountable filesystems on the LTSP server.
4. Provide a network filesystem that can easily handle the oddities
of dealing with removable media, and integrate well with udev
(LTSP's preferred device handling support).

Alternatives

Package Version Architecture Repository
ltspfsd-0.3-alt0.2.2.qa1.x86_64.rpm 0.3 x86_64 Classic
ltspfsd - - -

Requires

Name Value
/lib/ld-linux.so.2 -
coreutils -
fuse >= 2.5.2
grep -
libX11.so.6 -
libXau.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.1) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
mount -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
ltspfsd = 0.3-alt0.2.2.qa1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package ltspfsd-0.3-alt0.2.2.qa1.i586.rpm
Source Package ltspfsd-0.3-alt0.2.2.qa1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install ltspfsd rpm package:
    # sudo apt-get install ltspfsd

Files

Path
/sbin/ltspfs_mount
/sbin/ltspfs_umount
/usr/sbin/ltspfsd
/usr/share/doc/ltspfsd-0.3/AUTHORS
/usr/share/doc/ltspfsd-0.3/README
/usr/share/man/man1/ltspfsd.1.gz

Changelog

2013-04-19 - Dmitry V. Levin (QA) <qa_ldv@altlinux.org> 0.3-alt0.2.2.qa1
- NMU: rebuilt for updated dependencies.
2012-07-12 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 0.3-alt0.2.2
- Fixed build
2009-02-23 - Michael Shigorin <mike@altlinux.org> 0.3-alt0.2.1
- NMU: updated BuildRequires
2007-05-16 - Led <led@altlinux.ru> 0.3-alt0.2
- fixed mount/umount scripts names
- fixed ltspfs_umount
- replaced ltspfsd-0.2-mount_hal.patch with ltspfsd-0.3-mount_hal+info.patch

See Also

Package Description
ltspinfod-0.1-alt2.i586.rpm Tool to get info from LTSP clients
ltxml-1.2.7-alt2.1.i586.rpm LT XML toolkit
ltxml-devel-1.2.7-alt2.1.i586.rpm LT XML API libraries and header files
lua-md5-1.1.2-alt1_12.i586.rpm Cryptographic Library for MD5 hashes for Lua
lua-mpack-1.0.4-alt2_2.i586.rpm Implementation of MessagePack for Lua
lua-prelude-5.0.0-alt2.i586.rpm Lua bindings for prelude
lua5.1-5.1.5-alt15.i586.rpm Embeddable programming language
lua5.1-luarocks-2.4.2-alt7.i586.rpm A deployment and management system for Lua modules
lua5.1-module-lpeg-1.0.2-alt1_lr1.i586.rpm Parsing Expression Grammars For Lua
lua5.1-module-luafilesystem-1.7.0-alt1_lr2.i586.rpm File System Library for the Lua Programming Language
lua5.1-module-luasocket-3.0rc1-alt3_lr2.i586.rpm Network support for the Lua language
lua5.3-5.3.5-alt2.i586.rpm Powerful light-weight programming language
lua5.3-luarocks-2.4.2-alt7.i586.rpm A deployment and management system for Lua modules
lua5.3-module-lpeg-1.0.2-alt1_lr1.i586.rpm Parsing Expression Grammars For Lua
lua5.3-module-luaexpat-1.3.3-alt1_lr1.i586.rpm XML Expat parsing
Advertisement
Advertisement