ocaml-ocamlfuse-2.7.1-alt8.i586.rpm


Advertisement

Description

ocaml-ocamlfuse - Ocaml FUSE binding

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename ocaml-ocamlfuse-2.7.1-alt8.i586.rpm
Package name ocaml-ocamlfuse
Package version 2.7.1
Package release alt8
Package architecture i586
Package type rpm
Category Development/ML
Homepage -
License -
Maintainer -
Download size 134.00 KB
Installed size 134.00 KB
This is a binding to fuse for the ocaml programming language, enabling
you to write multithreaded filesystems in the ocaml language. It has
been designed with simplicity as a goal, as you can see by looking at
example/fusexmp.ml. Efficiency has also been a separate goal. The
Bigarray library is used for read and writes, allowing the library to
do zero-copy in ocaml land.

Alternatives

Package Version Architecture Repository
ocaml-ocamlfuse-2.7.1-alt8.x86_64.rpm 2.7.1 x86_64 Classic
ocaml-ocamlfuse - - -

Requires

Name Value
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libfuse -
libfuse.so.2 -
libfuse.so.2(FUSE_2.2) -
libfuse.so.2(FUSE_2.6) -
libfuse.so.2(FUSE_2.8) -
ocaml-camlidl-devel -
ocaml-cmi(Bigarray) = 4.07-5F83CFC1
ocaml-cmi(CamlinternalFormatBasics) = 4.07-E065A8B8
ocaml-cmi(Com) = 4.07-968673F5
ocaml-cmi(Condition) = 4.07-13B57FF2
ocaml-cmi(Mutex) = 4.07-1388795B
ocaml-cmi(Stdlib) = 4.07-785BC435
ocaml-cmi(Stdlib__bigarray) = 4.07-FC1AA91C
ocaml-cmi(Stdlib__callback) = 4.07-88A8ECEA
ocaml-cmi(Stdlib__complex) = 4.07-E9BB8037
ocaml-cmi(Stdlib__hashtbl) = 4.07-604C8339
ocaml-cmi(Stdlib__list) = 4.07-6AC77BA2
ocaml-cmi(Stdlib__seq) = 4.07-5714D5DA
ocaml-cmi(Stdlib__string) = 4.07-CF3A35A6
ocaml-cmi(Thread) = 4.07-8FCDEF24
ocaml-cmi(Unix) = 4.07-DF164073
ocaml-runtime = 4.07
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
ocaml-cmi(Fuse) = 4.07-353E7879
ocaml-cmi(Fuse__) = 4.07-21574672
ocaml-cmi(Fuse__Fuse_bindings) = 4.07-840BFF82
ocaml-cmi(Fuse__Fuse_lib) = 4.07-02133ABA
ocaml-cmi(Fuse__Fuse_result) = 4.07-23D65886
ocaml-cmi(Fuse__Thread_pool) = 4.07-AD54EEC9
ocaml-cmi(Fuse__Unix_util) = 4.07-2C955BFF
ocaml-dll(fuse_stubs) -
ocaml-fuse = 2.7.1-alt8
ocaml-ocamlfuse = 2.7.1-alt8:sisyphus+226783.200.1.1

Obsoletes

Name Value
ocaml-fuse < 2.7.1-alt8

Download

Type URL
Mirror ftp.altlinux.org
Binary Package ocaml-ocamlfuse-2.7.1-alt8.i586.rpm
Source Package ocaml-ocamlfuse-2.7.1-alt8.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install ocaml-ocamlfuse rpm package:
    # sudo apt-get install ocaml-ocamlfuse

Files

Path
/usr/lib/ocaml/ocamlfuse/Fuse.cmi
/usr/lib/ocaml/ocamlfuse/META
/usr/lib/ocaml/ocamlfuse/fuse.cma
/usr/lib/ocaml/ocamlfuse/fuse__.cmi
/usr/lib/ocaml/ocamlfuse/fuse__Fuse_bindings.cmi
/usr/lib/ocaml/ocamlfuse/fuse__Fuse_lib.cmi
/usr/lib/ocaml/ocamlfuse/fuse__Fuse_result.cmi
/usr/lib/ocaml/ocamlfuse/fuse__Thread_pool.cmi
/usr/lib/ocaml/ocamlfuse/fuse__Unix_util.cmi
/usr/lib/ocaml/stublibs/dllfuse_stubs.so
/usr/share/doc/ocaml-ocamlfuse-2.7.1/LICENSE
/usr/share/doc/ocaml-ocamlfuse-2.7.1/README.md

Changelog

2019-04-06 - Anton Farygin <rider@altlinux.ru> 2.7.1-alt8
- renamed to ocaml-ocamlfuse
- build from upstream git with dune
2018-10-18 - Anton Farygin <rider@altlinux.ru> 2.7.1-alt7
- rebuilt with ocaml-4.07.1
2018-09-05 - Anton Farygin <rider@altlinux.ru> 2.7.1-alt6
- rebuilt with ocaml 4.07
2018-05-19 - Anton Farygin <rider@altlinux.ru> 2.7.1-alt5
- rebuilt for ocaml 4.06.1
2017-07-11 - Anton Farygin <rider@altlinux.ru> 2.7.1-alt4
- rebuild with ocaml 4.04.2
2017-05-03 - Anton Farygin <rider@altlinux.ru> 2.7.1-alt3
- rebuild with ocaml 4.04.1
2017-04-21 - Anton Farygin <rider@altlinux.ru> 2.7.1-alt2
- split to devel and runtime
2017-02-13 - Anton Farygin <rider@altlinux.ru> 2.7.1-alt1
- first build for ALT, version 2.7.1.cvs4

See Also

Package Description
ocaml-ocamlfuse-devel-2.7.1-alt8.i586.rpm Development files for ocaml-ocamlfuse
ocaml-ocamlgraph-1.8.8-alt4.i586.rpm OCaml library for arc and node graphs
ocaml-ocamlgraph-devel-1.8.8-alt4.i586.rpm Development files for ocaml-ocamlgraph
ocaml-ocamlgraph-tools-1.8.8-alt4.i586.rpm Graph editing tools for ocaml-ocamlgraph
ocaml-ocamlnet-4.1.6-alt4.i586.rpm Network protocols for OCaml
ocaml-ocamlnet-devel-4.1.6-alt4.i586.rpm Development files for ocaml-ocamlnet
ocaml-ocamlnet-nethttpd-4.1.6-alt4.i586.rpm Ocamlnet HTTP daemon
ocaml-ocamlnet-nethttpd-devel-4.1.6-alt4.i586.rpm Development files for ocaml-ocamlnet-nethttpd
ocaml-odoc-1.4.1-alt1.i586.rpm Documentation compiler for OCaml and Reason
ocaml-omake-0.10.3-alt2.i586.rpm Build system with automated dependency analysis
ocaml-omd-1.3.1-alt2.i586.rpm OMD: extensible Markdown library and tool in OCaml
ocaml-omd-devel-1.3.1-alt2.i586.rpm Development files for ocaml-omd
ocaml-opam-file-format-2.0.0-alt4.i586.rpm Parser and printer for the opam file syntax
ocaml-opam-file-format-devel-2.0.0-alt4.i586.rpm Development files for ocaml-opam-file-format
ocaml-ounit-2.0.8-alt4.i586.rpm Unit test framework for OCaml
Advertisement
Advertisement