ocaml-react-1.2.1-alt4.i586.rpm


Advertisement

Description

ocaml-react - Development files for ocaml-react

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename ocaml-react-1.2.1-alt4.i586.rpm
Package name ocaml-react
Package version 1.2.1
Package release alt4
Package architecture i586
Package type rpm
Category Development/ML
Homepage -
License -
Maintainer -
Download size 58.14 KB
Installed size 58.14 KB
React is an OCaml module for functional reactive programming (FRP).
It provides support to program with time varying values : applicative
events and signals. React doesn't define any primitive event or signal,
this lets the client chooses the concrete timeline.
React is made of a single, independent, module and distributed under
the new BSD license.
Given an absolute notion of time Rtime helps you to manage a timeline
and provides time stamp events, delayed events and delayed signals.

Alternatives

Package Version Architecture Repository
ocaml-react-1.2.1-alt4.x86_64.rpm 1.2.1 x86_64 Classic
ocaml-react - - -

Requires

Name Value
ocaml-react-runtime = 1.2.1-alt4:sisyphus+235061.2300.23.1
rpm-build-ocaml >= 1.1.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
ocaml-cmx(React) = 4.08-0C62A23B
ocaml-cmx(React_top) = 4.08-AEB8CE76
ocaml-react = 1.2.1-alt4:sisyphus+235061.2300.23.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package ocaml-react-1.2.1-alt4.i586.rpm
Source Package ocaml-react-1.2.1-alt4.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install ocaml-react rpm package:
    # sudo apt-get install ocaml-react

Files

Path
/usr/lib/ocaml/react/react.cmx
/usr/lib/ocaml/react/react.mli
/usr/lib/ocaml/react/react_top.cmx

Changelog

2019-07-31 - Anton Farygin <rider@altlinux.ru> 1.2.1-alt4
- rebuilt with ocaml-4.08
2018-10-23 - Anton Farygin <rider@altlinux.ru> 1.2.1-alt3
- fixed the version repesentation for ocaml findlib
- installation method changed to opam-installer
2018-10-18 - Anton Farygin <rider@altlinux.ru> 1.2.1-alt2
- rebuilt with ocaml-4.07.1
2018-09-05 - Anton Farygin <rider@altlinux.ru> 1.2.1-alt1
- 1.2.1
2018-05-18 - Anton Farygin <rider@altlinux.ru> 1.2.0-alt4
- rebuilt for ocaml 4.06.1
2017-07-11 - Anton Farygin <rider@altlinux.ru> 1.2.0-alt3
- rebuild with ocaml 4.04.2
2017-05-03 - Anton Farygin <rider@altlinux.ru> 1.2.0-alt2
- rebuild with ocaml 4.04.1
2017-04-11 - Anton Farygin <rider@altlinux.ru> 1.2.0-alt1
- new version
2011-12-27 - Alexey Shabalin <shaba@altlinux.ru> 0.9.2-alt1
- initial build for ALT Linux Sisyphus

See Also

Package Description
ocaml-react-runtime-1.2.1-alt4.i586.rpm OCaml module for Functional Reactive Programming (FRP)
ocaml-reactiveData-0.2.2-alt1.i586.rpm Functional reactive programming with incremental changes in data structures
ocaml-reactiveData-devel-0.2.2-alt1.i586.rpm Development files for programs which will use the ocaml-reactiveData
ocaml-result-1.4-alt2.i586.rpm Compat result type
ocaml-result-devel-1.4-alt2.i586.rpm Development files for ocaml-result
ocaml-rresult-0.6.0-alt2.i586.rpm Result value combinators for OCaml
ocaml-rresult-devel-0.6.0-alt2.i586.rpm Development files for programs which will use the ocaml-rresult
ocaml-runtime-4.08.1-alt1.i586.rpm Runtime part of the OCaml system
ocaml-sexplib-0.12.0-alt1.i586.rpm OCaml library for converting OCaml values to S-expressions
ocaml-sexplib-devel-0.12.0-alt1.i586.rpm Development files for ocaml-sexplib
ocaml-sexplib0-0.12.0-alt1.i586.rpm OCaml library for converting OCaml values to S-expressions
ocaml-sexplib0-devel-0.12.0-alt1.i586.rpm Development files for ocaml-sexplib0
ocaml-sqlite3-4.4.1-alt1.i586.rpm OCaml library for accessing SQLite3 databases
ocaml-sqlite3-runtime-4.4.1-alt1.i586.rpm OCaml library for accessing SQLite3 databases
ocaml-ssl-0.5.9-alt1.i586.rpm OCaml bindings for the OpenSSL library
Advertisement
Advertisement