perl-Params-Validate-1.29-alt1.2.i586.rpm


Advertisement

Description

perl-Params-Validate - Validate method/function parameters

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename perl-Params-Validate-1.29-alt1.2.i586.rpm
Package name perl-Params-Validate
Package version 1.29
Package release alt1.2
Package architecture i586
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 169.45 KB
Installed size 169.45 KB
The Params::Validate module allows you to validate method or function
call parameters to an arbitrary level of specificity.  At the simplest
level, it is capable of validating the required parameters were given
and that no unspecified additional parameters were passed in.

Alternatives

Package Version Architecture Repository
perl-Params-Validate-1.29-alt1.2.x86_64.rpm 1.29 x86_64 Classic
perl-Params-Validate - - -

Requires

Name Value
/usr/lib/perl5 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.4) -
libperl-5.28.so -
libpthread.so.0(GLIBC_2.0) -
perl(Module/Implementation.pm) -
perl(Scalar/Util.pm) >= 1.100
perl(XSLoader.pm) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
perl(Params/Validate.pm) = 1.290
perl(Params/Validate/Constants.pm) = 1.290
perl(Params/Validate/PP.pm) = 1.290
perl(Params/Validate/XS.pm) = 1.290
perl(Params/ValidatePP.pm) -
perl(Params/ValidateXS.pm) -
perl-Params-Validate = 1.29-alt1.2:sisyphus+219907.5600.1.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Params-Validate-1.29-alt1.2.i586.rpm
Source Package perl-Params-Validate-1.29-alt1.2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Params-Validate rpm package:
    # sudo apt-get install perl-Params-Validate

Files

Path
/usr/lib/perl5/Params/Validate.pm
/usr/lib/perl5/Params/ValidatePP.pm
/usr/lib/perl5/Params/ValidateXS.pm
/usr/lib/perl5/Params/Validate/Constants.pm
/usr/lib/perl5/Params/Validate/PP.pm
/usr/lib/perl5/Params/Validate/XS.pm
/usr/lib/perl5/auto/Params/
/usr/lib/perl5/auto/Params/Validate/
/usr/lib/perl5/auto/Params/Validate/XS/XS.so
/usr/share/doc/perl-Params-Validate-1.29/CONTRIBUTING.md
/usr/share/doc/perl-Params-Validate-1.29/Changes
/usr/share/doc/perl-Params-Validate-1.29/README.md

Changelog

2019-01-24 - Igor Vlasenko <viy@altlinux.ru> 1.29-alt1.2
- rebuild with new perl 5.28.1
2017-12-15 - Igor Vlasenko <viy@altlinux.ru> 1.29-alt1.1
- rebuild with new perl 5.26.1
2017-08-02 - Igor Vlasenko <viy@altlinux.ru> 1.29-alt1
- automated CPAN update
2017-05-09 - Igor Vlasenko <viy@altlinux.ru> 1.28-alt1
- automated CPAN update
2017-02-03 - Igor Vlasenko <viy@altlinux.ru> 1.26-alt1.1
- rebuild with new perl 5.24.1
2016-10-19 - Igor Vlasenko <viy@altlinux.ru> 1.26-alt1
- automated CPAN update
2016-05-26 - Igor Vlasenko <viy@altlinux.ru> 1.24-alt1
- automated CPAN update
2016-03-28 - Igor Vlasenko <viy@altlinux.ru> 1.23-alt1
- automated CPAN update
2016-03-03 - Igor Vlasenko <viy@altlinux.ru> 1.22-alt1
- automated CPAN update
2015-11-25 - Igor Vlasenko <viy@altlinux.ru> 1.21-alt1.1
- rebuild with new perl 5.22.0

See Also

Package Description
perl-Parse-ExuberantCTags-1.02-alt3.2.i586.rpm Efficiently parse exuberant ctags files
perl-Passwd-Linux-1.3-alt1.2.i586.rpm Perl module for manipulating the passwd and shadow files
perl-PathTools-3.75-alt1.i586.rpm Perl modules to work with file names
perl-Perl-Destruct-Level-0.02-alt5_21.i586.rpm Allows you to change perl's internal destruction level
perl-PerlIO-Layers-0.011-alt2_15.i586.rpm Querying your file handle capabilities
perl-PerlIO-Util-0.72-alt5.2.i586.rpm A selection of general PerlIO utilities
perl-PerlIO-eol-0.17-alt1.1.i586.rpm PerlIO layer for normalizing line endings
perl-PerlIO-gzip-0.20-alt1.2.i586.rpm A layer for the PerlIO system to transparently gzip/gunzip files
perl-PerlIO-utf8_strict-0.007-alt1.2.i586.rpm fast and correct UTF-8 IO module
perl-PerlX-Maybe-XS-1.001-alt5.1.i586.rpm XS backend for PerlX::Maybe
perl-Pg-2.1.1-alt4.2.i586.rpm PostgreSQL database native Perl driver
perl-Pg-PQ-0.15-alt1.2.i586.rpm Perl wrapper for PostgreSQL libpq
perl-Prima-1.56-alt1.i586.rpm Perl graphic toolkit
perl-Prima-Test-1.56-alt1.i586.rpm Test tools for Prima Perl graphic toolkit
perl-Proc-FastSpawn-1.2-alt1.2.i586.rpm fork+exec, or spawn, a subprocess as quickly as possible
Advertisement
Advertisement