postgresql10-python-10.10-alt1.i586.rpm


Advertisement

Description

postgresql10-python - Development module for Python code to access a PostgreSQL DB

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename postgresql10-python-10.10-alt1.i586.rpm
Package name postgresql10-python
Package version 10.10
Package release alt1
Package architecture i586
Package type rpm
Category Databases
Homepage -
License -
Maintainer -
Download size 279.72 KB
Installed size 279.72 KB
PostgreSQL is an advanced Object-Relational database management
system.  The postgresql-python package includes a module for
developers to use when writing Python code for accessing a PostgreSQL
database.

Alternatives

Package Version Architecture Repository
postgresql10-python-10.10-alt1.x86_64.rpm 10.10 x86_64 Classic
postgresql10-python - - -

Requires

Name Value
libpython2.7.so.1.0 -
postgresql10-server = 10.10-alt1:sisyphus+235637.500.1.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
postgresql-python = 10.10-alt1
postgresql10-python = 10.10-alt1:sisyphus+235637.500.1.1

Conflicts

Name Value
postgresql10-1C-python -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package postgresql10-python-10.10-alt1.i586.rpm
Source Package postgresql10-10.10-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install postgresql10-python rpm package:
    # sudo apt-get install postgresql10-python

Files

Path
/usr/lib/pgsql/plpython2.so
/usr/share/doc/postgresql-10.10
/usr/share/locale/cs/LC_MESSAGES/plpython-10.mo
/usr/share/locale/de/LC_MESSAGES/plpython-10.mo
/usr/share/locale/es/LC_MESSAGES/plpython-10.mo
/usr/share/locale/fr/LC_MESSAGES/plpython-10.mo
/usr/share/locale/it/LC_MESSAGES/plpython-10.mo
/usr/share/locale/ja/LC_MESSAGES/plpython-10.mo
/usr/share/locale/ko/LC_MESSAGES/plpython-10.mo
/usr/share/locale/pl/LC_MESSAGES/plpython-10.mo
/usr/share/locale/pt_BR/LC_MESSAGES/plpython-10.mo
/usr/share/locale/ru/LC_MESSAGES/plpython-10.mo
/usr/share/locale/sv/LC_MESSAGES/plpython-10.mo
/usr/share/locale/tr/LC_MESSAGES/plpython-10.mo
/usr/share/locale/zh_CN/LC_MESSAGES/plpython-10.mo
/usr/share/pgsql/extension/plpython2u--1.0.sql
/usr/share/pgsql/extension/plpython2u--unpackaged--1.0.sql
/usr/share/pgsql/extension/plpython2u.control
/usr/share/pgsql/extension/plpythonu--1.0.sql
/usr/share/pgsql/extension/plpythonu--unpackaged--1.0.sql
/usr/share/pgsql/extension/plpythonu.control

Changelog

2019-08-07 - Alexei Takaseev <taf@altlinux.org> 10.10-alt1
- 10.10 (Fixes CVE-2019-10208)
2019-06-20 - Alexei Takaseev <taf@altlinux.org> 10.9-alt1
- 10.9 (Fixes CVE-2019-10164)
2019-05-08 - Alexei Takaseev <taf@altlinux.org> 10.8-alt1
- 10.8
- (Fixes CVE-2019-10130)
2019-04-04 - Alexei Takaseev <taf@altlinux.org> 10.7-alt2
- Move *.control and *.sql files from -server to -contrib subpackage
(Fixes ALT#36271)
- Removed unnecessary minor version in package name libpq and libecpg
- Join subpackages libpq-devel, libecpg-devel and postgresql-devel to
one postgresql-devel subpackage
- Remove unneeded Conflicts like postgresqlX.Y
- Remove unneeded Conflicts < and > for all subpackages
- Rename postgresqlX-devel to postgresql-devel
- Add Requires to -server for -contrib, -perl, -python and -tcl and subpackages
- Remove unneeded Requires tcl >= 8.4.0-alt1 for -tcl subpackages
2019-02-14 - Alexei Takaseev <taf@altlinux.org> 10.7-alt1
- 10.7
- Build with ICU
- (ALT #35986)
2019-01-24 - Igor Vlasenko <viy@altlinux.ru> 10.6-alt1.1
- rebuild with new perl 5.28.1
2018-11-08 - Alexei Takaseev <taf@altlinux.org> 10.6-alt1
- 10.6
- (Fixes CVE-2018-16850)
2018-10-19 - Alexei Takaseev <taf@altlinux.org> 10.5-alt8
- Disable package libs for --without devel. This will provide
one set of libraries for all versions of the PG.
- Disable -devel and lib subpackages
2018-09-27 - Alexei Takaseev <taf@altlinux.org> 10.5-alt7
- Drop online_analyze and plantuner contribs - performance
degradation
2018-09-10 - Alexei Takaseev <taf@altlinux.org> 10.5-alt6
- Another fix conflicts with libpq5.10-1C

See Also

Package Description
postgresql10-server-10.10-alt1.i586.rpm The programs needed to create and run a PostgreSQL server
postgresql10-tcl-10.10-alt1.i586.rpm The PL/Tcl procedural language for PostgreSQL
postgresql11-11.5-alt2.i586.rpm PostgreSQL client programs and libraries
postgresql11-contrib-11.5-alt2.i586.rpm Contributed source and binaries distributed with PostgreSQL
postgresql11-perl-11.5-alt2.i586.rpm The PL/Perl procedural language for PostgreSQL
postgresql11-pg_partman-4.2.0-alt1.i586.rpm pg_partman is an extension to create and manage both time-based and serial-based table partition sets
postgresql11-pgpool-II-4.0.2-alt1.i586.rpm Postgresql extensions for pgpool-II
postgresql11-postgis-2.5.3-alt1.i586.rpm The PostGIS extension for PostgreSQL
postgresql11-python-11.5-alt2.i586.rpm Development module for Python code to access a PostgreSQL DB
postgresql11-server-11.5-alt2.i586.rpm The programs needed to create and run a PostgreSQL server
postgresql11-tcl-11.5-alt2.i586.rpm The PL/Tcl procedural language for PostgreSQL
postgresql12-12.0-alt2.i586.rpm PostgreSQL client programs and libraries
postgresql12-contrib-12.0-alt2.i586.rpm Contributed source and binaries distributed with PostgreSQL
postgresql12-perl-12.0-alt2.i586.rpm The PL/Perl procedural language for PostgreSQL
postgresql12-python-12.0-alt2.i586.rpm Development module for Python code to access a PostgreSQL DB
Advertisement
Advertisement