prosody-0.9.10-alt3.i586.rpm


Advertisement

Description

prosody - Modern XMPP communication server

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package name prosody
Package version 0.9.10
Package release alt3
Package architecture i586
Package type rpm
Installed size 891.50 KB
Download size 891.50 KB
Official Mirror ftp.altlinux.org
Modern XMPP communication server

Alternatives

Package Version Architecture Repository
prosody-0.9.10-alt3.x86_64.rpm 0.9.10 x86_64 Classic
prosody - - -

Requires

Name Value
/usr/bin/env -
/usr/sbin/groupadd -
/usr/sbin/post_service -
/usr/sbin/preun_service -
/usr/sbin/useradd -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.2) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.4) -
libcrypto.so.10 -
libidn.so.11 -
libidn.so.11(LIBIDN_1.0) -
lua-module-luaexpat -
lua-module-luafilesystem -
lua-module-luasec -
lua-module-luasocket -
lua5.3 -
openssl -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
prosody = 0.9.10-alt3

Download

Type URL
Binary Package prosody-0.9.10-alt3.i586.rpm
Source Package prosody-0.9.10-alt3.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install prosody rpm package:
    # sudo apt-get install prosody

Files

Path
/etc/prosody/prosody.cfg.example.lua
/etc/prosody/prosody.cfg.lua
/etc/prosody/certs/Makefile
/etc/prosody/certs/example.com.cnf
/etc/prosody/certs/example.com.crt
/etc/prosody/certs/example.com.key
/etc/prosody/certs/localhost.cnf
/etc/prosody/certs/localhost.crt
/etc/prosody/certs/localhost.key
/etc/prosody/certs/openssl.cnf
/lib/systemd/system/prosody.service
/usr/bin/prosody
/usr/bin/prosodyctl
/usr/lib/prosody/prosody.version
/usr/lib/prosody/core/certmanager.lua
/usr/lib/prosody/core/configmanager.lua
/usr/lib/prosody/core/hostmanager.lua
/usr/lib/prosody/core/loggingmanager.lua
/usr/lib/prosody/core/moduleapi.lua
/usr/lib/prosody/core/modulemanager.lua
/usr/lib/prosody/core/portmanager.lua
/usr/lib/prosody/core/rostermanager.lua
/usr/lib/prosody/core/s2smanager.lua
/usr/lib/prosody/core/sessionmanager.lua
/usr/lib/prosody/core/stanza_router.lua
/usr/lib/prosody/core/storagemanager.lua
/usr/lib/prosody/core/usermanager.lua
/usr/lib/prosody/modules/mod_admin_adhoc.lua
/usr/lib/prosody/modules/mod_admin_telnet.lua
/usr/lib/prosody/modules/mod_announce.lua
/usr/lib/prosody/modules/mod_auth_anonymous.lua
/usr/lib/prosody/modules/mod_auth_cyrus.lua
/usr/lib/prosody/modules/mod_auth_internal_hashed.lua
/usr/lib/prosody/modules/mod_auth_internal_plain.lua
/usr/lib/prosody/modules/mod_bosh.lua
/usr/lib/prosody/modules/mod_c2s.lua
/usr/lib/prosody/modules/mod_component.lua
/usr/lib/prosody/modules/mod_compression.lua
/usr/lib/prosody/modules/mod_dialback.lua
/usr/lib/prosody/modules/mod_disco.lua
/usr/lib/prosody/modules/mod_groups.lua
/usr/lib/prosody/modules/mod_http.lua
/usr/lib/prosody/modules/mod_http_errors.lua
/usr/lib/prosody/modules/mod_http_files.lua
/usr/lib/prosody/modules/mod_iq.lua
/usr/lib/prosody/modules/mod_lastactivity.lua
/usr/lib/prosody/modules/mod_legacyauth.lua
/usr/lib/prosody/modules/mod_message.lua
/usr/lib/prosody/modules/mod_motd.lua
/usr/lib/prosody/modules/mod_net_multiplex.lua
/usr/lib/prosody/modules/mod_offline.lua
/usr/lib/prosody/modules/mod_pep.lua
/usr/lib/prosody/modules/mod_ping.lua
/usr/lib/prosody/modules/mod_posix.lua
/usr/lib/prosody/modules/mod_presence.lua
/usr/lib/prosody/modules/mod_privacy.lua
/usr/lib/prosody/modules/mod_private.lua
/usr/lib/prosody/modules/mod_proxy65.lua
/usr/lib/prosody/modules/mod_pubsub.lua
/usr/lib/prosody/modules/mod_register.lua
/usr/lib/prosody/modules/mod_roster.lua
/usr/lib/prosody/modules/mod_saslauth.lua
/usr/lib/prosody/modules/mod_storage_internal.lua
/usr/lib/prosody/modules/mod_storage_none.lua
/usr/lib/prosody/modules/mod_storage_sql.lua
/usr/lib/prosody/modules/mod_time.lua
/usr/lib/prosody/modules/mod_tls.lua
/usr/lib/prosody/modules/mod_uptime.lua
/usr/lib/prosody/modules/mod_vcard.lua
/usr/lib/prosody/modules/mod_version.lua
/usr/lib/prosody/modules/mod_watchregistrations.lua
/usr/lib/prosody/modules/mod_welcome.lua
/usr/lib/prosody/modules/sql.lib.lua
/usr/lib/prosody/modules/adhoc/adhoc.lib.lua
/usr/lib/prosody/modules/adhoc/mod_adhoc.lua
/usr/lib/prosody/modules/mod_s2s/mod_s2s.lua
/usr/lib/prosody/modules/mod_s2s/s2sout.lib.lua
/usr/lib/prosody/modules/muc/mod_muc.lua
/usr/lib/prosody/modules/muc/muc.lib.lua
/usr/lib/prosody/modules/storage/mod_xep0227.lua
/usr/lib/prosody/modules/storage/sqlbasic.lib.lua
/usr/lib/prosody/modules/storage/xep227store.lib.lua
/usr/lib/prosody/net/adns.lua
/usr/lib/prosody/net/connlisteners.lua
/usr/lib/prosody/net/dns.lua
/usr/lib/prosody/net/http.lua
/usr/lib/prosody/net/httpserver.lua
/usr/lib/prosody/net/server.lua
/usr/lib/prosody/net/server_event.lua
/usr/lib/prosody/net/server_select.lua
/usr/lib/prosody/net/http/codes.lua
/usr/lib/prosody/net/http/parser.lua
/usr/lib/prosody/net/http/server.lua
/usr/lib/prosody/util/adhoc.lua
/usr/lib/prosody/util/array.lua
/usr/lib/prosody/util/caps.lua
/usr/lib/prosody/util/dataforms.lua
/usr/lib/prosody/util/datamanager.lua
/usr/lib/prosody/util/datetime.lua
/usr/lib/prosody/util/debug.lua
/usr/lib/prosody/util/dependencies.lua
/usr/lib/prosody/util/encodings.so
/usr/lib/prosody/util/envload.lua
/usr/lib/prosody/util/events.lua
/usr/lib/prosody/util/filters.lua
/usr/lib/prosody/util/hashes.so
/usr/lib/prosody/util/helpers.lua
/usr/lib/prosody/util/hmac.lua
/usr/lib/prosody/util/http.lua
/usr/lib/prosody/util/import.lua
/usr/lib/prosody/util/ip.lua
/usr/lib/prosody/util/iterators.lua
/usr/lib/prosody/util/jid.lua
/usr/lib/prosody/util/json.lua
/usr/lib/prosody/util/logger.lua
/usr/lib/prosody/util/multitable.lua
/usr/lib/prosody/util/net.so
/usr/lib/prosody/util/openssl.lua
/usr/lib/prosody/util/pluginloader.lua
/usr/lib/prosody/util/pposix.so
/usr/lib/prosody/util/prosodyctl.lua
/usr/lib/prosody/util/pubsub.lua
/usr/lib/prosody/util/rfc6724.lua
/usr/lib/prosody/util/sasl.lua
/usr/lib/prosody/util/sasl_cyrus.lua
/usr/lib/prosody/util/serialization.lua
/usr/lib/prosody/util/set.lua
/usr/lib/prosody/util/signal.so
/usr/lib/prosody/util/sql.lua
/usr/lib/prosody/util/stanza.lua
/usr/lib/prosody/util/template.lua
/usr/lib/prosody/util/termcolours.lua
/usr/lib/prosody/util/throttle.lua
/usr/lib/prosody/util/timer.lua
/usr/lib/prosody/util/uuid.lua
/usr/lib/prosody/util/watchdog.lua
/usr/lib/prosody/util/x509.lua
/usr/lib/prosody/util/xml.lua
/usr/lib/prosody/util/xmppstream.lua
/usr/lib/prosody/util/sasl/anonymous.lua
/usr/lib/prosody/util/sasl/digest-md5.lua
/usr/lib/prosody/util/sasl/plain.lua
/usr/lib/prosody/util/sasl/scram.lua
/usr/share/man/man1/prosodyctl.1.xz
/var/lib/prosody

Changelog

2017-08-31 - Eugene Prokopiev <enp@altlinux.ru> 0.9.10-alt3
- rebuild with lua5.3 fir sisyphus
2016-11-05 - Eugene Prokopiev <enp@altlinux.ru> 0.9.10-alt2
- remove lua-posix dependency
2016-11-01 - Eugene Prokopiev <enp@altlinux.ru> 0.9.10-alt1
- new version
- add unit and minimal config
2016-07-05 - Eugene Prokopiev <enp@altlinux.ru> 0.9.8-alt1
- inital build

See Also

Package Description
protobuf-c-compiler-1.3.0-alt1.i586.rpm Protocol Buffers Compiler
protobuf-compiler-3.5.2-alt1.i586.rpm Protocol Buffers Compiler
proxychains-3.1-alt2.i586.rpm HTTP CONNECT and SOCKS proxy server client
proxysql-1.4.2-alt1.S1.i586.rpm A high-performance MySQL proxy
psi-1.3-alt2.i586.rpm Psi Jabber client
psi-plugins-1.3-alt2.i586.rpm Plugins pack for psi
psi-plus-1.2.109-alt1.i586.rpm Psi+ Jabber client
psi-plus-plugin-attention-1.2.109-alt1.i586.rpm Attention support for psi-plus
psi-plus-plugin-autoreply-1.2.109-alt1.i586.rpm Autoreply support for psi-plus
psi-plus-plugin-birthdayreminder-1.2.109-alt1.i586.rpm Birthdayreminder support for psi-plus
psi-plus-plugin-chess-1.2.109-alt1.i586.rpm Chess forms support for psi-plus
psi-plus-plugin-cleaner-1.2.109-alt1.i586.rpm Cleaner support for psi-plus
psi-plus-plugin-clientswitcher-1.2.109-alt1.i586.rpm Client switcher support for psi-plus
psi-plus-plugin-conferencelogger-1.2.109-alt1.i586.rpm Conference logger support for psi-plus
psi-plus-plugin-contentdownloader-1.2.109-alt1.i586.rpm Content downloader support for psi-plus
Advertisement
Advertisement