python-module-pygobject-devel-2.28.7-alt1.i586.rpm


Advertisement

Description

python-module-pygobject-devel - Development files for pygobject

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename python-module-pygobject-devel-2.28.7-alt1.i586.rpm
Package name python-module-pygobject-devel
Package version 2.28.7
Package release alt1
Package architecture i586
Package type rpm
Category Development/Python
Homepage -
License -
Maintainer -
Download size 1.09 MB
Installed size 1.09 MB
Development files for pygobject.

Alternatives

Package Version Architecture Repository
python-module-pygobject-devel-2.28.7-alt1.x86_64.rpm 2.28.7 x86_64 Classic
python-module-pygobject-devel - - -

Requires

Name Value
/usr/bin/env -
/usr/bin/python -
/usr/lib/pkgconfig -
glib2-devel -
pkgconfig(gobject-2.0) -
python-base -
python-dev -
python-module-pygobject = 2.28.7-alt1
python2.7(ctypes) -
python2.7(distutils) -
python2.7(keyword) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
pkgconfig(pygobject-2.0) = 2.28.7
python-module-pygobject-devel = 2.28.7-alt1
python2.7(dsextras) -

Conflicts

Name Value
python-module-pygtk-devel <= 2.8.2-alt2.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package python-module-pygobject-devel-2.28.7-alt1.i586.rpm
Source Package python-module-pygobject-2.28.7-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install python-module-pygobject-devel rpm package:
    # sudo apt-get install python-module-pygobject-devel

Files

Path
/usr/bin/pygobject-codegen-2.0
/usr/include/python2.7/pygtk/pyglib.h
/usr/include/python2.7/pygtk/pygobject.h
/usr/lib/libpyglib-2.0-python.so
/usr/lib/pkgconfig/pygobject-2.0.pc
/usr/lib/python2.7/site-packages/gtk-2.0/dsextras.py
/usr/lib/python2.7/site-packages/gtk-2.0/dsextras.pyc
/usr/lib/python2.7/site-packages/gtk-2.0/dsextras.pyo
/usr/share/doc/python-module-pygobject-devel-2.28.7/AUTHORS
/usr/share/doc/python-module-pygobject-devel-2.28.7/NEWS
/usr/share/doc/python-module-pygobject-devel-2.28.7/README
/usr/share/doc/python-module-pygobject-devel-2.28.7/examples/Makefile
/usr/share/doc/python-module-pygobject-devel-2.28.7/examples/Makefile.am
/usr/share/doc/python-module-pygobject-devel-2.28.7/examples/Makefile.in
/usr/share/doc/python-module-pygobject-devel-2.28.7/examples/cairo-demo.py
/usr/share/doc/python-module-pygobject-devel-2.28.7/examples/option.py
/usr/share/doc/python-module-pygobject-devel-2.28.7/examples/properties.py
/usr/share/doc/python-module-pygobject-devel-2.28.7/examples/signal.py
/usr/share/pygobject/2.0/
/usr/share/pygobject/2.0/codegen/__init__.py
/usr/share/pygobject/2.0/codegen/__init__.pyc
/usr/share/pygobject/2.0/codegen/__init__.pyo
/usr/share/pygobject/2.0/codegen/argtypes.py
/usr/share/pygobject/2.0/codegen/argtypes.pyc
/usr/share/pygobject/2.0/codegen/argtypes.pyo
/usr/share/pygobject/2.0/codegen/code-coverage.py
/usr/share/pygobject/2.0/codegen/codegen.py
/usr/share/pygobject/2.0/codegen/createdefs.py
/usr/share/pygobject/2.0/codegen/definitions.py
/usr/share/pygobject/2.0/codegen/definitions.pyc
/usr/share/pygobject/2.0/codegen/definitions.pyo
/usr/share/pygobject/2.0/codegen/defsconvert.py
/usr/share/pygobject/2.0/codegen/defsgen.py
/usr/share/pygobject/2.0/codegen/defsparser.py
/usr/share/pygobject/2.0/codegen/defsparser.pyc
/usr/share/pygobject/2.0/codegen/defsparser.pyo
/usr/share/pygobject/2.0/codegen/docextract.py
/usr/share/pygobject/2.0/codegen/docextract.pyc
/usr/share/pygobject/2.0/codegen/docextract.pyo
/usr/share/pygobject/2.0/codegen/docextract_to_xml.py
/usr/share/pygobject/2.0/codegen/docgen.py
/usr/share/pygobject/2.0/codegen/h2def.py
/usr/share/pygobject/2.0/codegen/mergedefs.py
/usr/share/pygobject/2.0/codegen/missingdefs.py
/usr/share/pygobject/2.0/codegen/mkskel.py
/usr/share/pygobject/2.0/codegen/override.py
/usr/share/pygobject/2.0/codegen/override.pyc
/usr/share/pygobject/2.0/codegen/override.pyo
/usr/share/pygobject/2.0/codegen/reversewrapper.py
/usr/share/pygobject/2.0/codegen/reversewrapper.pyc
/usr/share/pygobject/2.0/codegen/reversewrapper.pyo
/usr/share/pygobject/2.0/codegen/scanvirtuals.py
/usr/share/pygobject/2.0/codegen/scmexpr.py
/usr/share/pygobject/2.0/defs/gappinfo.override
/usr/share/pygobject/2.0/defs/gapplaunchcontext.override
/usr/share/pygobject/2.0/defs/gbufferedinputstream.override
/usr/share/pygobject/2.0/defs/gcancellable.override
/usr/share/pygobject/2.0/defs/gdatainputstream.override
/usr/share/pygobject/2.0/defs/gdrive.override
/usr/share/pygobject/2.0/defs/gfile.override
/usr/share/pygobject/2.0/defs/gfileattribute.override
/usr/share/pygobject/2.0/defs/gfileenumerator.override
/usr/share/pygobject/2.0/defs/gfileinfo.override
/usr/share/pygobject/2.0/defs/gfileinputstream.override
/usr/share/pygobject/2.0/defs/gfileiostream.override
/usr/share/pygobject/2.0/defs/gfileoutputstream.override
/usr/share/pygobject/2.0/defs/gicon.override
/usr/share/pygobject/2.0/defs/ginputstream.override
/usr/share/pygobject/2.0/defs/gio-types.defs
/usr/share/pygobject/2.0/defs/gio.defs
/usr/share/pygobject/2.0/defs/gio.override
/usr/share/pygobject/2.0/defs/giostream.override
/usr/share/pygobject/2.0/defs/gmemoryinputstream.override
/usr/share/pygobject/2.0/defs/gmemoryoutputstream.override
/usr/share/pygobject/2.0/defs/gmount.override
/usr/share/pygobject/2.0/defs/goutputstream.override
/usr/share/pygobject/2.0/defs/gresolver.override
/usr/share/pygobject/2.0/defs/gsocket.override
/usr/share/pygobject/2.0/defs/gvolume.override
/usr/share/pygobject/2.0/defs/gvolumemonitor.override
/usr/share/pygobject/2.0/defs/unix-types.defs
/usr/share/pygobject/2.0/defs/unix.defs
/usr/share/pygobject/2.0/defs/unix.override
/usr/share/pygobject/xsl/common.xsl
/usr/share/pygobject/xsl/devhelp.xsl
/usr/share/pygobject/xsl/fixxref.py
/usr/share/pygobject/xsl/html.xsl
/usr/share/pygobject/xsl/pdf-style.xsl
/usr/share/pygobject/xsl/pdf.xsl
/usr/share/pygobject/xsl/ref-html-style.xsl

Changelog

2017-12-21 - Yuri N. Sedunov <aris@altlinux.org> 2.28.7-alt1
- 2.28.7
2016-03-31 - Denis Medvedev <nbr@altlinux.org> 2.28.6-alt4
- Removed LD_PRELOAD, added macros needed for python3.5
2012-04-13 - Yuri N. Sedunov <aris@altlinux.org> 2.28.6-alt3
- updated to latest pygobject-2-28 (42d01f0)
- no more libpython dependencies
2011-10-30 - Vitaly Kuznetsov <vitty@altlinux.ru> 2.28.6-alt2.1
- Rebuild with Python-2.7
2011-09-11 - Yuri N. Sedunov <aris@altlinux.org> 2.28.6-alt2
- disabled introspection support
2011-06-14 - Yuri N. Sedunov <aris@altlinux.org> 2.28.6-alt1
- 2.28.6
2011-04-18 - Yuri N. Sedunov <aris@altlinux.org> 2.28.4-alt1
- 2.28.4
2011-03-23 - Yuri N. Sedunov <aris@altlinux.org> 2.28.3-alt1
- 2.28.3
2011-03-23 - Yuri N. Sedunov <aris@altlinux.org> 2.28.2-alt1
- 2.28.2
2011-03-21 - Yuri N. Sedunov <aris@altlinux.org> 2.28.1-alt1
- 2.28.1
- fixed link

See Also

Package Description
python-module-pygobject3-3.34.0-alt1.i586.rpm Python bindings for GObject
python-module-pygobject3-common-devel-3.34.0-alt1.i586.rpm Common development files for pygobject
python-module-pygobject3-pygtkcompat-3.34.0-alt1.i586.rpm PyGTK compatibility layer for PyGObject
python-module-pygoocanvas-0.14.1-alt1.1.1.i586.rpm GooCanvas python bindings
python-module-pygoocanvas-devel-0.14.1-alt1.1.1.i586.rpm GooCanvas python bindings - Development files
python-module-pygraphviz-1.5-alt3.i586.rpm Python wrapper for the Graphviz Agraph data structure
python-module-pygraphviz-tests-1.5-alt3.i586.rpm Tests for pygraphviz
python-module-pygsl-2.2.0-alt1.i586.rpm Python interface for GNU Scientific Library (GSL)
python-module-pygsl-testing-2.2.0-alt1.i586.rpm Tests for Python interface for GSL
python-module-pygtk-2.24.0-alt7.i586.rpm Python bindings for the GTK+ widget set
python-module-pygtk-demo-2.24.0-alt7.i586.rpm PyGTK demo
python-module-pygtk-devel-2.24.0-alt7.i586.rpm files needed to build wrappers for GTK+ addon libraries
python-module-pygtk-libglade-2.24.0-alt7.i586.rpm A wrapper for the libglade library for use with PyGTK
python-module-pygtkglext-1.1.0-alt5.1.1.i586.rpm Python bindings for GtkGLExt
python-module-pygtkglext-devel-1.1.0-alt5.1.1.i586.rpm Development files for python-module-pygtkglext
Advertisement
Advertisement