python-module-pygtk-devel-2.24.0-alt6.i586.rpm


Advertisement

Description

python-module-pygtk-devel - files needed to build wrappers for GTK+ addon libraries

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename python-module-pygtk-devel-2.24.0-alt6.i586.rpm
Package name python-module-pygtk-devel
Package version 2.24.0
Package release alt6
Package architecture i586
Package type rpm
Category Development/Python
Homepage -
License -
Maintainer -
Download size 1.15 MB
Installed size 1.15 MB
This package contains files required to build wrappers for GTK+ addon
libraries so that they interoperate with pygtk.

Alternatives

Package Version Architecture Repository
python-module-pygtk-devel-2.24.0-alt6.x86_64.rpm 2.24.0 x86_64 Classic
python-module-pygtk-devel - - -

Requires

Name Value
/usr/lib/pkgconfig -
libgtk+2-devel -
pkgconfig(gtk+-2.0) -
pkgconfig(pygobject-2.0) -
python-dev -
python-module-pygobject-devel -
python-module-pygtk = 2.24.0-alt6
rpmlib(PayloadIsLzma) -

Provides

Name Value
pkgconfig(pygtk-2.0) = 2.24.1
python-module-pygtk-devel = 2.24.0-alt6

Download

Type URL
Mirror ftp.altlinux.org
Binary Package python-module-pygtk-devel-2.24.0-alt6.i586.rpm
Source Package python-module-pygtk-2.24.0-alt6.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install python-module-pygtk-devel rpm package:
    # sudo apt-get install python-module-pygtk-devel

Files

Path
/usr/bin/pygtk-codegen-2.0
/usr/include/python2.7/pygtk/pygtk/pygtk.h
/usr/lib/pkgconfig/pygtk-2.0.pc
/usr/share/pygtk/
/usr/share/pygtk/2.0/
/usr/share/pygtk/2.0/defs/atk-types.defs
/usr/share/pygtk/2.0/defs/atk.defs
/usr/share/pygtk/2.0/defs/gdk-2.10.defs
/usr/share/pygtk/2.0/defs/gdk-2.12.defs
/usr/share/pygtk/2.0/defs/gdk-2.14.defs
/usr/share/pygtk/2.0/defs/gdk-2.16.defs
/usr/share/pygtk/2.0/defs/gdk-2.18.defs
/usr/share/pygtk/2.0/defs/gdk-2.20.defs
/usr/share/pygtk/2.0/defs/gdk-2.22.defs
/usr/share/pygtk/2.0/defs/gdk-2.24.defs
/usr/share/pygtk/2.0/defs/gdk-base-types.defs
/usr/share/pygtk/2.0/defs/gdk-base.defs
/usr/share/pygtk/2.0/defs/gdk-types.defs
/usr/share/pygtk/2.0/defs/gdk.defs
/usr/share/pygtk/2.0/defs/gtk-2.10-types.defs
/usr/share/pygtk/2.0/defs/gtk-2.10.defs
/usr/share/pygtk/2.0/defs/gtk-2.12-types.defs
/usr/share/pygtk/2.0/defs/gtk-2.12.defs
/usr/share/pygtk/2.0/defs/gtk-2.14-types.defs
/usr/share/pygtk/2.0/defs/gtk-2.14.defs
/usr/share/pygtk/2.0/defs/gtk-2.16-types.defs
/usr/share/pygtk/2.0/defs/gtk-2.16.defs
/usr/share/pygtk/2.0/defs/gtk-2.18-types.defs
/usr/share/pygtk/2.0/defs/gtk-2.18.defs
/usr/share/pygtk/2.0/defs/gtk-2.20-types.defs
/usr/share/pygtk/2.0/defs/gtk-2.20.defs
/usr/share/pygtk/2.0/defs/gtk-2.22-types.defs
/usr/share/pygtk/2.0/defs/gtk-2.22.defs
/usr/share/pygtk/2.0/defs/gtk-2.24-types.defs
/usr/share/pygtk/2.0/defs/gtk-2.24.defs
/usr/share/pygtk/2.0/defs/gtk-base-types.defs
/usr/share/pygtk/2.0/defs/gtk-base.defs
/usr/share/pygtk/2.0/defs/gtk-extrafuncs.defs
/usr/share/pygtk/2.0/defs/gtk-types.defs
/usr/share/pygtk/2.0/defs/gtk.defs
/usr/share/pygtk/2.0/defs/gtkunixprint-2.12.defs
/usr/share/pygtk/2.0/defs/gtkunixprint-2.14.defs
/usr/share/pygtk/2.0/defs/gtkunixprint-base-types.defs
/usr/share/pygtk/2.0/defs/gtkunixprint-base.defs
/usr/share/pygtk/2.0/defs/libglade.defs
/usr/share/pygtk/2.0/defs/pango-types.defs
/usr/share/pygtk/2.0/defs/pango.defs
/usr/share/pygtk/2.0/defs/pangocairo.defs
/usr/share/pygtk/2.0/defs/pangocairo.override

Changelog

2013-09-30 - Yuri N. Sedunov <aris@altlinux.org> 2.24.0-alt6
- update to c524124 (fixed BGO #660216)
- fixed build
2012-10-09 - Yuri N. Sedunov <aris@altlinux.org> 2.24.0-alt5
- fixed %install
2012-05-21 - Yuri N. Sedunov <aris@altlinux.org> 2.24.0-alt4
- -devel subpackage requires python-module-pygobject-devel
2011-10-26 - Vitaly Kuznetsov <vitty@altlinux.ru> 2.24.0-alt3.1
- Rebuild with Python-2.7
2011-04-07 - Yuri N. Sedunov <aris@altlinux.org> 2.24.0-alt3
- numpy support turned back, some apps require it
2011-04-07 - Yuri N. Sedunov <aris@altlinux.org> 2.24.0-alt2
- numpy support disabled
2011-04-01 - Yuri N. Sedunov <aris@altlinux.org> 2.24.0-alt1
- 2.24.0
2011-03-25 - Yuri N. Sedunov <aris@altlinux.org> 2.23.2-alt1
- 2.23.2
2011-03-12 - Yuri N. Sedunov <aris@altlinux.org> 2.23.1-alt1
- 2.23.1
2011-03-10 - Yuri N. Sedunov <aris@altlinux.org> 2.23.0-alt2
- rebuild against current numpy (2.0.0-alt1.svn20100607.6)
- added explicit dependency on python-module-numpy-addons

See Also

Package Description
python-module-pygtk-libglade-2.24.0-alt6.i586.rpm A wrapper for the libglade library for use with PyGTK
python-module-pygtkglext-1.1.0-alt5.1.1.i586.rpm Python bindings for GtkGLExt
python-module-pygtkglext-devel-1.1.0-alt5.1.1.i586.rpm Development files for python-module-pygtkglext
python-module-pygtkimageview-1.1.0-alt1.1.1.1.i586.rpm PyGtkImageView is a set of Python bindings for GtkImageView
python-module-pygtksourceview-2.10.1-alt1.1.i586.rpm python bindings for the version 2 of the GtkSourceView library
python-module-pygtksourceview-devel-2.10.1-alt1.1.i586.rpm development files for GtkSourceView python binding
python-module-pygwy-2.49-alt1.1.i586.rpm Python tools for Gwyddion module development
python-module-pyhacrf-0.1.2-alt1.1.1.1.i586.rpm Hidden alignment conditional random field, discriminative string edit distance
python-module-pyices-0.2-alt2.git20140507.i586.rpm Python bindings for Yices SMT solver
python-module-pyices-tests-0.2-alt2.git20140507.i586.rpm Tests for pyices
python-module-pykcs11-1.4.3-alt1.i586.rpm A complete PKCS#11 wrapper for Python
python-module-pykcs11-docs-1.4.3-alt1.i586.rpm A complete PKCS#11 wrapper for Python
python-module-pylbfgs-0.2.0.12-alt1.i586.rpm LBFGS and OWL-QN optimization algorithms
python-module-pyldb-1.5.5-alt1.i586.rpm Python bindings for the LDB library
python-module-pyldb-devel-1.5.5-alt1.i586.rpm Development files for the Python bindings for the LDB library
Advertisement
Advertisement