python-module-pysubnettree-0.23-alt1.1.1.1.i586.rpm


Advertisement

Description

python-module-pysubnettree - Provides maps subnets given in CIDR notation to Python objects

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename python-module-pysubnettree-0.23-alt1.1.1.1.i586.rpm
Package name python-module-pysubnettree
Package version 0.23
Package release alt1.1.1.1
Package architecture i586
Package type rpm
Category Development/Python
Homepage -
License -
Maintainer -
Download size 78.33 KB
Installed size 78.33 KB
The PySubnetTree package provides a Python data structure SubnetTree
which maps subnets given in CIDR notation to Python objects. Lookups are
performed by longest-prefix matching.

Alternatives

Package Version Architecture Repository
python-module-pysubnettree-0.23-alt1.1.1.1.x86_64.rpm 0.23 x86_64 Classic
python-module-pysubnettree - - -

Requires

Name Value
/usr/lib/python2.7/site-packages -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1(GCC_3.0) -
libpthread.so.0(GLIBC_2.0) -
libpython2.7.so.1.0 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
python-module-pysubnettree = 0.23-alt1.1.1.1
python2.7(SubnetTree) -
python2.7(_SubnetTree) -

Obsoletes

Name Value
pysubnettree <= 0.12-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package python-module-pysubnettree-0.23-alt1.1.1.1.i586.rpm
Source Package python-module-pysubnettree-0.23-alt1.1.1.1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install python-module-pysubnettree rpm package:
    # sudo apt-get install python-module-pysubnettree

Files

Path
/usr/lib/python2.7/site-packages/SubnetTree.py
/usr/lib/python2.7/site-packages/SubnetTree.pyc
/usr/lib/python2.7/site-packages/SubnetTree.pyo
/usr/lib/python2.7/site-packages/_SubnetTree.so
/usr/lib/python2.7/site-packages/pysubnettree-0.23-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/pysubnettree-0.23-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/pysubnettree-0.23-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/pysubnettree-0.23-py2.7.egg-info/top_level.txt
/usr/share/doc/python-module-pysubnettree-0.23/CHANGES
/usr/share/doc/python-module-pysubnettree-0.23/COPYING
/usr/share/doc/python-module-pysubnettree-0.23/README

Changelog

2018-03-22 - Aleksei Nikiforov <darktemplar@altlinux.org> 0.23-alt1.1.1.1
- (NMU) Rebuilt with python-3.6.4.
2016-03-17 - Ivan Zakharyaschev <imz@altlinux.org> 0.23-alt1.1.1
- (NMU) rebuild with python3-3.5 & rpm-build-python3-0.1.10
(for ABI dependence and new python3(*) reqs)
2016-01-28 - Mikhail Efremov <sem@altlinux.org> 0.23-alt1.1
- NMU: Use buildreq for BR.
2014-08-25 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 0.23-alt1
- Version 0.23
- Added module for Python 3
2012-04-12 - Vitaly Kuznetsov <vitty@altlinux.ru> 0.12-alt2.2.1.1
- Rebuild to remove redundant libpython2.7 dependency
2011-10-20 - Vitaly Kuznetsov <vitty@altlinux.ru> 0.12-alt2.2.1
- Rebuild with Python-2.7
2011-03-29 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 0.12-alt2.2
- Rebuilt for debuginfo
2009-11-13 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 0.12-alt2.1
- Rebuilt with python 2.6
2009-03-09 - Slava Dubrovskiy <dubrsl@altlinux.org> 0.12-alt2
- Rename pysubnettree to python-module-pysubnettree
- Add Obsoletes: pysubnettree <= 0.12-alt1
2008-10-17 - Slava Dubrovskiy <dubrsl@altlinux.org> 0.12-alt1
- New version

See Also

Package Description
python-module-pysvn-1.9.10-alt1.i586.rpm Subversion support for python
python-module-pythonmagick-0.9.64-alt2.20170528.i586.rpm Object-oriented Python interface to ImageMagick
python-module-pyublas-2013.1-alt1.git20140620.1.1.2.i586.rpm Seamless Numpy-UBlas interoperability
python-module-pyublas-devel-2013.1-alt1.git20140620.1.1.2.i586.rpm Development files of PyUblas
python-module-pyublas-pickles-2013.1-alt1.git20140620.1.1.2.i586.rpm Pickles for PyUblas
python-module-pyuv-1.1.0-alt1.git20150619.1.1.1.i586.rpm Python interface for libuv
python-module-pyuv-pickles-1.1.0-alt1.git20150619.1.1.1.i586.rpm Pickles for pyuv
python-module-pyvorbis-1.4-alt2.i586.rpm A Python module for the the Ogg/Vorbis library
python-module-pywebkitgtk-1.1.8-alt1.1.1.i586.rpm Python Bindings for WebKit-gtk
python-module-pywm-1.0-alt1.i586.rpm Module python for WindowMaker docklets
python-module-pywrapper-2.4.0-alt2.i586.rpm Python wrapper for ALGENCAN
python-module-pyxattr-0.6.1-alt1.i586.rpm A python module for accessing filesystem Extended Attributes
python-module-pyxattr-docs-0.6.1-alt1.i586.rpm Documentation for pyxattr
python-module-pyxkb-0.1-alt2.2.1.1.i586.rpm Python module for the X Keyboard Extension (XKB)
python-module-pyxmpp-1.1.2-alt1.1.i586.rpm XMPP-IM-compliant library for jabber instant messenging
Advertisement
Advertisement