python-modules-curses-2.7.16-alt1.i586.rpm


Advertisement

Description

python-modules-curses - Python "curses" module

Property Value
Distribution ALT Linux Sisyphus
Repository Classic i586
Package filename python-modules-curses-2.7.16-alt1.i586.rpm
Package name python-modules-curses
Package version 2.7.16
Package release alt1
Package architecture i586
Package type rpm
Category Development/Python
Homepage -
License -
Maintainer -
Download size 142.21 KB
Installed size 142.21 KB
An interface to the curses library, providing portable terminal
handling. The Curses module provides an interface to the curses library, the
de-facto standard for portable advanced terminal handling.
This extension module is designed to match the API of ncurses, an
open-source curses library hosted on Linux and the BSD variants of UNIX.

Alternatives

Package Version Architecture Repository
python-modules-curses-2.7.16-alt1.x86_64.rpm 2.7.16 x86_64 Classic
python-modules-curses - - -

Requires

Name Value
libncursesw.so.5 -
libpanelw.so.5 -
libtinfo.so.5 -
python-base = 2.7.16-alt1:sisyphus+226365.200.2.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
python-modules-curses = 2.7.16-alt1:sisyphus+226365.200.2.1
python2.7(_curses) -
python2.7(_curses_panel) -
python2.7(curses) -
python2.7(curses.ascii) -
python2.7(curses.has_key) -
python2.7(curses.panel) -
python2.7(curses.textpad) -
python2.7(curses.wrapper) -

Obsoletes

Name Value
python2.7-modules-curses -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package python-modules-curses-2.7.16-alt1.i586.rpm
Source Package python-2.7.16-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus i586 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install python-modules-curses rpm package:
    # sudo apt-get install python-modules-curses

Files

Path
/usr/lib/python2.7/curses/__init__.py
/usr/lib/python2.7/curses/__init__.pyc
/usr/lib/python2.7/curses/__init__.pyo
/usr/lib/python2.7/curses/ascii.py
/usr/lib/python2.7/curses/ascii.pyc
/usr/lib/python2.7/curses/ascii.pyo
/usr/lib/python2.7/curses/has_key.py
/usr/lib/python2.7/curses/has_key.pyc
/usr/lib/python2.7/curses/has_key.pyo
/usr/lib/python2.7/curses/panel.py
/usr/lib/python2.7/curses/panel.pyc
/usr/lib/python2.7/curses/panel.pyo
/usr/lib/python2.7/curses/textpad.py
/usr/lib/python2.7/curses/textpad.pyc
/usr/lib/python2.7/curses/textpad.pyo
/usr/lib/python2.7/curses/wrapper.py
/usr/lib/python2.7/curses/wrapper.pyc
/usr/lib/python2.7/curses/wrapper.pyo
/usr/lib/python2.7/lib-dynload/_curses.so
/usr/lib/python2.7/lib-dynload/_curses_panel.so

Changelog

2019-04-01 - Gleb F-Malinovskiy <glebfm@altlinux.org> 2.7.16-alt1
- Updated to 2.7.16 (fixes FTBFS with openssl 1.1.1).
- Removed redundant R: alternatives.
2018-12-04 - Fr. Br. George <george@altlinux.ru> 2.7.15-alt1
- Version up (now builds with gcc8);
- fix check section LOCALE.
2018-08-29 - Grigory Ustinov <grenka@altlinux.org> 2.7.14-alt7.1
- NMU: Rebuild with new openssl 1.1.0.
2018-07-02 - Ivan Zakharyaschev <imz@altlinux.org> 2.7.14-alt7
- Made distutils install maximum Python minus python-dev
to mitigate the separation from python-dev (for building packages).
2018-06-29 - Ivan Zakharyaschev <imz@altlinux.org> 2.7.14-alt6
- move distutils into a separate pkg from python-dev
(because it can be used at runtime by other libs/executables).
2018-06-29 - Michael Shigorin <mike@altlinux.org> 2.7.14-alt5
- E2K:
+ support e2kv4 through %e2k macro (grenka@)
+ reworked -lcxa quirk towards lcc-1.23+ compatibility
2018-05-31 - Aleksei Nikiforov <darktemplar@altlinux.org> 2.7.14-alt4
- Fixed heap-use-after-free bug (Fixes: CVE-2018-1000030).
2018-05-30 - Andrey Bychkov <mrdrew@altlinux.org> 2.7.14-alt3.1
- added cleaning os-release parameters (patch25)
2018-05-28 - Aleksei Nikiforov <darktemplar@altlinux.org> 2.7.14-alt3
- NMU: updated runtime devel dependencies.
2018-03-22 - Ivan Zakharyaschev <imz@altlinux.org> 2.7.14-alt2
- buildreq's ignore list (thx grenka@):
+ Make buildreq ignore atomic .egg-info files
because they are read too often (ALT#34660)
+ Fix escaping of backslash in buildreq's ignore.d regular expression
- Kept nis module despite the deprecation of NIS in glibc because it
used to be a part of our standard "interface". Split nis from
python-modules so that the rebuild of dependents will make them
obtain an explicit dep on it. (python-modules will require it for a
while not to break the past promise.)
- Fixed detection of linux distribution (thx mrdrew)
- (e2k arch) Link against -lcxa (thx mike@, sem@)
- (.spec) Renamed bootstrap knob to bluez, enabled by default (thx mike@)
- (.spec) Enabled %check

See Also

Package Description
python-modules-distutils-2.7.16-alt1.i586.rpm Python "distutils" module
python-modules-email-2.7.16-alt1.i586.rpm A package for parsing, handling, and generating email messages
python-modules-encodings-2.7.16-alt1.i586.rpm Python "encodings" module
python-modules-ensurepip-2.7.16-alt1.i586.rpm Bootstrapping the pip installer
python-modules-hotshot-2.7.16-alt1.i586.rpm High-perfomance logging profiler, mostly written in C
python-modules-json-2.7.16-alt1.i586.rpm Python JSON encoder and decoder
python-modules-logging-2.7.16-alt1.i586.rpm Logging package for Python
python-modules-multiprocessing-2.7.16-alt1.i586.rpm Process-based threading interface for Python
python-modules-nis-2.7.16-alt1.i586.rpm NIS module from Python
python-modules-sqlite3-2.7.16-alt1.i586.rpm DB-API 2.0 interface for SQLite databases
python-modules-tkinter-2.7.16-alt1.i586.rpm A graphical user interface for the Python scripting language
python-modules-unittest-2.7.16-alt1.i586.rpm Unit testing framework for Python
python-modules-wsgiref-2.7.16-alt1.i586.rpm WSGI Utilities and Reference Implementation
python-modules-xml-2.7.16-alt1.i586.rpm Core XML support for Python
python-test-2.7.16-alt1.i586.rpm Test suite for standard python modules
Advertisement
Advertisement