apache2-mod_ssl-compat-2.4.41-alt1.noarch.rpm


Advertisement

Description

apache2-mod_ssl-compat - Set DocumentRoot in /var/www/apache2 (for https)

Property Value
Distribution ALT Linux Sisyphus
Repository Classic noarch
Package filename apache2-mod_ssl-compat-2.4.41-alt1.noarch.rpm
Package name apache2-mod_ssl-compat
Package version 2.4.41
Package release alt1
Package architecture noarch
Package type rpm
Category System/Servers
Homepage -
License -
Maintainer -
Download size unknown
Installed size unknown
Set DocumentRoot in /var/www/apache2 (for https) to support the old configurations.

Alternatives

Package Version Architecture Repository
apache2-mod_ssl-compat - - -

Requires

Name Value
apache2-compat = 1:2.4.41-alt1:sisyphus+236033.100.1.1
apache2-mod_ssl = 1:2.4.41-alt1:sisyphus+236033.100.1.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
apache2-mod_ssl-compat = 1:2.4.41-alt1:sisyphus+236033.100.1.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package apache2-mod_ssl-compat-2.4.41-alt1.noarch.rpm
Source Package apache2-2.4.41-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install apache2-mod_ssl-compat rpm package:
    # sudo apt-get install apache2-mod_ssl-compat

Files

Path
/etc/httpd2/conf/sites-enabled/000-default_https-compat.conf
/etc/httpd2/conf/sites-enabled/default_https-compat.conf

Changelog

2019-08-14 - Anton Farygin <rider@altlinux.ru> 1:2.4.41-alt1
- 2.4.41
2019-04-02 - Anton Farygin <rider@altlinux.ru> 1:2.4.39-alt1
- 2.4.39
- fixes:
* Apache HTTP Server privilege escalation from modules scripts. CVE-2019-0211
* mod_auth_digest access control bypass. CVE-2019-0217
* mod_ssl access control bypass. CVE-2019-0215
* Apache httpd URL normalization inconsistincy. CVE-2019-0220
2019-01-25 - Anton Farygin <rider@altlinux.ru> 1:2.4.38-alt1
- 2.4.38
- fixes:
* important: mod_ssl 2.4.37 remote DoS when used with OpenSSL 1.1.1. CVE-2019-0190
* low: mod_session_cookie does not respect expiry time. CVE-2018-17199
* low: DoS for HTTP/2 connections via slow request bodies. CVE-2018-17189
2018-10-24 - Anton Farygin <rider@altlinux.ru> 1:2.4.37-alt1
- 2.4.37
- removed TimeoutStartSec in httpd.service (closes: #27925)
- save to log remoteip instead of remote hostname for fix of work with
mod_remoteip module (closes: #34974)
2018-10-15 - Anton Farygin <rider@altlinux.ru> 1:2.4.35-alt2
- removed ubt tag
- changed rundir location to /run in tmpfiles
- disabled TLSv1 and TLSv1.1 protocols by default (closes: #34717)
2018-10-14 - Igor Vlasenko <viy@altlinux.ru> 1:2.4.35-alt1.qa1
- NMU: applied repocop patch
2018-09-25 - Anton Farygin <rider@altlinux.ru> 1:2.4.35-alt1
- 2.4.35
2018-09-03 - Anton Farygin <rider@altlinux.ru> 1:2.4.34-alt2
- rebuilt with openssl-1.1 (Sisyphus)
2018-07-31 - Anton Farygin <rider@altlinux.ru> 1:2.4.34-alt1
- 2.4.34
- fixes:
* CVE-2018-1333 DoS for HTTP/2 connections by crafted requests
* CVE-2018-8011 mod_md, DoS via Coredumps on specially crafted requests
2018-03-31 - Anton Farygin <rider@altlinux.ru> 1:2.4.33-alt1
- 2.4.33
- fixes:
* CVE-2018-1303 low: Possible out of bound read in mod_cache_socache
* CVE-2018-1302 low: Possible write of after free on HTTP/2 stream shutdown
* CVE-2018-1301 low: Possible out of bound access after failure in reading the HTTP request 
* CVE-2018-1312 low: Weak Digest auth nonce generation in mod_auth_digest
* CVE-2017-15715 low: <FilesMatch> bypass with a trailing newline in the file name
* CVE-2017-15710 low: Out of bound write in mod_authnz_ldap when using too small Accept-Language values
* CVE-2018-1283 medium: Tampering of mod_session data for CGI applications

See Also

Package Description
apacheds-2.0.0-alt1_0.8.M21jpp8.noarch.rpm Apache Directory Server
apacheds-core-2.0.0-alt1_0.8.M21jpp8.noarch.rpm ApacheDS Core
apacheds-http-integration-2.0.0-alt1_0.8.M21jpp8.noarch.rpm ApacheDS Jetty HTTP Server Integration
apacheds-i18n-2.0.0-alt1_0.8.M21jpp8.noarch.rpm ApacheDS I18n
apacheds-javadoc-2.0.0-alt1_0.8.M21jpp8.noarch.rpm Javadoc for apacheds
apacheds-jdbm-javadoc-2.0.0-alt1_0.10.M3jpp8.noarch.rpm Javadoc for apacheds-jdbm
apacheds-jdbm-parent-2.0.0-alt1_0.10.M3jpp8.noarch.rpm ApacheDS JDBM Parent POM
apacheds-jdbm1-2.0.0-alt1_0.10.M3jpp8.noarch.rpm ApacheDS Original JDBM Implementation
apacheds-jdbm2-2.0.0-alt1_0.10.M3jpp8.noarch.rpm ApacheDS JDBM Implementation MVCC
apacheds-kerberos-2.0.0-alt1_0.8.M21jpp8.noarch.rpm ApacheDS Kerberos
apacheds-ldap-api-1.0.0-alt1_0.7.M33jpp8.noarch.rpm Apache Directory LDAP API
apacheds-ldap-api-javadoc-1.0.0-alt1_0.7.M33jpp8.noarch.rpm Javadoc for apacheds-ldap-api
apacheds-osgi-2.0.0-alt1_0.8.M21jpp8.noarch.rpm ApacheDS OSGi Integration
apacheds-protocols-2.0.0-alt1_0.8.M21jpp8.noarch.rpm ApacheDS Protocols
apacheds-server-2.0.0-alt1_0.8.M21jpp8.noarch.rpm ApacheDS Server modules
Advertisement
Advertisement