apt-blacklist-0.01.2-alt1.noarch.rpm


Advertisement

Description

apt-blacklist - Forbids installation of packages based on some criteria

Property Value
Distribution ALT Linux Sisyphus
Repository Classic noarch
Package name apt-blacklist
Package version 0.01.2
Package release alt1
Package architecture noarch
Package type rpm
Installed size 4.86 KB
Download size 4.86 KB
Official Mirror ftp.altlinux.org
This small tool checks packages that apt wants to install and aborts the
installation process if some criteria are met. Now it has only one
criterion: last changelog entry author must not contain lines from
/etc/apt-blacklist/packagers. Also, it can warn you when apt going to
install package that changed by author from /etc/apt-blacklist/warning
and inform about packager changes for authors from /etc/apt-blacklist/watch.

Alternatives

Package Version Architecture Repository
apt-blacklist - - -

Requires

Name Value
/usr/bin/python -
python-base -
python-module-rpm >= 4.13.0
python2.7(rpm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
apt-blacklist = 0.01.2-alt1

Download

Type URL
Binary Package apt-blacklist-0.01.2-alt1.noarch.rpm
Source Package apt-blacklist-0.01.2-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install apt-blacklist rpm package:
    # sudo apt-get install apt-blacklist

Files

Path
/etc/apt-blacklist/packagers
/etc/apt-blacklist/warning
/etc/apt-blacklist/watch
/etc/apt/apt.conf.d/10-apt-blacklist.conf
/usr/bin/apt-blacklist

Changelog

2017-05-14 - Terechkov Evgenii <evg@altlinux.org> 0.01.2-alt1
- Fix for rpm installation without pubkey
2016-12-28 - Terechkov Evgenii <evg@altlinux.org> 0.01.1-alt1
- Fix for new rpm python module.
2014-06-29 - Terechkov Evgenii <evg@altlinux.org> 0.01-alt2.4
- Compact all printed messages
2011-10-22 - Vitaly Kuznetsov <vitty@altlinux.ru> 0.01-alt2.3.1
- Rebuild with Python-2.7
2010-03-26 - Terechkov Evgenii <evg@altlinux.ru> 0.01-alt2.3
- Fix new package installation (with just one changelog entry)
2010-03-20 - Terechkov Evgenii <evg@altlinux.ru> 0.01-alt2.2
- Watching for packager change added (#23182)
2009-12-07 - Eugeny A. Rostovtsev (REAL) <real at altlinux.org> 0.01-alt2.1
- Rebuilt with python 2.6
2009-10-09 - Andrey Rahmatullin <wrar@altlinux.ru> 0.01-alt2
- Sisyphus build
2009-09-13 - Terechkov Evgenii <evg@altlinux.ru> 0.01-alt1.1
- Warn list support added
2009-09-12 - Andrey Rahmatullin <wrar@altlinux.ru> 0.01-alt1
- initial version

See Also

Package Description
apt-conf-etersoft-common-2.0-alt2.noarch.rpm Etersoft vendor configuration files for apt
apt-conf-etersoft-hold-2.0-alt2.noarch.rpm Etersoft addittional configuration files for apt
apt-conf-ignore-systemd-0.1-alt2.noarch.rpm apt configuration file for systems on sysvinit
apt-conf-mithraen-1.0-alt1.noarch.rpm arepo repository by Denis Smirnov
apt-conf-tmp-cache-1.0-alt1.noarch.rpm Temporary cache configuration files for apt
apt-log-0.1-alt3.noarch.rpm Log support for APT
apt-printchanges-0.01.1-alt1.noarch.rpm Print last changelog for each installed/upgraded package
apt-repo-1.3.9-alt1.noarch.rpm Script for manipulation APT repository list
apt-scripts-0.1.3-alt1.noarch.rpm Lua scripts for APT
aqbanking-doc-5.7.8-alt2.noarch.rpm AqBanking4 Handbook
aqsis-data-1.8.2-alt3_29.noarch.rpm Example content for Aqsis Renderer
aqute-bnd-3.5.0-alt1_2jpp8.noarch.rpm BND Tool
aqute-bnd-javadoc-3.5.0-alt1_2jpp8.noarch.rpm Javadoc for aqute-bnd
aqute-bndlib-3.5.0-alt1_2jpp8.noarch.rpm BND library
arachne-pnr-chipdb-0.1.0.0.310.g5d830dd-alt1.noarch.rpm Place and route tool for iCE40 family FPGAs - binary chipdb files
Advertisement
Advertisement