httpie-0.9.9-alt1.qa1.noarch.rpm


Advertisement

Description

httpie - A Curl-like tool for humans

Property Value
Distribution ALT Linux Sisyphus
Repository Classic noarch
Package filename httpie-0.9.9-alt1.qa1.noarch.rpm
Package name httpie
Package version 0.9.9
Package release alt1.qa1
Package architecture noarch
Package type rpm
Category Networking/WWW
Homepage -
License -
Maintainer -
Download size 409.96 KB
Installed size 409.96 KB
HTTPie is a CLI HTTP utility built out of frustration with existing tools. The
goal is to make CLI interaction with HTTP-based services as human-friendly as
possible.
HTTPie does so by providing an http command that allows for issuing arbitrary
HTTP requests using a simple and natural syntax and displaying colorized
responses.

Alternatives

Package Version Architecture Repository
httpie - - -

Requires

Name Value
/usr/bin/python -
/usr/lib/python2.7/site-packages -
python-module-Pygments >= 2.1.3
python-module-requests >= 2.11.0
python-modules -
python2.7(mailbox) -
python2.7(mimetypes) -
python2.7(pkg_resources) -
python2.7(pygments) -
python2.7(requests) -
python2.7(urllib3) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
httpie = 0.9.9-alt1.qa1
python2.7(httpie) -
python2.7(httpie.__main__) -
python2.7(httpie.cli) -
python2.7(httpie.client) -
python2.7(httpie.compat) -
python2.7(httpie.config) -
python2.7(httpie.context) -
python2.7(httpie.core) -
python2.7(httpie.downloads) -
python2.7(httpie.input) -
python2.7(httpie.models) -
python2.7(httpie.output) -
python2.7(httpie.output.formatters) -
python2.7(httpie.output.formatters.colors) -
python2.7(httpie.output.formatters.headers) -
python2.7(httpie.output.formatters.json) -
python2.7(httpie.output.processing) -
python2.7(httpie.output.streams) -
python2.7(httpie.plugins) -
python2.7(httpie.plugins.base) -
python2.7(httpie.plugins.builtin) -
python2.7(httpie.plugins.manager) -
python2.7(httpie.sessions) -
python2.7(httpie.utils) -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package httpie-0.9.9-alt1.qa1.noarch.rpm
Source Package httpie-0.9.9-alt1.qa1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install httpie rpm package:
    # sudo apt-get install httpie

Files

Path
/usr/bin/http
/usr/lib/python2.7/site-packages/httpie/__init__.py
/usr/lib/python2.7/site-packages/httpie/__init__.pyc
/usr/lib/python2.7/site-packages/httpie/__init__.pyo
/usr/lib/python2.7/site-packages/httpie/__main__.py
/usr/lib/python2.7/site-packages/httpie/__main__.pyc
/usr/lib/python2.7/site-packages/httpie/__main__.pyo
/usr/lib/python2.7/site-packages/httpie/cli.py
/usr/lib/python2.7/site-packages/httpie/cli.pyc
/usr/lib/python2.7/site-packages/httpie/cli.pyo
/usr/lib/python2.7/site-packages/httpie/client.py
/usr/lib/python2.7/site-packages/httpie/client.pyc
/usr/lib/python2.7/site-packages/httpie/client.pyo
/usr/lib/python2.7/site-packages/httpie/compat.py
/usr/lib/python2.7/site-packages/httpie/compat.pyc
/usr/lib/python2.7/site-packages/httpie/compat.pyo
/usr/lib/python2.7/site-packages/httpie/config.py
/usr/lib/python2.7/site-packages/httpie/config.pyc
/usr/lib/python2.7/site-packages/httpie/config.pyo
/usr/lib/python2.7/site-packages/httpie/context.py
/usr/lib/python2.7/site-packages/httpie/context.pyc
/usr/lib/python2.7/site-packages/httpie/context.pyo
/usr/lib/python2.7/site-packages/httpie/core.py
/usr/lib/python2.7/site-packages/httpie/core.pyc
/usr/lib/python2.7/site-packages/httpie/core.pyo
/usr/lib/python2.7/site-packages/httpie/downloads.py
/usr/lib/python2.7/site-packages/httpie/downloads.pyc
/usr/lib/python2.7/site-packages/httpie/downloads.pyo
/usr/lib/python2.7/site-packages/httpie/input.py
/usr/lib/python2.7/site-packages/httpie/input.pyc
/usr/lib/python2.7/site-packages/httpie/input.pyo
/usr/lib/python2.7/site-packages/httpie/models.py
/usr/lib/python2.7/site-packages/httpie/models.pyc
/usr/lib/python2.7/site-packages/httpie/models.pyo
/usr/lib/python2.7/site-packages/httpie/sessions.py
/usr/lib/python2.7/site-packages/httpie/sessions.pyc
/usr/lib/python2.7/site-packages/httpie/sessions.pyo
/usr/lib/python2.7/site-packages/httpie/utils.py
/usr/lib/python2.7/site-packages/httpie/utils.pyc
/usr/lib/python2.7/site-packages/httpie/utils.pyo
/usr/lib/python2.7/site-packages/httpie-0.9.8-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/httpie-0.9.8-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/httpie-0.9.8-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/httpie-0.9.8-py2.7.egg-info/entry_points.txt
/usr/lib/python2.7/site-packages/httpie-0.9.8-py2.7.egg-info/requires.txt
/usr/lib/python2.7/site-packages/httpie-0.9.8-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/httpie/output/__init__.py
/usr/lib/python2.7/site-packages/httpie/output/__init__.pyc
/usr/lib/python2.7/site-packages/httpie/output/__init__.pyo
/usr/lib/python2.7/site-packages/httpie/output/processing.py
/usr/lib/python2.7/site-packages/httpie/output/processing.pyc
/usr/lib/python2.7/site-packages/httpie/output/processing.pyo
/usr/lib/python2.7/site-packages/httpie/output/streams.py
/usr/lib/python2.7/site-packages/httpie/output/streams.pyc
/usr/lib/python2.7/site-packages/httpie/output/streams.pyo
/usr/lib/python2.7/site-packages/httpie/output/formatters/__init__.py
/usr/lib/python2.7/site-packages/httpie/output/formatters/__init__.pyc
/usr/lib/python2.7/site-packages/httpie/output/formatters/__init__.pyo
/usr/lib/python2.7/site-packages/httpie/output/formatters/colors.py
/usr/lib/python2.7/site-packages/httpie/output/formatters/colors.pyc
/usr/lib/python2.7/site-packages/httpie/output/formatters/colors.pyo
/usr/lib/python2.7/site-packages/httpie/output/formatters/headers.py
/usr/lib/python2.7/site-packages/httpie/output/formatters/headers.pyc
/usr/lib/python2.7/site-packages/httpie/output/formatters/headers.pyo
/usr/lib/python2.7/site-packages/httpie/output/formatters/json.py
/usr/lib/python2.7/site-packages/httpie/output/formatters/json.pyc
/usr/lib/python2.7/site-packages/httpie/output/formatters/json.pyo
/usr/lib/python2.7/site-packages/httpie/plugins/__init__.py
/usr/lib/python2.7/site-packages/httpie/plugins/__init__.pyc
/usr/lib/python2.7/site-packages/httpie/plugins/__init__.pyo
/usr/lib/python2.7/site-packages/httpie/plugins/base.py
/usr/lib/python2.7/site-packages/httpie/plugins/base.pyc
/usr/lib/python2.7/site-packages/httpie/plugins/base.pyo
/usr/lib/python2.7/site-packages/httpie/plugins/builtin.py
/usr/lib/python2.7/site-packages/httpie/plugins/builtin.pyc
/usr/lib/python2.7/site-packages/httpie/plugins/builtin.pyo
/usr/lib/python2.7/site-packages/httpie/plugins/manager.py
/usr/lib/python2.7/site-packages/httpie/plugins/manager.pyc
/usr/lib/python2.7/site-packages/httpie/plugins/manager.pyo
/usr/share/doc/httpie-0.9.9/LICENSE
/usr/share/doc/httpie-0.9.9/README.rst
/usr/share/man/man1/http.1.xz

Changelog

2018-10-14 - Igor Vlasenko <viy@altlinux.ru> 0.9.9-alt1.qa1
- NMU: applied repocop patch
2018-09-21 - Terechkov Evgenii <evg@altlinux.org> 0.9.9-alt1
- 0.9.9
2018-07-18 - Grigory Ustinov <grenka@altlinux.org> 0.9.8-alt3
- Fixed FTBFS (Add BR python3-module-setuptools).
2017-07-19 - Evgeniy Korneechev <ekorneechev@altlinux.org> 0.9.8-alt2
- Update requires
- Added patch - fixed import 'urllib3'
2017-07-19 - Evgeniy Korneechev <ekorneechev@altlinux.org> 0.9.8-alt1
- Build new version
2016-03-13 - Ivan Zakharyaschev <imz@altlinux.org> 0.8.0-alt1.1
- (NMU) rebuild with rpm-build-python3-0.1.9
(for common python3/site-packages/ and auto python3.3-ABI dep when needed)
2014-09-06 - Terechkov Evgenii <evg@altlinux.org> 0.8.0-alt1
- Initial build for ALT Linux Sisyphus

See Also

Package Description
httpie-python3-0.9.9-alt1.qa1.noarch.rpm A Curl-like tool for humans
httpry-scripts-0.1.8-alt1.noarch.rpm Plugins for httpry
httpunit-1.7-alt7_27jpp8.noarch.rpm Automated web site testing toolkit
httpunit-doc-1.7-alt7_27jpp8.noarch.rpm Documentation for httpunit
httpunit-javadoc-1.7-alt7_27jpp8.noarch.rpm Javadoc for httpunit
hunalign-data-1.2-alt1.noarch.rpm Data files for hunalign
hunspell-af-0.20080825-alt2_16.noarch.rpm Afrikaans hunspell dictionary
hunspell-ak-0.9.1-alt1_1.noarch.rpm Akan hunspell dictionaries
hunspell-am-0.20090704-alt2_13.noarch.rpm Amharic hunspell dictionaries
hunspell-ar-3.5-alt1_6.noarch.rpm Arabic hunspell dictionaries
hunspell-as-1.0.3-alt2_17.noarch.rpm Assamese hunspell dictionaries
hunspell-ast-2.0-alt1_1.noarch.rpm Asturian hunspell dictionaries
hunspell-az-0.20040827-alt2_19.noarch.rpm Azerbaijani hunspell dictionaries
hunspell-be-1.1-alt2.noarch.rpm Belarusian hunspell dictionaries
hunspell-ber-0.20080210-alt2_14.noarch.rpm Amazigh hunspell dictionaries
Advertisement
Advertisement