perl-Dist-Zilla-Plugin-MakeMaker-Awesome-0.48-alt2.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-MakeMaker-Awesome - a more awesome MakeMaker plugin for Dist::Zilla

Property Value
Distribution ALT Linux Sisyphus
Repository Classic noarch
Package filename perl-Dist-Zilla-Plugin-MakeMaker-Awesome-0.48-alt2.noarch.rpm
Package name perl-Dist-Zilla-Plugin-MakeMaker-Awesome
Package version 0.48
Package release alt2
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 34.99 KB
Installed size 34.99 KB
Perl module Dist::Zilla::Plugin::MakeMaker::Awesome is a more
awesome MakeMaker plugin for Dist::Zilla.
It is limited, if you want to stray from the marked path and do
something that would normally be done in a package MY section or
otherwise run custom code in your Makefile.PL you're out of luck.
This plugin is 100% compatible with Dist::Zilla::Plugin::MakeMaker -
we add additional customization hooks by subclassing it.

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-MakeMaker-Awesome - - -

Requires

Name Value
/usr/share/perl5 -
perl(CPAN/Meta/Requirements.pm) >= 2.121
perl(Dist/Zilla/File/InMemory.pm) -
perl(Dist/Zilla/Role/FileGatherer.pm) -
perl(List/Util.pm) >= 1.290
perl(Moose.pm) -
perl(MooseX/Types/Moose.pm) -
perl(MooseX/Types/Stringlike.pm) -
perl(Path/Tiny.pm) -
perl(namespace/autoclean.pm) -
perl(version.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Dist/Zilla/Plugin/MakeMaker/Awesome.pm) = 0.480
perl-Dist-Zilla-Plugin-MakeMaker-Awesome = 0.48-alt2:sisyphus+235437.100.1.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Dist-Zilla-Plugin-MakeMaker-Awesome-0.48-alt2.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-MakeMaker-Awesome-0.48-alt2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Dist-Zilla-Plugin-MakeMaker-Awesome rpm package:
    # sudo apt-get install perl-Dist-Zilla-Plugin-MakeMaker-Awesome

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-MakeMaker-Awesome-0.48/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-MakeMaker-Awesome-0.48/README
/usr/share/perl5/Dist/Zilla/Plugin/MakeMaker/Awesome.pm

Changelog

2019-08-04 - Nikolay A. Fetisov <naf@altlinux.org> 0.48-alt2
- Update BuildRequires
2019-05-02 - Nikolay A. Fetisov <naf@altlinux.org> 0.48-alt1
- New version
2018-08-05 - Nikolay A. Fetisov <naf@altlinux.org> 0.47-alt1
- New version
2018-06-30 - Nikolay A. Fetisov <naf@altlinux.org> 0.45-alt1
- New version
2018-05-09 - Nikolay A. Fetisov <naf@altlinux.org> 0.42-alt1
- New version
2018-03-04 - Nikolay A. Fetisov <naf@altlinux.org> 0.41-alt1
- New version
2018-01-28 - Nikolay A. Fetisov <naf@altlinux.org> 0.40-alt1
- New version
2017-11-12 - Nikolay A. Fetisov <naf@altlinux.org> 0.39-alt1
- New version
2016-06-21 - Nikolay A. Fetisov <naf@altlinux.ru> 0.38-alt1
- New version
2016-03-19 - Nikolay A. Fetisov <naf@altlinux.ru> 0.36-alt1
- New version

See Also

Package Description
perl-Dist-Zilla-Plugin-MetaProvides-2.002004-alt1.noarch.rpm Generating and Populating 'provides' in META.yml
perl-Dist-Zilla-Plugin-MetaProvides-Package-2.004003-alt1.noarch.rpm Extract namespaces/version from traditional packages for provides
perl-Dist-Zilla-Plugin-OSPrereqs-0.011-alt1.noarch.rpm List prereqs conditional on operating system
perl-Dist-Zilla-Plugin-OurPkgVersion-0.21-alt1.noarch.rpm Dist::Zilla plugin for package version management
perl-Dist-Zilla-Plugin-PodWeaver-4.008-alt2.noarch.rpm weave Pod together from configuration and Dist::Zilla
perl-Dist-Zilla-Plugin-PromptIfStale-0.055-alt1.noarch.rpm Dist::Zilla module to check at build/release time
perl-Dist-Zilla-Plugin-TaskWeaver-0.101628-alt2.noarch.rpm a PodWeaver plugin used to build Task distributions
perl-Dist-Zilla-Plugin-Test-CheckBreaks-0.019-alt1.noarch.rpm Generate a test that shows what modules you are breaking
perl-Dist-Zilla-Plugin-Test-MinimumVersion-2.000010-alt1.noarch.rpm Release tests for minimum required versions
perl-Dist-Zilla-Plugin-Test-Perl-Critic-3.001-alt1.noarch.rpm Dist::Zilla tests to check code against best practices
perl-Dist-Zilla-Plugin-Test-ReportPrereqs-0.027-alt1.noarch.rpm Report on prerequisite versions during automated testing
perl-Dist-Zilla-PluginBundle-RJBS-5.010-alt2.noarch.rpm BeLike::RJBS when you build your dists
perl-Dist-Zilla-Role-Bootstrap-1.001004-alt1.noarch.rpm Dist::Zilla module with shared logic for bootstrap things
perl-Dist-Zilla-Role-DynamicConfig-1.002-alt4.noarch.rpm Dist::Zilla role that accepts a dynamic configuration
perl-Dist-Zilla-Role-ModuleMetadata-0.006-alt1.noarch.rpm a role for plugins that use Module::Metadata
Advertisement
Advertisement