perl-Dist-Zilla-Plugin-PromptIfStale-0.055-alt1.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-PromptIfStale - Dist::Zilla module to check at build/release time

Property Value
Distribution ALT Linux Sisyphus
Repository Classic noarch
Package filename perl-Dist-Zilla-Plugin-PromptIfStale-0.055-alt1.noarch.rpm
Package name perl-Dist-Zilla-Plugin-PromptIfStale
Package version 0.055
Package release alt1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage -
License -
Maintainer -
Download size 40.21 KB
Installed size 40.21 KB
Perl module Dist::Zilla::Plugin::PromptIfStale is a Dist::Zilla
BeforeBuild or BeforeRelease plugin that compares the
locally-installed version of a module(s) with the latest indexed
version, prompting to abort the build process if a discrepancy
is found.

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-PromptIfStale - - -

Requires

Name Value
/usr/share/perl5 -
perl(CPAN/DistnameInfo.pm) -
perl(Dist/Zilla/App.pm) -
perl(Dist/Zilla/Role/AfterBuild.pm) -
perl(Dist/Zilla/Role/BeforeBuild.pm) -
perl(Dist/Zilla/Role/BeforeRelease.pm) -
perl(Dist/Zilla/Util/AuthorDeps.pm) >= 5.021
perl(Encode.pm) -
perl(HTTP/Headers.pm) -
perl(HTTP/Tiny.pm) -
perl(List/Util.pm) >= 1.450
perl(Module/CoreList.pm) >= 5.201.512
perl(Module/Metadata.pm) >= 1.0.023
perl(Moose.pm) -
perl(Moose/Util.pm) -
perl(Moose/Util/TypeConstraints.pm) -
perl(Parse/CPAN/Packages/Fast.pm) -
perl(Path/Tiny.pm) -
perl(Term/ANSIColor.pm) >= 3.0
perl(Try/Tiny.pm) -
perl(YAML/Tiny.pm) -
perl(namespace/autoclean.pm) -
perl(version.pm) -
perl-base >= 1:5.10.0
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Dist/Zilla/App/Command/stale.pm) = 0.055
perl(Dist/Zilla/Plugin/EnsureNotStale.pm) = 0.055
perl(Dist/Zilla/Plugin/PromptIfStale.pm) = 0.055
perl-Dist-Zilla-Plugin-PromptIfStale = 0.055-alt1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package perl-Dist-Zilla-Plugin-PromptIfStale-0.055-alt1.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-PromptIfStale-0.055-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Dist-Zilla-Plugin-PromptIfStale rpm package:
    # sudo apt-get install perl-Dist-Zilla-Plugin-PromptIfStale

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-PromptIfStale-0.055/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-PromptIfStale-0.055/README
/usr/share/perl5/Dist/Zilla/App/
/usr/share/perl5/Dist/Zilla/App/Command/stale.pm
/usr/share/perl5/Dist/Zilla/Plugin/EnsureNotStale.pm
/usr/share/perl5/Dist/Zilla/Plugin/PromptIfStale.pm

Changelog

2018-05-12 - Nikolay A. Fetisov <naf@altlinux.org> 0.055-alt1
- New version
2017-08-30 - Nikolay A. Fetisov <naf@altlinux.org> 0.054-alt1
- New version
2017-04-23 - Nikolay A. Fetisov <naf@altlinux.org> 0.053-alt1
- New version
2017-02-14 - Nikolay A. Fetisov <naf@altlinux.org> 0.052-alt1
- New version
2017-01-23 - Nikolay A. Fetisov <naf@altlinux.org> 0.051-alt1
- Initial build for ALT Linux Sisyphus

See Also

Package Description
perl-Dist-Zilla-Plugin-TaskWeaver-0.101628-alt2.noarch.rpm a PodWeaver plugin used to build Task distributions
perl-Dist-Zilla-Plugin-Test-CheckBreaks-0.019-alt1.noarch.rpm Generate a test that shows what modules you are breaking
perl-Dist-Zilla-Plugin-Test-MinimumVersion-2.000008-alt1.noarch.rpm Release tests for minimum required versions
perl-Dist-Zilla-Plugin-Test-Perl-Critic-3.001-alt1.noarch.rpm Dist::Zilla tests to check code against best practices
perl-Dist-Zilla-Plugin-Test-ReportPrereqs-0.027-alt1.noarch.rpm Report on prerequisite versions during automated testing
perl-Dist-Zilla-PluginBundle-RJBS-5.010-alt2.noarch.rpm BeLike::RJBS when you build your dists
perl-Dist-Zilla-Role-Bootstrap-1.001004-alt1.noarch.rpm Dist::Zilla module with shared logic for bootstrap things
perl-Dist-Zilla-Role-DynamicConfig-1.002-alt4.noarch.rpm Dist::Zilla role that accepts a dynamic configuration
perl-Dist-Zilla-Role-ModuleMetadata-0.006-alt1.noarch.rpm a role for plugins that use Module::Metadata
perl-Dist-Zilla-Role-RegisterStash-0.003-alt2.noarch.rpm Dist::Zilla plugin that can register stashes
perl-Dist-Zilla-Role-Stash-Plugins-1.006-alt3.noarch.rpm Dist::Zilla Stash that stores arguments for plugins
perl-Dist-Zilla-Stash-PodWeaver-1.005-alt2.noarch.rpm Dist::Zilla plugin to stash of config options for Pod::Weaver
perl-Dist-Zilla-Util-ConfigDumper-0.003009-alt1.noarch.rpm A Dist::Zilla plugin configuration extraction utility
perl-Dist-Zilla-Util-Test-KENTNL-1.005014-alt1.noarch.rpm KENTNL's DZil plugin testing tool
perl-DistroMap-0.392-alt1.noarch.rpm DistroMap - Perl interface for DistroMap database
Advertisement
Advertisement