perl-Dist-Zilla-Plugin-Test-CheckBreaks-0.019-alt1.noarch.rpm


Advertisement

Description

perl-Dist-Zilla-Plugin-Test-CheckBreaks - Generate a test that shows what modules you are breaking

Property Value
Distribution ALT Linux Sisyphus
Repository Classic noarch
Package name perl-Dist-Zilla-Plugin-Test-CheckBreaks
Package version 0.019
Package release alt1
Package architecture noarch
Package type rpm
Installed size 18.58 KB
Download size 18.58 KB
Official Mirror ftp.altlinux.org
Perl module Dist::Zilla::Plugin::Test::CheckBreaks is a Dist::Zilla
plugin that runs at the gather files stage, providing a test file
that runs last in your test suite and checks for conflicting
modules, as indicated by x_breaks in your distribution metadata.

Alternatives

Package Version Architecture Repository
perl-Dist-Zilla-Plugin-Test-CheckBreaks - - -

Requires

Name Value
/usr/share/perl5 -
perl(Data/Dumper.pm) -
perl(Data/Section.pm) >= 0.004
perl(Dist/Zilla/File/InMemory.pm) -
perl(Dist/Zilla/Role/FileGatherer.pm) -
perl(Dist/Zilla/Role/FileMunger.pm) -
perl(Dist/Zilla/Role/ModuleMetadata.pm) -
perl(Dist/Zilla/Role/PrereqSource.pm) -
perl(Dist/Zilla/Role/TextTemplate.pm) -
perl(List/Util.pm) >= 1.330
perl(Module/Runtime.pm) -
perl(Moose.pm) -
perl(Path/Tiny.pm) -
perl(Sub/Exporter/ForMethods.pm) -
perl(namespace/autoclean.pm) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
perl(Dist/Zilla/Plugin/Test/CheckBreaks.pm) = 0.019
perl-Dist-Zilla-Plugin-Test-CheckBreaks = 0.019-alt1

Download

Type URL
Binary Package perl-Dist-Zilla-Plugin-Test-CheckBreaks-0.019-alt1.noarch.rpm
Source Package perl-Dist-Zilla-Plugin-Test-CheckBreaks-0.019-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install perl-Dist-Zilla-Plugin-Test-CheckBreaks rpm package:
    # sudo apt-get install perl-Dist-Zilla-Plugin-Test-CheckBreaks

Files

Path
/usr/share/doc/perl-Dist-Zilla-Plugin-Test-CheckBreaks-0.019/Changes
/usr/share/doc/perl-Dist-Zilla-Plugin-Test-CheckBreaks-0.019/README
/usr/share/perl5/Dist/Zilla/Plugin/Test/CheckBreaks.pm

Changelog

2017-08-30 - Nikolay A. Fetisov <naf@altlinux.org> 0.019-alt1
- New version
2017-04-23 - Nikolay A. Fetisov <naf@altlinux.org> 0.018-alt1
- New version
2017-01-22 - Nikolay A. Fetisov <naf@altlinux.ru> 0.017-alt2
- Initial build for ALT Linux Sisyphus

See Also

Package Description
perl-Dist-Zilla-Plugin-Test-MinimumVersion-2.000008-alt1.noarch.rpm Release tests for minimum required versions
perl-Dist-Zilla-Plugin-Test-Perl-Critic-3.001-alt1.noarch.rpm Dist::Zilla tests to check code against best practices
perl-Dist-Zilla-Plugin-Test-ReportPrereqs-0.027-alt1.noarch.rpm Report on prerequisite versions during automated testing
perl-Dist-Zilla-PluginBundle-RJBS-5.010-alt2.noarch.rpm BeLike::RJBS when you build your dists
perl-Dist-Zilla-Role-Bootstrap-1.001004-alt1.noarch.rpm Dist::Zilla module with shared logic for bootstrap things
perl-Dist-Zilla-Role-DynamicConfig-1.002-alt4.noarch.rpm Dist::Zilla role that accepts a dynamic configuration
perl-Dist-Zilla-Role-ModuleMetadata-0.006-alt1.noarch.rpm a role for plugins that use Module::Metadata
perl-Dist-Zilla-Role-RegisterStash-0.003-alt2.noarch.rpm Dist::Zilla plugin that can register stashes
perl-Dist-Zilla-Role-Stash-Plugins-1.006-alt3.noarch.rpm Dist::Zilla Stash that stores arguments for plugins
perl-Dist-Zilla-Stash-PodWeaver-1.005-alt2.noarch.rpm Dist::Zilla plugin to stash of config options for Pod::Weaver
perl-Dist-Zilla-Util-ConfigDumper-0.003009-alt1.noarch.rpm A Dist::Zilla plugin configuration extraction utility
perl-Dist-Zilla-Util-Test-KENTNL-1.005014-alt1.noarch.rpm KENTNL's DZil plugin testing tool
perl-DistroMap-0.391-alt1.noarch.rpm DistroMap - Perl interface for DistroMap database
perl-Dpkg-1.19.0.5-alt1.noarch.rpm Package maintenance system for Debian Linux
perl-DublinCore-Record-0.03-alt2.1.noarch.rpm DublinCore-Record - Perl module
Advertisement
Advertisement