python-module-pyatspi-2.26.0-alt1.noarch.rpm


Advertisement

Description

python-module-pyatspi - Python bindings for at-spi library

Property Value
Distribution ALT Linux Sisyphus
Repository Classic noarch
Package name python-module-pyatspi
Package version 2.26.0
Package release alt1
Package architecture noarch
Package type rpm
Installed size 360.96 KB
Download size 360.96 KB
Official Mirror ftp.altlinux.org
at-spi allows assistive technologies to access GTK-based
applications. Essentially it exposes the internals of applications for
automation, so tools such as screen readers, magnifiers, or even
scripting interfaces can query and interact with GUI controls.
This version of at-spi is a major break from previous versions.
It has been completely rewritten to use D-Bus rather than
ORBIT / CORBA for its transport protocol.
This package includes a python client library for at-spi.

Alternatives

Package Version Architecture Repository
python-module-pyatspi - - -

Requires

Name Value
/usr/lib/python2.7/site-packages -
python-base -
python2.7(gi) -
rpmlib(PayloadIsLzma) -
typelib(Atspi) -
typelib(GLib) -
typelib(GObject) -

Provides

Name Value
python-module-pyatspi = 2.26.0-alt1
python2.7(pyatspi) -
python2.7(pyatspi.Accessibility) -
python2.7(pyatspi.action) -
python2.7(pyatspi.appevent) -
python2.7(pyatspi.application) -
python2.7(pyatspi.atspienum) -
python2.7(pyatspi.collection) -
python2.7(pyatspi.component) -
python2.7(pyatspi.constants) -
python2.7(pyatspi.deviceevent) -
python2.7(pyatspi.document) -
python2.7(pyatspi.editabletext) -
python2.7(pyatspi.hypertext) -
python2.7(pyatspi.image) -
python2.7(pyatspi.interface) -
python2.7(pyatspi.registry) -
python2.7(pyatspi.role) -
python2.7(pyatspi.selection) -
python2.7(pyatspi.state) -
python2.7(pyatspi.table) -
python2.7(pyatspi.tablecell) -
python2.7(pyatspi.text) -
python2.7(pyatspi.utils) -
python2.7(pyatspi.value) -

Download

Type URL
Binary Package python-module-pyatspi-2.26.0-alt1.noarch.rpm
Source Package python-module-pyatspi-2.26.0-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install python-module-pyatspi rpm package:
    # sudo apt-get install python-module-pyatspi

Files

Path
/usr/lib/python2.7/site-packages/pyatspi/Accessibility.py
/usr/lib/python2.7/site-packages/pyatspi/Accessibility.pyc
/usr/lib/python2.7/site-packages/pyatspi/Accessibility.pyo
/usr/lib/python2.7/site-packages/pyatspi/__init__.py
/usr/lib/python2.7/site-packages/pyatspi/__init__.pyc
/usr/lib/python2.7/site-packages/pyatspi/__init__.pyo
/usr/lib/python2.7/site-packages/pyatspi/action.py
/usr/lib/python2.7/site-packages/pyatspi/action.pyc
/usr/lib/python2.7/site-packages/pyatspi/action.pyo
/usr/lib/python2.7/site-packages/pyatspi/appevent.py
/usr/lib/python2.7/site-packages/pyatspi/appevent.pyc
/usr/lib/python2.7/site-packages/pyatspi/appevent.pyo
/usr/lib/python2.7/site-packages/pyatspi/application.py
/usr/lib/python2.7/site-packages/pyatspi/application.pyc
/usr/lib/python2.7/site-packages/pyatspi/application.pyo
/usr/lib/python2.7/site-packages/pyatspi/atspienum.py
/usr/lib/python2.7/site-packages/pyatspi/atspienum.pyc
/usr/lib/python2.7/site-packages/pyatspi/atspienum.pyo
/usr/lib/python2.7/site-packages/pyatspi/collection.py
/usr/lib/python2.7/site-packages/pyatspi/collection.pyc
/usr/lib/python2.7/site-packages/pyatspi/collection.pyo
/usr/lib/python2.7/site-packages/pyatspi/component.py
/usr/lib/python2.7/site-packages/pyatspi/component.pyc
/usr/lib/python2.7/site-packages/pyatspi/component.pyo
/usr/lib/python2.7/site-packages/pyatspi/constants.py
/usr/lib/python2.7/site-packages/pyatspi/constants.pyc
/usr/lib/python2.7/site-packages/pyatspi/constants.pyo
/usr/lib/python2.7/site-packages/pyatspi/deviceevent.py
/usr/lib/python2.7/site-packages/pyatspi/deviceevent.pyc
/usr/lib/python2.7/site-packages/pyatspi/deviceevent.pyo
/usr/lib/python2.7/site-packages/pyatspi/document.py
/usr/lib/python2.7/site-packages/pyatspi/document.pyc
/usr/lib/python2.7/site-packages/pyatspi/document.pyo
/usr/lib/python2.7/site-packages/pyatspi/editabletext.py
/usr/lib/python2.7/site-packages/pyatspi/editabletext.pyc
/usr/lib/python2.7/site-packages/pyatspi/editabletext.pyo
/usr/lib/python2.7/site-packages/pyatspi/hypertext.py
/usr/lib/python2.7/site-packages/pyatspi/hypertext.pyc
/usr/lib/python2.7/site-packages/pyatspi/hypertext.pyo
/usr/lib/python2.7/site-packages/pyatspi/image.py
/usr/lib/python2.7/site-packages/pyatspi/image.pyc
/usr/lib/python2.7/site-packages/pyatspi/image.pyo
/usr/lib/python2.7/site-packages/pyatspi/interface.py
/usr/lib/python2.7/site-packages/pyatspi/interface.pyc
/usr/lib/python2.7/site-packages/pyatspi/interface.pyo
/usr/lib/python2.7/site-packages/pyatspi/registry.py
/usr/lib/python2.7/site-packages/pyatspi/registry.pyc
/usr/lib/python2.7/site-packages/pyatspi/registry.pyo
/usr/lib/python2.7/site-packages/pyatspi/role.py
/usr/lib/python2.7/site-packages/pyatspi/role.pyc
/usr/lib/python2.7/site-packages/pyatspi/role.pyo
/usr/lib/python2.7/site-packages/pyatspi/selection.py
/usr/lib/python2.7/site-packages/pyatspi/selection.pyc
/usr/lib/python2.7/site-packages/pyatspi/selection.pyo
/usr/lib/python2.7/site-packages/pyatspi/state.py
/usr/lib/python2.7/site-packages/pyatspi/state.pyc
/usr/lib/python2.7/site-packages/pyatspi/state.pyo
/usr/lib/python2.7/site-packages/pyatspi/table.py
/usr/lib/python2.7/site-packages/pyatspi/table.pyc
/usr/lib/python2.7/site-packages/pyatspi/table.pyo
/usr/lib/python2.7/site-packages/pyatspi/tablecell.py
/usr/lib/python2.7/site-packages/pyatspi/tablecell.pyc
/usr/lib/python2.7/site-packages/pyatspi/tablecell.pyo
/usr/lib/python2.7/site-packages/pyatspi/text.py
/usr/lib/python2.7/site-packages/pyatspi/text.pyc
/usr/lib/python2.7/site-packages/pyatspi/text.pyo
/usr/lib/python2.7/site-packages/pyatspi/utils.py
/usr/lib/python2.7/site-packages/pyatspi/utils.pyc
/usr/lib/python2.7/site-packages/pyatspi/utils.pyo
/usr/lib/python2.7/site-packages/pyatspi/value.py
/usr/lib/python2.7/site-packages/pyatspi/value.pyc
/usr/lib/python2.7/site-packages/pyatspi/value.pyo
/usr/share/doc/python-module-pyatspi-2.26.0/AUTHORS
/usr/share/doc/python-module-pyatspi-2.26.0/NEWS
/usr/share/doc/python-module-pyatspi-2.26.0/README

Changelog

2017-09-11 - Yuri N. Sedunov <aris@altlinux.org> 2.26.0-alt1
- 2.26.0
2017-03-21 - Yuri N. Sedunov <aris@altlinux.org> 2.24.0-alt1
- 2.24.0
2017-01-17 - Yuri N. Sedunov <aris@altlinux.org> 2.20.3-alt1
- 2.20.3
2016-05-09 - Yuri N. Sedunov <aris@altlinux.org> 2.20.2-alt1
- 2.20.2
2016-04-12 - Yuri N. Sedunov <aris@altlinux.org> 2.20.1-alt1
- 2.20.1
2016-03-31 - Denis Medvedev <nbr@altlinux.org> 2.20.0-alt2
- NMU removed incorrect LD_PRELOADS from noarch package
2016-03-22 - Yuri N. Sedunov <aris@altlinux.org> 2.20.0-alt1
- 2.20.0
2016-03-13 - Ivan Zakharyaschev <imz@altlinux.org> 2.18.0-alt1.1
- (NMU) rebuild with rpm-build-python3-0.1.9
(for common python3/site-packages/ and auto python3.3-ABI dep when needed)
2015-09-22 - Yuri N. Sedunov <aris@altlinux.org> 2.18.0-alt1
- 2.18.0
2015-03-25 - Yuri N. Sedunov <aris@altlinux.org> 2.16.0-alt1
- 2.16.0

See Also

Package Description
python-module-pybald-routes-2.11-alt2.git20140308.1.1.noarch.rpm Routing Recognition and Generation Tools
python-module-pybars3-0.9.3-alt1.noarch.rpm Handlebars.js templating for Python 3 and 2
python-module-pybill-1.1.0-alt2.1.noarch.rpm PDF formatting tool for bills
python-module-pybill-docs-1.1.0-alt2.1.noarch.rpm Documentation for pybill
python-module-pybill-tests-1.1.0-alt2.1.noarch.rpm Tests for pybill
python-module-pyblio-core-1.3.4-alt3.1.noarch.rpm Pybliographer base package
python-module-pybugz-0.9.0-alt1.rc1.1.noarch.rpm PyBugz - Python Interface to Bugzilla
python-module-pycadf-2.5.0-alt1.1.noarch.rpm DMTF Cloud Audit (CADF) data model
python-module-pycadf-doc-2.5.0-alt1.1.noarch.rpm Documentation for DMTF Cloud Audit (CADF) data model
python-module-pycadf-tests-2.5.0-alt1.1.noarch.rpm Tests for pycadf
python-module-pycairo-docs-1.16.3-alt1.1.noarch.rpm Documentation for pycairo
python-module-pycall-2.3.0-alt1.noarch.rpm flexible python library for creating and using Asterisk call files
python-module-pycaptcha-0.4-alt3.1.noarch.rpm An attempt to rewrite the decimal module in C
python-module-pycedict-0.9.2-alt1.git20170220.1.noarch.rpm A library for parsing CEDict and adding tone marks to pinyin
python-module-pycerberus-0.6-alt1.1.2.noarch.rpm Highly flexible, no magic input validation library
Advertisement
Advertisement