python3-module-twine-1.9.1-alt1.noarch.rpm


Advertisement

Description

python3-module-twine - Collection of utilities for interacting with PyPI

Property Value
Distribution ALT Linux Sisyphus
Repository Classic noarch
Package name python3-module-twine
Package version 1.9.1
Package release alt1
Package architecture noarch
Package type rpm
Installed size 123.88 KB
Download size 123.88 KB
Official Mirror ftp.altlinux.org
Twine is a utility for interacting with PyPI.
Currently it only supports uploading distributions.

Alternatives

Package Version Architecture Repository
python3-module-twine - - -

Requires

Name Value
/usr/bin/python3 -
/usr/lib/python3/site-packages -
python3(__future__) < 0
python3(argparse) < 0
python3(functools) < 0
python3(getpass) < 0
python3(glob) < 0
python3(hashlib) < 0
python3(io) < 0
python3(os) < 0
python3(os.path) < 0
python3(pkg_resources) < 0
python3(pkginfo) < 0
python3(pkginfo.distribution) < 0
python3(re) < 0
python3(requests) < 0
python3(requests_toolbelt) < 0
python3(requests_toolbelt.multipart) < 0
python3(requests_toolbelt.utils) < 0
python3(setuptools) < 0
python3(subprocess) < 0
python3(tqdm) < 0
python3(urllib3) < 0
python3(warnings) < 0
python3(zipfile) < 0
rpmlib(PayloadIsLzma) -

Provides

Name Value
python3(twine) -
python3(twine.__main__) -
python3(twine._installed) -
python3(twine.cli) -
python3(twine.commands) -
python3(twine.commands.register) -
python3(twine.commands.upload) -
python3(twine.exceptions) -
python3(twine.package) -
python3(twine.repository) -
python3(twine.utils) -
python3(twine.wheel) -
python3(twine.wininst) -
python3-module-twine = 1.9.1-alt1
python3.3(twine) -
python3.3(twine.__main__) -
python3.3(twine._installed) -
python3.3(twine.cli) -
python3.3(twine.commands) -
python3.3(twine.commands.register) -
python3.3(twine.commands.upload) -
python3.3(twine.exceptions) -
python3.3(twine.package) -
python3.3(twine.repository) -
python3.3(twine.utils) -
python3.3(twine.wheel) -
python3.3(twine.wininst) -

Download

Type URL
Binary Package python3-module-twine-1.9.1-alt1.noarch.rpm
Source Package python-module-twine-1.9.1-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install python3-module-twine rpm package:
    # sudo apt-get install python3-module-twine

Files

Path
/usr/bin/twine.py3
/usr/lib/python3/site-packages/twine/__init__.py
/usr/lib/python3/site-packages/twine/__main__.py
/usr/lib/python3/site-packages/twine/_installed.py
/usr/lib/python3/site-packages/twine/cli.py
/usr/lib/python3/site-packages/twine/exceptions.py
/usr/lib/python3/site-packages/twine/package.py
/usr/lib/python3/site-packages/twine/repository.py
/usr/lib/python3/site-packages/twine/utils.py
/usr/lib/python3/site-packages/twine/wheel.py
/usr/lib/python3/site-packages/twine/wininst.py
/usr/lib/python3/site-packages/twine-1.9.1-py3.5.egg-info/PKG-INFO
/usr/lib/python3/site-packages/twine-1.9.1-py3.5.egg-info/SOURCES.txt
/usr/lib/python3/site-packages/twine-1.9.1-py3.5.egg-info/dependency_links.txt
/usr/lib/python3/site-packages/twine-1.9.1-py3.5.egg-info/entry_points.txt
/usr/lib/python3/site-packages/twine-1.9.1-py3.5.egg-info/requires.txt
/usr/lib/python3/site-packages/twine-1.9.1-py3.5.egg-info/top_level.txt
/usr/lib/python3/site-packages/twine/__pycache__/__init__.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/__pycache__/__init__.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/__pycache__/__init__.cpython-35.pyc
/usr/lib/python3/site-packages/twine/__pycache__/__main__.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/__pycache__/__main__.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/__pycache__/__main__.cpython-35.pyc
/usr/lib/python3/site-packages/twine/__pycache__/_installed.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/__pycache__/_installed.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/__pycache__/_installed.cpython-35.pyc
/usr/lib/python3/site-packages/twine/__pycache__/cli.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/__pycache__/cli.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/__pycache__/cli.cpython-35.pyc
/usr/lib/python3/site-packages/twine/__pycache__/exceptions.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/__pycache__/exceptions.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/__pycache__/exceptions.cpython-35.pyc
/usr/lib/python3/site-packages/twine/__pycache__/package.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/__pycache__/package.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/__pycache__/package.cpython-35.pyc
/usr/lib/python3/site-packages/twine/__pycache__/repository.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/__pycache__/repository.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/__pycache__/repository.cpython-35.pyc
/usr/lib/python3/site-packages/twine/__pycache__/utils.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/__pycache__/utils.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/__pycache__/utils.cpython-35.pyc
/usr/lib/python3/site-packages/twine/__pycache__/wheel.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/__pycache__/wheel.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/__pycache__/wheel.cpython-35.pyc
/usr/lib/python3/site-packages/twine/__pycache__/wininst.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/__pycache__/wininst.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/__pycache__/wininst.cpython-35.pyc
/usr/lib/python3/site-packages/twine/commands/__init__.py
/usr/lib/python3/site-packages/twine/commands/register.py
/usr/lib/python3/site-packages/twine/commands/upload.py
/usr/lib/python3/site-packages/twine/commands/__pycache__/__init__.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/commands/__pycache__/__init__.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/commands/__pycache__/__init__.cpython-35.pyc
/usr/lib/python3/site-packages/twine/commands/__pycache__/register.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/commands/__pycache__/register.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/commands/__pycache__/register.cpython-35.pyc
/usr/lib/python3/site-packages/twine/commands/__pycache__/upload.cpython-35.opt-1.pyc
/usr/lib/python3/site-packages/twine/commands/__pycache__/upload.cpython-35.opt-2.pyc
/usr/lib/python3/site-packages/twine/commands/__pycache__/upload.cpython-35.pyc
/usr/share/doc/python3-module-twine-1.9.1/AUTHORS
/usr/share/doc/python3-module-twine-1.9.1/README.rst
/usr/share/doc/python3-module-twine-1.9.1/changelog.rst
/usr/share/doc/python3-module-twine-1.9.1/index.rst

Changelog

See python-module-twine-1.9.1-alt1.noarch.rpm changelog.

See Also

Package Description
python3-module-twisted-core-doc-17.5.0-alt2.1.noarch.rpm Documentation for Twisted Core (Python 3)
python3-module-twisted-json-socket-0.1.3-alt1.git20141113.1.1.1.noarch.rpm Protocol for twisted json socket
python3-module-twitter-3.4.1-alt1.noarch.rpm Python Interface for Twitter API
python3-module-twod-2.0-alt2.b1.2.noarch.rpm Core package for twod
python3-module-twod.wsgi-2.0-alt2.b1.2.noarch.rpm Enhanced WSGI support for Django applications
python3-module-twunnel3-0.4.0-alt2.1.noarch.rpm A HTTPS/SOCKS4/SOCKS5 tunnel for AsyncIO
python3-module-txaio-18.7.1-alt1.noarch.rpm Compatibility API between asyncio/Twisted/Trollius
python3-module-txaio-tests-18.7.1-alt1.noarch.rpm Tests for txaio
python3-module-txredis-2.3-alt1.1.2.noarch.rpm Python/Twisted client for Redis key-value store
python3-module-txredisapi-1.2-alt1.git20140728.1.2.noarch.rpm Twisted client protocol for redis
python3-module-txtorcon-0.19.3-alt1.noarch.rpm txtorcon password-authenticated key exchange (pure python)
python3-module-tyoi-0.2.1-alt1.git20110417.2.noarch.rpm Core files of tyoi
python3-module-tyoiOAuth2-0.2.1-alt1.git20110417.2.noarch.rpm Implements the "client" side of OAuth 2.0
python3-module-typing-3.6.4-alt1.noarch.rpm This is a backport of the standard library typing module to Python versions older than 3.6
python3-module-tzlocal-1.3-alt1.1.noarch.rpm tzinfo object for the local timezone
Advertisement
Advertisement