rpm-build-ocaml-1.3-alt1.noarch.rpm


Advertisement

Description

rpm-build-ocaml - RPM helpers to rebuild OCaml packages

Property Value
Distribution ALT Linux Sisyphus
Repository Classic noarch
Package name rpm-build-ocaml
Package version 1.3
Package release alt1
Package architecture noarch
Package type rpm
Installed size 6.68 KB
Download size 6.68 KB
Official Mirror ftp.altlinux.org
RPM macros and reqprov helpers to be used in OCaml packages.

Alternatives

Package Version Architecture Repository
rpm-build-ocaml - - -

Requires

Name Value
/usr/bin/ocamlrun -
/usr/lib/rpm(ArgvFileAction) -
/usr/lib/rpm(Debug) -
/usr/lib/rpm(Fatal) -
/usr/lib/rpm(FindPackage) -
/usr/lib/rpm(Info) -
/usr/lib/rpm(Verbose) -
/usr/lib/rpm(Warning) -
/usr/lib/rpm/find-package -
/usr/lib/rpm/functions -
/usr/lib/rpm/macros.d -
/usr/lib/rpm/ocaml-reqprov -
gawk -
grep -
rpmlib(PayloadIsLzma) -

Provides

Name Value
rpm-build-ocaml = 1.3-alt1

Conflicts

Name Value
ocaml4-runtime -

Obsoletes

Name Value
rpm-build-ocaml4 -

Download

Type URL
Binary Package rpm-build-ocaml-1.3-alt1.noarch.rpm
Source Package rpm-build-ocaml-1.3-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install rpm-build-ocaml rpm package:
    # sudo apt-get install rpm-build-ocaml

Files

Path
/usr/lib/rpm/ocaml-functions
/usr/lib/rpm/ocaml.prov
/usr/lib/rpm/ocaml.prov.files
/usr/lib/rpm/ocaml.req
/usr/lib/rpm/ocaml.req.files
/usr/lib/rpm/macros.d/ocaml
/usr/lib/rpm/macros.d/ocaml.env

Changelog

2017-05-16 - Anton Farygin <rider@altlinux.ru> 1.3-alt1
- added %add_ocaml_req_skip macros
- added %ocamldir
2017-04-18 - Anton Farygin <rider@altlinux.ru> 1.2-alt1
- added stublibs path to search shared libraries in cmxi archives
- resolve .so path for avoid requires to devel packages in runtime ocaml libraries
2017-02-16 - Anton Farygin <rider@altlinux.ru> 1.1.1-alt2
- added temporaty conflict with ocaml4-runtime
2008-04-08 - Alexey Tourbin <at@altlinux.ru> 1.1.1-alt1
- ocaml.req: check "ccopt" libaray paths when resolving "cclib" dependencies

See Also

Package Description
rpm-build-palemoon-27.9.0-alt1.noarch.rpm RPM helper macros to rebuild palemoon packages
rpm-build-pear-0.4-alt2.noarch.rpm RPM helper scripts for build PEAR packages
rpm-build-pecl-0.4-alt2.noarch.rpm RPM helper scripts for build PECL packages
rpm-build-pecl-php7-0.5-alt1.noarch.rpm RPM helper scripts for build PECL packages with php7
rpm-build-perl-0.84-alt13.noarch.rpm RPM helper scripts to calculate Perl dependencies
rpm-build-perl6-0.3-alt1.noarch.rpm RPM macroses for Rakudo Perl 6
rpm-build-php-version-5.6.38-alt1.S1.noarch.rpm RPM helper macros to rebuild PHP5 packages
rpm-build-php5-5.5-alt2.noarch.rpm RPM helper macros to rebuild PHP5 packages
rpm-build-php7-7.1-alt1.S1.noarch.rpm RPM helper macros to rebuild PHP packages
rpm-build-php7-version-7.2.10-alt1.S1.noarch.rpm RPM helper macros to rebuild PHP7 packages
rpm-build-python-0.37.0-alt1.noarch.rpm RPM helper macros to rebuild python packages
rpm-build-python3-0.1.13.1-alt2.noarch.rpm RPM helper macros to rebuild python3 packages
rpm-build-rpm-eval-0.1-alt3.noarch.rpm The script disclosure macros in files
rpm-build-ruby-0.7-alt7.noarch.rpm RPM helper scripts to calculate Ruby dependencies
rpm-build-sawfish-1.12.90-alt1.noarch.rpm RPM macros for sawfish-related packages
Advertisement
Advertisement