ruby-amazon-ec2-0.9.17-alt3.noarch.rpm


Advertisement

Description

ruby-amazon-ec2 - A Ruby Gem that gives you full access to several of the Amazon Web Services API from your Ruby/Ruby on Rails apps

Property Value
Distribution ALT Linux Sisyphus
Repository Classic noarch
Package filename ruby-amazon-ec2-0.9.17-alt3.noarch.rpm
Package name ruby-amazon-ec2
Package version 0.9.17
Package release alt3
Package architecture noarch
Package type rpm
Category Development/Ruby
Homepage -
License -
Maintainer -
Download size 204.54 KB
Installed size 204.54 KB
A Ruby Gem that gives you full access to several of the Amazon Web Services API from your Ruby/Ruby on Rails apps

Alternatives

Package Version Architecture Repository
ruby-amazon-ec2 - - -

Requires

Name Value
/usr/bin/ruby -
rpmlib(PayloadIsLzma) -
ruby >= 0
ruby-gem(xml-simple) >= 1.0.12
rubygems >= 0

Provides

Name Value
/usr/bin/awshell -
/usr/bin/ec2-gem-example.rb -
/usr/bin/ec2-gem-profile.rb -
/usr/bin/ec2sh -
gem(amazon-ec2) = 0.9.17
ruby-amazon-ec2 = 0.9.17-alt3:sisyphus+226411.1700.6.1
ruby-gem(amazon-ec2) = 0.9.17
rubygem(amazon-ec2) = 0.9.17

Download

Type URL
Mirror ftp.altlinux.org
Binary Package ruby-amazon-ec2-0.9.17-alt3.noarch.rpm
Source Package ruby-amazon-ec2-0.9.17-alt3.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install ruby-amazon-ec2 rpm package:
    # sudo apt-get install ruby-amazon-ec2

Files

Path
/usr/bin/awshell
/usr/bin/ec2-gem-example.rb
/usr/bin/ec2-gem-profile.rb
/usr/bin/ec2sh
/usr/lib/ruby/gems/2.5.0/specifications/amazon-ec2-0.9.17.gemspec
/usr/lib/ruby/gems/2.5.0/specifications/amazon-ec2-0.9.17/Gemfile
/usr/lib/ruby/gems/2.5.0/specifications/amazon-ec2-0.9.17/amazon-ec2.gemspec
/usr/lib/ruby/site_ruby/AWS.rb
/usr/lib/ruby/site_ruby/AWS/Autoscaling.rb
/usr/lib/ruby/site_ruby/AWS/Cloudwatch.rb
/usr/lib/ruby/site_ruby/AWS/EC2.rb
/usr/lib/ruby/site_ruby/AWS/ELB.rb
/usr/lib/ruby/site_ruby/AWS/RDS.rb
/usr/lib/ruby/site_ruby/AWS/exceptions.rb
/usr/lib/ruby/site_ruby/AWS/responses.rb
/usr/lib/ruby/site_ruby/AWS/version.rb
/usr/lib/ruby/site_ruby/AWS/Autoscaling/autoscaling.rb
/usr/lib/ruby/site_ruby/AWS/Cloudwatch/monitoring.rb
/usr/lib/ruby/site_ruby/AWS/EC2/availability_zones.rb
/usr/lib/ruby/site_ruby/AWS/EC2/console.rb
/usr/lib/ruby/site_ruby/AWS/EC2/devpay.rb
/usr/lib/ruby/site_ruby/AWS/EC2/elastic_ips.rb
/usr/lib/ruby/site_ruby/AWS/EC2/image_attributes.rb
/usr/lib/ruby/site_ruby/AWS/EC2/images.rb
/usr/lib/ruby/site_ruby/AWS/EC2/instances.rb
/usr/lib/ruby/site_ruby/AWS/EC2/keypairs.rb
/usr/lib/ruby/site_ruby/AWS/EC2/password.rb
/usr/lib/ruby/site_ruby/AWS/EC2/products.rb
/usr/lib/ruby/site_ruby/AWS/EC2/security_groups.rb
/usr/lib/ruby/site_ruby/AWS/EC2/snapshots.rb
/usr/lib/ruby/site_ruby/AWS/EC2/spot_instance_requests.rb
/usr/lib/ruby/site_ruby/AWS/EC2/spot_prices.rb
/usr/lib/ruby/site_ruby/AWS/EC2/subnets.rb
/usr/lib/ruby/site_ruby/AWS/EC2/tags.rb
/usr/lib/ruby/site_ruby/AWS/EC2/volumes.rb
/usr/lib/ruby/site_ruby/AWS/ELB/load_balancers.rb
/usr/lib/ruby/site_ruby/AWS/RDS/rds.rb
/usr/share/doc/ruby-amazon-ec2-0.9.17/README.rdoc

Changelog

2019-03-11 - Pavel Skrylev <majioa@altlinux.org> 0.9.17-alt3
- Removed unnecessary test dep.
2018-07-11 - Andrey Cherepanov <cas@altlinux.org> 0.9.17-alt2.1
- Rebuild with new Ruby autorequirements.
- Disable tests.
2018-06-08 - Andrey Cherepanov <cas@altlinux.org> 0.9.17-alt2
- Fix tests.
2017-09-01 - Andrey Cherepanov <cas@altlinux.org> 0.9.17-alt1
- Initial build for Sisyphus.

See Also

Package Description
ruby-amazon-ec2-doc-0.9.17-alt3.noarch.rpm Documentation files for ruby-amazon-ec2
ruby-amq-protocol-2.3.0-alt1.1.noarch.rpm AMQP 0.9.1 protocol serialization and deserialization implementation for Ruby (2.0+)
ruby-amq-protocol-doc-2.3.0-alt1.1.noarch.rpm Documentation files for ruby-amq-protocol
ruby-amqp-1.8.0-alt1.1.noarch.rpm EventMachine-based RabbitMQ client. Prefer Bunny: http://rubybunny.info. See documentation guides at http://rubyamqp.info
ruby-amqp-doc-1.8.0-alt1.1.noarch.rpm Documentation files for ruby-amqp
ruby-ancestry-3.0.7-alt1.noarch.rpm Organise ActiveRecord model into a tree structure
ruby-ancestry-doc-3.0.7-alt1.noarch.rpm Documentation files for ancestry gem
ruby-apipie-params-0.0.5-alt1.1.noarch.rpm DSL for describing data structures with json-schema bindings
ruby-apipie-params-doc-0.0.5-alt1.1.noarch.rpm Documentation files for ruby-apipie-params
ruby-apipie-rails-0.5.16-alt1.noarch.rpm Ruby on Rails API documentation tool
ruby-apipie-rails-doc-0.5.16-alt1.noarch.rpm Documentation files for apipie-rails gem
ruby-archive-zip-0.11.0-alt1.noarch.rpm A simple Ruby-esque interface to creating, extracting, and updating ZIP archives in 100% Ruby
ruby-archive-zip-doc-0.11.0-alt1.noarch.rpm Documentation files for ruby-archive-zip
ruby-arel-9.0.0-alt2.1.noarch.rpm A Relational Algebra
ruby-arel-doc-9.0.0-alt2.1.noarch.rpm Documentation files for ruby-arel
Advertisement
Advertisement