389-ds-base-devel-1.4.1.2-alt2.x86_64.rpm


Advertisement

Description

389-ds-base-devel - Development libraries for 389 Directory Server

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename 389-ds-base-devel-1.4.1.2-alt2.x86_64.rpm
Package name 389-ds-base-devel
Package version 1.4.1.2
Package release alt2
Package architecture x86_64
Package type rpm
Category Development/C
Homepage -
License -
Maintainer -
Download size 465.88 KB
Installed size 465.88 KB
Development Libraries and headers for 389 Directory Server.

Alternatives

Package Version Architecture Repository
389-ds-base-devel - - -

Requires

Name Value
/usr/lib64/pkgconfig -
389-ds-base = 1.4.1.2-alt2:sisyphus+234205.100.1.1
libldap-devel -
libnspr-devel -
libnss-devel -
pkgconfig(nspr) -
pkgconfig(nss) -
rpmlib(PayloadIsLzma) -

Provides

Name Value
389-ds-base-devel = 1.4.1.2-alt2:sisyphus+234205.100.1.1
libsvrcore-devel = 4.1.4
pkgconfig(dirsrv) = 1.4.1.2
pkgconfig(libsds) = 1.4.1.2
pkgconfig(nunc-stans) = 1.4.1.2
pkgconfig(svrcore) = 1.4.1.2

Conflicts

Name Value
libsvrcore-devel -

Obsoletes

Name Value
libsvrcore-devel <= 4.1.3

Download

Type URL
Mirror ftp.altlinux.org
Binary Package 389-ds-base-devel-1.4.1.2-alt2.x86_64.rpm
Source Package 389-ds-base-1.4.1.2-alt2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install 389-ds-base-devel rpm package:
    # sudo apt-get install 389-ds-base-devel

Files

Path
/usr/include/svrcore.h
/usr/include/dirsrv/nunc-stans.h
/usr/include/dirsrv/repl-session-plugin.h
/usr/include/dirsrv/sds.h
/usr/include/dirsrv/slapi-plugin.h
/usr/include/dirsrv/slapi_pal.h
/usr/include/dirsrv/winsync-plugin.h
/usr/lib64/libldaputil.so
/usr/lib64/libns-dshttpd.so
/usr/lib64/libnunc-stans.so
/usr/lib64/libsds.so
/usr/lib64/libslapd.so
/usr/lib64/libsvrcore.so
/usr/lib64/pkgconfig/dirsrv.pc
/usr/lib64/pkgconfig/libsds.pc
/usr/lib64/pkgconfig/nunc-stans.pc
/usr/lib64/pkgconfig/svrcore.pc
/usr/share/man/man3/md_docs_job-safety.3.xz
/usr/share/man/man3/ns_job_t.3.xz
/usr/share/man/man3/ns_thrpool_config.3.xz
/usr/share/man/man3/nunc-stans.h.3.xz
/usr/share/man/man3/sds_bptree.3.xz
/usr/share/man/man3/sds_bptree_cow.3.xz
/usr/share/man/man3/sds_bptree_cow_instance.3.xz
/usr/share/man/man3/sds_bptree_instance.3.xz
/usr/share/man/man3/sds_bptree_node.3.xz
/usr/share/man/man3/sds_bptree_node_list.3.xz
/usr/share/man/man3/sds_bptree_transaction.3.xz
/usr/share/man/man3/sds_ht_instance.3.xz
/usr/share/man/man3/sds_ht_node.3.xz
/usr/share/man/man3/sds_ht_slot.3.xz
/usr/share/man/man3/sds_ht_value.3.xz
/usr/share/man/man3/sds_lqueue.3.xz
/usr/share/man/man3/sds_misc.3.xz
/usr/share/man/man3/sds_queue.3.xz
/usr/share/man/man3/sds_queue_node.3.xz
/usr/share/man/man3/sds_tqueue.3.xz

Changelog

2019-07-10 - Ivan A. Melnikov <iv@altlinux.org> 1.4.1.2-alt2
- Link with libatomic on mipsel.
2019-05-21 - Stanislav Levin <slev@altlinux.org> 1.4.1.2-alt1
- 1.4.1.1 -> 1.4.1.2.
2019-01-22 - Stanislav Levin <slev@altlinux.org> 1.4.1.1-alt1
- 1.3.9.0 -> 1.4.1.1.
- Stopped build for i586 arch.
2018-11-28 - Stanislav Levin <slev@altlinux.org> 1.3.9.0-alt3
- Fixed initialization of plugin's hashtable.
- Dropped useless Provides of python 389-ds-tests.
2018-11-08 - Stanislav Levin <slev@altlinux.org> 1.3.9.0-alt2
- Added enforced upgrade.
2018-11-01 - Andrey Cherepanov <cas@altlinux.org> 1.3.9.0-alt1
- New version.
2018-10-11 - Andrey Cherepanov <cas@altlinux.org> 1.3.8.10-alt1
- New version.
- Security fixes:
+ Ticket 49969 - DOS caused by malformed search operation
+ Ticket 49937 - Log buffer exceeded emergency logging msg is not thread-safe
2018-10-05 - Andrey Cherepanov <cas@altlinux.org> 1.3.8.8-alt3
- Remove python2.7(gdb) requirement.
2018-09-20 - Anton V. Boyarshinov <boyarsh@altlinux.org> 1.3.8.8-alt2
- autoreconf moved inot %build
2018-08-30 - Stanislav Levin <slev@altlinux.org> 1.3.8.8-alt1
- 1.3.8.5 -> 1.3.8.8.
- Fix build with new openssl1.1.

See Also

Package Description
389-ds-base-legacy-tools-1.4.1.2-alt2.x86_64.rpm Legacy utilities for 389 Directory Server
389-ds-base-libs-1.4.1.2-alt2.x86_64.rpm Core libraries for 389 Directory Server
389-dsgw-1.1.11-alt4.x86_64.rpm 389 Directory Server Gateway (dsgw)
3proxy-0.6.1-alt1.qa1.x86_64.rpm Proxy server
4th-3.62.2-alt1.x86_64.rpm Basic framework for creating application specific scripting languages
4ti2-1.6.9-alt1_2.x86_64.rpm Algebraic, geometric and combinatorial problems on linear spaces
4ti2-devel-1.6.9-alt1_2.x86_64.rpm Headers needed to develop software that uses 4ti2
4ti2-libs-1.6.9-alt1_2.x86_64.rpm Library for problems on linear spaces
7colors-0.10-alt1.x86_64.rpm Little addicting game, take over the gaming area with your color
7kaa-2.14.7-alt1.x86_64.rpm Seven Kingdoms: Ancient Adversaries
AGReader-1.2-alt2_21.x86_64.rpm Console reader for viewing AmigaGuide files
AcetoneISO2-2.3-alt2.x86_64.rpm CD/DVD Image Manipulator
AlephOne-1.0.1-alt1.3.x86_64.rpm 3D first-person shooter game
Ants-1.4-alt2_22.x86_64.rpm Guide the insects safely home before they drop of the cliff
Ants-level-editor-1.4-alt2_22.x86_64.rpm Ants level editor
Advertisement
Advertisement