GMT-5.4.5-alt1_1.x86_64.rpm


Advertisement

Description

GMT - Generic Mapping Tools

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename GMT-5.4.5-alt1_1.x86_64.rpm
Package name GMT
Package version 5.4.5
Package release alt1_1
Package architecture x86_64
Package type rpm
Category Engineering
Homepage -
License -
Maintainer -
Download size 5.00 MB
Installed size 5.00 MB
GMT is an open source collection of ~60 tools for manipulating geographic and
Cartesian data sets (including filtering, trend fitting, gridding, projecting,
etc.) and producing Encapsulated PostScript File (EPS) illustrations ranging
from simple x-y plots via contour maps to artificially illuminated surfaces
and 3-D perspective views.  GMT supports ~30 map projections and transforma-
tions and comes with support data such as coastlines, rivers, and political
boundaries.
GMT is developed and maintained by Paul Wessel and Walter H. F.  Smith with
help from a global set of volunteers, and is supported by the National
Science Foundation.
NOTE: Specific executables that conflict with other Fedora packages have been
removed.  These functions can still be accessed via the GMT wrapper script
with: GMT <function> [args]

Alternatives

Package Version Architecture Repository
GMT-5.4.5-alt1_1.i586.rpm 5.4.5 i586 Classic
GMT - - -

Requires

Name Value
/lib64/ld-linux-x86-64.so.2 -
GMT-common = 5.4.5-alt1_1:sisyphus+223910.100.1.1
bash -
dcw-gmt -
ffmpeg -
gshhg-gmt-nc4 -
less -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.27)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libc.so.6(GLIBC_2.8)(64bit) -
libcurl.so.4()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libfftw3f.so.3()(64bit) -
libfftw3f_threads.so.3()(64bit) -
libgdal.so.20()(64bit) -
libglib-2.0.so.0()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.27)(64bit) -
libnetcdf.so.11()(64bit) -
libpcre.so.3()(64bit) -
libz.so.1()(64bit) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -

Provides

Name Value
GMT = 5.4.5-alt1_1:sisyphus+223910.100.1.1
gmt = 5.4.5-alt1_1
libgmt.so.5()(64bit) -
libpostscriptlight.so.5()(64bit) -

Obsoletes

Name Value
GMT-octave <= 4.5.11

Download

Type URL
Mirror ftp.altlinux.org
Binary Package GMT-5.4.5-alt1_1.x86_64.rpm
Source Package GMT-5.4.5-alt1_1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install GMT rpm package:
    # sudo apt-get install GMT

Files

Path
/usr/bin/backtracker
/usr/bin/blockmean
/usr/bin/blockmedian
/usr/bin/blockmode
/usr/bin/dimfilter
/usr/bin/filter1d
/usr/bin/fitcircle
/usr/bin/gmt
/usr/bin/gmt-config
/usr/bin/gmt2kml
/usr/bin/gmt2rgb
/usr/bin/gmt_shell_functions.sh
/usr/bin/gmtconnect
/usr/bin/gmtconvert
/usr/bin/gmtdefaults
/usr/bin/gmtdp
/usr/bin/gmtflexure
/usr/bin/gmtget
/usr/bin/gmtgravmag3d
/usr/bin/gmtinfo
/usr/bin/gmtlogo
/usr/bin/gmtmath
/usr/bin/gmtpmodeler
/usr/bin/gmtregress
/usr/bin/gmtselect
/usr/bin/gmtset
/usr/bin/gmtsimplify
/usr/bin/gmtspatial
/usr/bin/gmtstitch
/usr/bin/gmtswitch
/usr/bin/gmtvector
/usr/bin/gmtwhich
/usr/bin/gpsgridder
/usr/bin/gravfft
/usr/bin/grd2cpt
/usr/bin/grd2rgb
/usr/bin/grd2xyz
/usr/bin/grdblend
/usr/bin/grdclip
/usr/bin/grdcontour
/usr/bin/grdconvert
/usr/bin/grdcut
/usr/bin/grdedit
/usr/bin/grdfft
/usr/bin/grdfilter
/usr/bin/grdflexure
/usr/bin/grdgradient
/usr/bin/grdgravmag3d
/usr/bin/grdhisteq
/usr/bin/grdimage
/usr/bin/grdinfo
/usr/bin/grdlandmask
/usr/bin/grdmask
/usr/bin/grdmath
/usr/bin/grdpaste
/usr/bin/grdpmodeler
/usr/bin/grdproject
/usr/bin/grdraster
/usr/bin/grdredpol
/usr/bin/grdreformat
/usr/bin/grdrotater
/usr/bin/grdsample
/usr/bin/grdseamount
/usr/bin/grdspotter
/usr/bin/grdtrack
/usr/bin/grdtrend
/usr/bin/grdvector
/usr/bin/grdview
/usr/bin/grdvolume
/usr/bin/greenspline
/usr/bin/gshhg
/usr/bin/hotspotter
/usr/bin/img2grd
/usr/bin/isogmt
/usr/bin/kml2gmt
/usr/bin/makecpt
/usr/bin/mapproject
/usr/bin/mgd77convert
/usr/bin/mgd77header
/usr/bin/mgd77info
/usr/bin/mgd77list
/usr/bin/mgd77magref
/usr/bin/mgd77manage
/usr/bin/mgd77path
/usr/bin/mgd77sniffer
/usr/bin/mgd77track
/usr/bin/minmax
/usr/bin/nearneighbor
/usr/bin/originator
/usr/bin/project
/usr/bin/ps2raster
/usr/bin/psbasemap
/usr/bin/psclip
/usr/bin/pscoast
/usr/bin/pscontour
/usr/bin/psconvert
/usr/bin/pscoupe
/usr/bin/pshistogram
/usr/bin/psimage
/usr/bin/pslegend
/usr/bin/psmask
/usr/bin/psmeca
/usr/bin/pspolar
/usr/bin/psrose
/usr/bin/pssac
/usr/bin/psscale
/usr/bin/pssegy
/usr/bin/pssegyz
/usr/bin/pssolar
/usr/bin/psternary
/usr/bin/pstext
/usr/bin/psvelo
/usr/bin/pswiggle
/usr/bin/psxy
/usr/bin/psxyz
/usr/bin/rotconverter
/usr/bin/rotsmoother
/usr/bin/sample1d
/usr/bin/segy2grd
/usr/bin/spectrum1d
/usr/bin/sph2grd
/usr/bin/sphdistance
/usr/bin/sphinterpolate
/usr/bin/sphtriangulate
/usr/bin/splitxyz
/usr/bin/surface
/usr/bin/talwani2d
/usr/bin/talwani3d
/usr/bin/trend1d
/usr/bin/trend2d
/usr/bin/triangulate
/usr/bin/x2sys_binlist
/usr/bin/x2sys_cross
/usr/bin/x2sys_datalist
/usr/bin/x2sys_get
/usr/bin/x2sys_init
/usr/bin/x2sys_list
/usr/bin/x2sys_merge
/usr/bin/x2sys_put
/usr/bin/x2sys_report
/usr/bin/x2sys_solve
/usr/bin/xyz2grd
/usr/lib64/libgmt.so.5
/usr/lib64/libgmt.so.5.4.5
/usr/lib64/libpostscriptlight.so.5
/usr/lib64/libpostscriptlight.so.5.4.5
/usr/lib64/gmt/
/usr/lib64/gmt/plugins/supplements.so
/usr/share/doc/GMT-5.4.5/COPYING.LESSERv3
/usr/share/doc/GMT-5.4.5/COPYINGv3
/usr/share/doc/GMT-5.4.5/LICENSE.TXT
/usr/share/doc/GMT-5.4.5/README

Changelog

2019-03-06 - Igor Vlasenko <viy@altlinux.ru> 5.4.5-alt1_1
- new version
2019-03-06 - Anton Farygin <rider@altlinux.ru> 5.4.4-alt2
- removed ganglia-gmond requires (via gstat binary)
2018-12-10 - Igor Vlasenko <viy@altlinux.ru> 5.4.4-alt1_4
- update to new release by fcimport
2018-10-30 - Igor Vlasenko <viy@altlinux.ru> 5.4.4-alt1_3
- update to new release by fcimport
2018-10-10 - Igor Vlasenko <viy@altlinux.ru> 5.4.4-alt1_2
- update to new release by fcimport
2017-11-18 - Igor Vlasenko <viy@altlinux.ru> 5.4.2-alt1_3
- new version
2017-11-16 - Igor Vlasenko <viy@altlinux.ru> 5.2.1-alt3_3
- added gmt-5.2.1-alt-tmp_usage.patch
2017-08-28 - Aleksei Nikiforov <darktemplar@altlinux.org> 5.2.1-alt2_3
- Rebuilt with libnetcdf11.
2016-03-02 - Igor Vlasenko <viy@altlinux.ru> 5.2.1-alt1_3
- rebuild with libgdal
2014-04-07 - Igor Vlasenko <viy@altlinux.ru> 5.1.1-alt2_1
- DGMT_INSTALL_MODULE_LINKS=on

See Also

Package Description
GMT-devel-5.4.5-alt1_1.x86_64.rpm Development files for GMT
GraphicsMagick-1.3.30-alt2.1.x86_64.rpm An X application for displaying and manipulating images
GraphicsMagick-nox-1.3.30-alt2.1.x86_64.rpm An X application for manipulating images
I2P-Messenger-0.2.20-alt1.x86_64.rpm I2P Instant Messaging Client
I2util-tools-1.6-alt1.x86_64.rpm I2 Utility Tools
ImageMagick-6.9.10.39-alt1.x86_64.rpm An X application for displaying and manipulating images
ImageMagick-tools-6.9.10.39-alt1.x86_64.rpm Console tools from ImageMagick
Inventor-2.1.5-alt5.x86_64.rpm SGI Open Inventor (TM)
Inventor-demos-2.1.5-alt5.x86_64.rpm SGI Open Inventor (TM) Demos
KoboDeluxe-0.5.1-alt6.x86_64.rpm 3'rd person scrolling 2D shooter
Kvantum-0.11.0-alt1.x86_64.rpm SVG-based theme engine for Qt5, KDE and LXQt
LibreOffice-6.2.2.2-alt1.1.x86_64.rpm LibreOffice Productivity Suite
LibreOffice-common-6.2.2.2-alt1.1.x86_64.rpm Basic installation of LibreOffice
LibreOffice-extension-CyrillicTools-1.3-alt3.x86_64.rpm A macro library useful for working with Cyrillic documents
LibreOffice-extensions-6.2.2.2-alt1.1.x86_64.rpm Additional extensions for LibreOffice
Advertisement
Advertisement