GMT-devel-5.4.5-alt1_1.x86_64.rpm


Advertisement

Description

GMT-devel - Development files for GMT

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename GMT-devel-5.4.5-alt1_1.x86_64.rpm
Package name GMT-devel
Package version 5.4.5
Package release alt1_1
Package architecture x86_64
Package type rpm
Category Development/C
Homepage -
License -
Maintainer -
Download size 533.83 KB
Installed size 533.83 KB
The GMT-devel package contains libraries and header files for
developing applications that use GMT.

Alternatives

Package Version Architecture Repository
GMT-devel-5.4.5-alt1_1.i586.rpm 5.4.5 i586 Classic
GMT-devel - - -

Requires

Name Value
GMT = 5.4.5-alt1_1:sisyphus+223910.100.1.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
GMT-devel = 5.4.5-alt1_1:sisyphus+223910.100.1.1
gmt-devel = 5.4.5-alt1_1

Obsoletes

Name Value
GMT-static <= 4.5.11

Download

Type URL
Mirror ftp.altlinux.org
Binary Package GMT-devel-5.4.5-alt1_1.x86_64.rpm
Source Package GMT-5.4.5-alt1_1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install GMT-devel rpm package:
    # sudo apt-get install GMT-devel

Files

Path
/usr/include/gmt/common_math.h
/usr/include/gmt/common_string.h
/usr/include/gmt/config.h
/usr/include/gmt/declspec.h
/usr/include/gmt/gmt.h
/usr/include/gmt/gmt_common.h
/usr/include/gmt/gmt_config.h
/usr/include/gmt/gmt_constants.h
/usr/include/gmt/gmt_contour.h
/usr/include/gmt/gmt_core_module.h
/usr/include/gmt/gmt_customio.h
/usr/include/gmt/gmt_dcw.h
/usr/include/gmt/gmt_decorate.h
/usr/include/gmt/gmt_defaults.h
/usr/include/gmt/gmt_dev.h
/usr/include/gmt/gmt_dimensions.h
/usr/include/gmt/gmt_error.h
/usr/include/gmt/gmt_error_codes.h
/usr/include/gmt/gmt_fft.h
/usr/include/gmt/gmt_gdalread.h
/usr/include/gmt/gmt_grd.h
/usr/include/gmt/gmt_grdio.h
/usr/include/gmt/gmt_hash.h
/usr/include/gmt/gmt_io.h
/usr/include/gmt/gmt_macros.h
/usr/include/gmt/gmt_mb.h
/usr/include/gmt/gmt_memory.h
/usr/include/gmt/gmt_nan.h
/usr/include/gmt/gmt_notposix.h
/usr/include/gmt/gmt_plot.h
/usr/include/gmt/gmt_private.h
/usr/include/gmt/gmt_project.h
/usr/include/gmt/gmt_prototypes.h
/usr/include/gmt/gmt_psl.h
/usr/include/gmt/gmt_resources.h
/usr/include/gmt/gmt_shore.h
/usr/include/gmt/gmt_supplements_module.h
/usr/include/gmt/gmt_symbol.h
/usr/include/gmt/gmt_synopsis.h
/usr/include/gmt/gmt_texture.h
/usr/include/gmt/gmt_time.h
/usr/include/gmt/gmt_types.h
/usr/include/gmt/gmt_version.h
/usr/include/gmt/postscriptlight.h
/usr/include/gmt/psl_config.h
/usr/include/gmt/qsort.h
/usr/include/gmt/compat/qsort.h
/usr/include/gmt/gshhg/gmt_gshhg.h
/usr/include/gmt/gshhg/gshhg.h
/usr/include/gmt/meca/meca.h
/usr/include/gmt/meca/utilmeca.h
/usr/include/gmt/mgd77/cm4_functions.h
/usr/include/gmt/mgd77/mgd77.h
/usr/include/gmt/mgd77/mgd77_IGF_coeffs.h
/usr/include/gmt/mgd77/mgd77_codes.h
/usr/include/gmt/mgd77/mgd77_e77.h
/usr/include/gmt/mgd77/mgd77_functions.h
/usr/include/gmt/mgd77/mgd77_init.h
/usr/include/gmt/mgd77/mgd77_recalc.h
/usr/include/gmt/mgd77/mgd77_rls_coeffs.h
/usr/include/gmt/mgd77/mgd77defaults.h
/usr/include/gmt/mgd77/mgd77magref.h
/usr/include/gmt/mgd77/mgd77sniffer.h
/usr/include/gmt/mgd77/mgd77snifferdefaults.h
/usr/include/gmt/potential/okbfuns.h
/usr/include/gmt/spotter/spotter.h
/usr/include/gmt/x2sys/x2sys.h
/usr/lib64/libgmt.so
/usr/lib64/libpostscriptlight.so

Changelog

2019-03-06 - Igor Vlasenko <viy@altlinux.ru> 5.4.5-alt1_1
- new version
2019-03-06 - Anton Farygin <rider@altlinux.ru> 5.4.4-alt2
- removed ganglia-gmond requires (via gstat binary)
2018-12-10 - Igor Vlasenko <viy@altlinux.ru> 5.4.4-alt1_4
- update to new release by fcimport
2018-10-30 - Igor Vlasenko <viy@altlinux.ru> 5.4.4-alt1_3
- update to new release by fcimport
2018-10-10 - Igor Vlasenko <viy@altlinux.ru> 5.4.4-alt1_2
- update to new release by fcimport
2017-11-18 - Igor Vlasenko <viy@altlinux.ru> 5.4.2-alt1_3
- new version
2017-11-16 - Igor Vlasenko <viy@altlinux.ru> 5.2.1-alt3_3
- added gmt-5.2.1-alt-tmp_usage.patch
2017-08-28 - Aleksei Nikiforov <darktemplar@altlinux.org> 5.2.1-alt2_3
- Rebuilt with libnetcdf11.
2016-03-02 - Igor Vlasenko <viy@altlinux.ru> 5.2.1-alt1_3
- rebuild with libgdal
2014-04-07 - Igor Vlasenko <viy@altlinux.ru> 5.1.1-alt2_1
- DGMT_INSTALL_MODULE_LINKS=on

See Also

Package Description
GraphicsMagick-1.3.30-alt2.1.x86_64.rpm An X application for displaying and manipulating images
GraphicsMagick-nox-1.3.30-alt2.1.x86_64.rpm An X application for manipulating images
I2P-Messenger-0.2.20-alt1.x86_64.rpm I2P Instant Messaging Client
I2util-tools-1.6-alt1.x86_64.rpm I2 Utility Tools
ImageMagick-6.9.10.49-alt2.x86_64.rpm An X application for displaying and manipulating images
ImageMagick-tools-6.9.10.49-alt2.x86_64.rpm Console tools from ImageMagick
Inventor-2.1.5-alt5.x86_64.rpm SGI Open Inventor (TM)
Inventor-demos-2.1.5-alt5.x86_64.rpm SGI Open Inventor (TM) Demos
KoboDeluxe-0.5.1-alt6.x86_64.rpm 3'rd person scrolling 2D shooter
Kvantum-0.11.2-alt1.x86_64.rpm SVG-based theme engine for Qt5, KDE and LXQt
LibreOffice-6.3.0.3-alt1.x86_64.rpm LibreOffice Productivity Suite
LibreOffice-common-6.3.0.3-alt1.x86_64.rpm Basic installation of LibreOffice
LibreOffice-extension-CyrillicTools-1.3-alt3.x86_64.rpm A macro library useful for working with Cyrillic documents
LibreOffice-extensions-6.3.0.3-alt1.x86_64.rpm Additional extensions for LibreOffice
LibreOffice-gtk2-6.3.0.3-alt1.x86_64.rpm GTK2 Extensions for LibreOffice
Advertisement
Advertisement