NetworkManager-l2tp-1.2.12-alt1.x86_64.rpm


Advertisement

Description

NetworkManager-l2tp - NetworkManager VPN plugin for l2tp

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename NetworkManager-l2tp-1.2.12-alt1.x86_64.rpm
Package name NetworkManager-l2tp
Package version 1.2.12
Package release alt1
Package architecture x86_64
Package type rpm
Category System/Configuration/Networking
Homepage -
License -
Maintainer -
Download size 107.58 KB
Installed size 107.58 KB
This package contains software for integrating the l2tp VPN software
with NetworkManager.

Alternatives

Package Version Architecture Repository
NetworkManager-l2tp-1.2.12-alt1.i586.rpm 1.2.12 i586 Classic
NetworkManager-l2tp - - -

Requires

Name Value
/lib64/ld-linux-x86-64.so.2 -
NetworkManager-daemon >= 1.1.90
NetworkManager-ppp >= 1.1.90
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libgio-2.0.so.0()(64bit) -
libglib-2.0.so.0()(64bit) -
libgobject-2.0.so.0()(64bit) -
libnm.so.0()(64bit) -
libnm.so.0(libnm_1_0_0)(64bit) -
libnm.so.0(libnm_1_2_0)(64bit) -
ppp = 2.4.7
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -
strongswan -
xl2tpd -

Provides

Name Value
NetworkManager-l2tp = 1.2.12-alt1:sisyphus+225071.100.1.1

Download

Type URL
Mirror ftp.altlinux.org
Binary Package NetworkManager-l2tp-1.2.12-alt1.x86_64.rpm
Source Package NetworkManager-l2tp-1.2.12-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install NetworkManager-l2tp rpm package:
    # sudo apt-get install NetworkManager-l2tp

Files

Path
/etc/dbus-1/system.d/nm-l2tp-service.conf
/usr/lib/NetworkManager/nm-l2tp-service
/usr/lib/NetworkManager/VPN/nm-l2tp-service.name
/usr/lib64/pppd/2.4.7/nm-l2tp-pppd-plugin.so
/usr/share/doc/NetworkManager-l2tp-1.2.12/AUTHORS

Changelog

2019-03-15 - Mikhail Efremov <sem@altlinux.org> 1.2.12-alt1
- Don't pull gnome-keyring.
- Updated to 1.2.12.
2018-08-01 - Mikhail Efremov <sem@altlinux.org> 1.2.10-alt1
- Disable libnm-glib-* support.
- Fix build without libnm-glib-*.
- Updated to 1.2.10.
2017-08-14 - Mikhail Efremov <sem@altlinux.org> 1.2.8-alt1
- Updated to 1.2.8.
2017-07-11 - Mikhail Efremov <sem@altlinux.org> 1.2.6-alt1
- Disable silent rules.
- Updated to 1.2.6.
2017-02-06 - Mikhail Efremov <sem@altlinux.org> 1.2.4-alt2.git20170115
- Spec cleanup.
- Require NetworkManager-ppp.
2016-12-05 - Mikhail Efremov <sem@altlinux.org> 1.2.4-alt1
- Don't treat warrnings as errors.
- Updated to 1.2.4.
2016-05-24 - Mikhail Efremov <sem@altlinux.org> 1.2.2-alt1
- Updated to 1.2.2.
2016-05-04 - Mikhail Efremov <sem@altlinux.org> 1.2.0-alt1
- Fix build on i586.
- Patches from upstream:
+ service: fix critical errors in dispose().
+ all: NML2tpPlugin D-Bus fixes.
+ all: libnm and libnm-gtk can't mix; use libnma instead.
- Updated to 1.2.0.
2016-01-21 - Mikhail Efremov <sem@altlinux.org> 1.1.0-alt1.git20150916
- Require strongswan again.
- Upstream git snapshot (master branch) (closes: #30613).
2015-01-16 - Mikhail Efremov <sem@altlinux.org> 0.9.8.7-alt2
- Rebuild with ppp-2.4.7.
- Drop strongswan requires (see ALT bug #30613).

See Also

Package Description
NetworkManager-l2tp-gtk-1.2.12-alt1.x86_64.rpm Applications for use NetworkManager-l2tp with NetworkManager-applet-gtk
NetworkManager-openconnect-1.2.4-alt3.x86_64.rpm NetworkManager VPN integration for openconnect
NetworkManager-openconnect-gtk-1.2.4-alt3.x86_64.rpm Applications for use NetworkManager-openconnect with NetworkManager-applet-gtk
NetworkManager-openvpn-1.8.10-alt1.x86_64.rpm NetworkManager VPN plugin for OpenVPN
NetworkManager-openvpn-gtk-1.8.10-alt1.x86_64.rpm Applications for use NetworkManager-openvpn with NetworkManager-applet-gtk
NetworkManager-ovs-1.18.0-alt2.x86_64.rpm OpenVSwitch device plugin for NetworkManager
NetworkManager-ppp-1.18.0-alt2.x86_64.rpm PPP plugin for NetworkManager
NetworkManager-pptp-1.2.8-alt1.x86_64.rpm NetworkManager VPN plugin for pptp
NetworkManager-pptp-gtk-1.2.8-alt1.x86_64.rpm Applications for use NetworkManager-pptp with NetworkManager-applet-gtk
NetworkManager-ssh-1.2.10-alt1.x86_64.rpm NetworkManager VPN plugin for SSH
NetworkManager-ssh-gtk-1.2.10-alt1.x86_64.rpm Applications for use NetworkManager-ssh with NetworkManager-applet-gtk
NetworkManager-sstp-1.2.6-alt1.x86_64.rpm NetworkManager VPN plugin for SSTP
NetworkManager-sstp-gtk-1.2.6-alt1.x86_64.rpm Applications for use NetworkManager-sstp with NetworkManager-applet-gtk
NetworkManager-team-1.18.0-alt2.x86_64.rpm Team device plugin for NetworkManager
NetworkManager-tui-1.18.0-alt2.x86_64.rpm Curses-based Text User Interface for NetworkManager
Advertisement
Advertisement