apache2-devel-2.4.41-alt1.x86_64.rpm


Advertisement

Description

apache2-devel - Module development tools for the Apache web server

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename apache2-devel-2.4.41-alt1.x86_64.rpm
Package name apache2-devel
Package version 2.4.41
Package release alt1
Package architecture x86_64
Package type rpm
Category Development/C
Homepage -
License -
Maintainer -
Download size 821.89 KB
Installed size 821.89 KB
The apache-devel package contains the source code for the Apache
Web server you'll need to build Dynamic
Shared Objects (DSOs) for Apache.
If you are installing the Apache Web server and
you want to be able to compile or develop additional modules
for Apache, you'll need to install this package.

Alternatives

Package Version Architecture Repository
apache2-devel-2.4.41-alt1.i586.rpm 2.4.41 i586 Classic
apache2-devel - - -

Requires

Name Value
apache2-base = 1:2.4.41-alt1:sisyphus+236033.100.1.1
apache2-httpd = 1:2.4.41-alt1
libapr1-devel >= 1.6.5-alt1
libaprutil1-devel >= 1.6.1-alt2
rpm-build-apache2 = 1:2.4.41-alt1:sisyphus+236033.100.1.1
rpmlib(PayloadIsLzma) -

Provides

Name Value
/usr/include/apache2 -
/usr/lib64/apache2/build -
apache2-devel = 1:2.4.41-alt1:sisyphus+236033.100.1.1

Obsoletes

Name Value
apache2-libapr -
apache2-libapr-devel -
apache2-libaprutil -
apache2-libaprutil-devel -
secureweb-devel -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package apache2-devel-2.4.41-alt1.x86_64.rpm
Source Package apache2-2.4.41-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install apache2-devel rpm package:
    # sudo apt-get install apache2-devel

Files

Path
/etc/httpd2/build
/usr/bin/apxs
/usr/bin/apxs2
/usr/include/apache2/.mmn
/usr/include/apache2/ap_compat.h
/usr/include/apache2/ap_config.h
/usr/include/apache2/ap_config_auto.h
/usr/include/apache2/ap_config_layout.h
/usr/include/apache2/ap_expr.h
/usr/include/apache2/ap_hooks.h
/usr/include/apache2/ap_listen.h
/usr/include/apache2/ap_mmn.h
/usr/include/apache2/ap_mpm.h
/usr/include/apache2/ap_provider.h
/usr/include/apache2/ap_regex.h
/usr/include/apache2/ap_regkey.h
/usr/include/apache2/ap_release.h
/usr/include/apache2/ap_slotmem.h
/usr/include/apache2/ap_socache.h
/usr/include/apache2/apache_noprobes.h
/usr/include/apache2/cache_common.h
/usr/include/apache2/heartbeat.h
/usr/include/apache2/http_config.h
/usr/include/apache2/http_connection.h
/usr/include/apache2/http_core.h
/usr/include/apache2/http_log.h
/usr/include/apache2/http_main.h
/usr/include/apache2/http_protocol.h
/usr/include/apache2/http_request.h
/usr/include/apache2/http_vhost.h
/usr/include/apache2/httpd.h
/usr/include/apache2/mod_auth.h
/usr/include/apache2/mod_cache.h
/usr/include/apache2/mod_cgi.h
/usr/include/apache2/mod_core.h
/usr/include/apache2/mod_dav.h
/usr/include/apache2/mod_dbd.h
/usr/include/apache2/mod_include.h
/usr/include/apache2/mod_log_config.h
/usr/include/apache2/mod_proxy.h
/usr/include/apache2/mod_request.h
/usr/include/apache2/mod_rewrite.h
/usr/include/apache2/mod_session.h
/usr/include/apache2/mod_so.h
/usr/include/apache2/mod_ssl.h
/usr/include/apache2/mod_ssl_openssl.h
/usr/include/apache2/mod_status.h
/usr/include/apache2/mod_unixd.h
/usr/include/apache2/mod_watchdog.h
/usr/include/apache2/mod_xml2enc.h
/usr/include/apache2/mpm_common.h
/usr/include/apache2/os.h
/usr/include/apache2/scoreboard.h
/usr/include/apache2/unixd.h
/usr/include/apache2/util_cfgtree.h
/usr/include/apache2/util_charset.h
/usr/include/apache2/util_cookies.h
/usr/include/apache2/util_ebcdic.h
/usr/include/apache2/util_fcgi.h
/usr/include/apache2/util_filter.h
/usr/include/apache2/util_ldap.h
/usr/include/apache2/util_md5.h
/usr/include/apache2/util_mutex.h
/usr/include/apache2/util_script.h
/usr/include/apache2/util_time.h
/usr/include/apache2/util_varbuf.h
/usr/include/apache2/util_xml.h
/usr/lib64/apache2/build/config_vars.mk
/usr/lib64/apache2/build/instdso.sh
/usr/lib64/apache2/build/library.mk
/usr/lib64/apache2/build/ltlib.mk
/usr/lib64/apache2/build/program.mk
/usr/lib64/apache2/build/rules.mk
/usr/lib64/apache2/build/special.mk
/usr/sbin/envvars
/usr/sbin/envvars2

Changelog

2019-08-14 - Anton Farygin <rider@altlinux.ru> 1:2.4.41-alt1
- 2.4.41
2019-04-02 - Anton Farygin <rider@altlinux.ru> 1:2.4.39-alt1
- 2.4.39
- fixes:
* Apache HTTP Server privilege escalation from modules scripts. CVE-2019-0211
* mod_auth_digest access control bypass. CVE-2019-0217
* mod_ssl access control bypass. CVE-2019-0215
* Apache httpd URL normalization inconsistincy. CVE-2019-0220
2019-01-25 - Anton Farygin <rider@altlinux.ru> 1:2.4.38-alt1
- 2.4.38
- fixes:
* important: mod_ssl 2.4.37 remote DoS when used with OpenSSL 1.1.1. CVE-2019-0190
* low: mod_session_cookie does not respect expiry time. CVE-2018-17199
* low: DoS for HTTP/2 connections via slow request bodies. CVE-2018-17189
2018-10-24 - Anton Farygin <rider@altlinux.ru> 1:2.4.37-alt1
- 2.4.37
- removed TimeoutStartSec in httpd.service (closes: #27925)
- save to log remoteip instead of remote hostname for fix of work with
mod_remoteip module (closes: #34974)
2018-10-15 - Anton Farygin <rider@altlinux.ru> 1:2.4.35-alt2
- removed ubt tag
- changed rundir location to /run in tmpfiles
- disabled TLSv1 and TLSv1.1 protocols by default (closes: #34717)
2018-10-14 - Igor Vlasenko <viy@altlinux.ru> 1:2.4.35-alt1.qa1
- NMU: applied repocop patch
2018-09-25 - Anton Farygin <rider@altlinux.ru> 1:2.4.35-alt1
- 2.4.35
2018-09-03 - Anton Farygin <rider@altlinux.ru> 1:2.4.34-alt2
- rebuilt with openssl-1.1 (Sisyphus)
2018-07-31 - Anton Farygin <rider@altlinux.ru> 1:2.4.34-alt1
- 2.4.34
- fixes:
* CVE-2018-1333 DoS for HTTP/2 connections by crafted requests
* CVE-2018-8011 mod_md, DoS via Coredumps on specially crafted requests
2018-03-31 - Anton Farygin <rider@altlinux.ru> 1:2.4.33-alt1
- 2.4.33
- fixes:
* CVE-2018-1303 low: Possible out of bound read in mod_cache_socache
* CVE-2018-1302 low: Possible write of after free on HTTP/2 stream shutdown
* CVE-2018-1301 low: Possible out of bound access after failure in reading the HTTP request 
* CVE-2018-1312 low: Weak Digest auth nonce generation in mod_auth_digest
* CVE-2017-15715 low: <FilesMatch> bypass with a trailing newline in the file name
* CVE-2017-15710 low: Out of bound write in mod_authnz_ldap when using too small Accept-Language values
* CVE-2018-1283 medium: Tampering of mod_session data for CGI applications

See Also

Package Description
apache2-htcacheclean-2.4.41-alt1.x86_64.rpm Clean up the cache disk for Apache
apache2-htpasswd-2.4.41-alt1.x86_64.rpm Manage user files for basic authentication
apache2-httpd-event-2.4.41-alt1.x86_64.rpm Event driven model for Apache HTTPD 2.1
apache2-httpd-prefork-2.4.41-alt1.x86_64.rpm Traditional model for Apache HTTPD 2.1
apache2-httpd-worker-2.4.41-alt1.x86_64.rpm High speed threaded model for Apache HTTPD 2.1
apache2-mod_apreq-2.13-alt6.2.x86_64.rpm Apache2 HTTP request library
apache2-mod_apreq-devel-2.13-alt6.2.x86_64.rpm Development files for apache2-mod_apreq
apache2-mod_auth_gssapi-1.6.1-alt3.x86_64.rpm A GSSAPI Authentication module for Apache2
apache2-mod_auth_kerb-5.4-alt1.1.x86_64.rpm An Apache 2 authentication module using Kerberos
apache2-mod_auth_token-1.0.5-alt1.x86_64.rpm Token based URI access module for Apache 2.x
apache2-mod_authn_pam-0.0.1-alt1.qa1.x86_64.rpm PAM authentication module for Apache
apache2-mod_authz_external-3.3.2-alt1.x86_64.rpm flexible tools for building custom basic authentication systems for the Apache HTTP Daemon
apache2-mod_cache_disk-2.4.41-alt1.x86_64.rpm Module supported content cache storage for the Apache HTTP server
apache2-mod_dbi_pool-0.4.0-alt2.x86_64.rpm Provides database connection pooling services for the apache web server
apache2-mod_dbi_pool-devel-0.4.0-alt2.x86_64.rpm Development files for mod_dbi_pool
Advertisement
Advertisement