gcc-go-8-alt2.x86_64.rpm


Advertisement

Description

gcc-go - Dependency package for GNU Go compiler

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename gcc-go-8-alt2.x86_64.rpm
Package name gcc-go
Package version 8
Package release alt2
Package architecture x86_64
Package type rpm
Category Development/C
Homepage -
License -
Maintainer -
Download size unknown
Installed size unknown
This is metapackage for the default GNU Go compiler.

Alternatives

Package Version Architecture Repository
gcc-go-8-alt2.i586.rpm 8 i586 Classic
gcc-go - - -

Requires

Name Value
/usr/bin/x86_64-alt-linux-gccgo-8 -
gcc = 8-alt2:sisyphus+235723.100.1.1
gcc8-go -
rpmlib(PayloadIsLzma) -

Provides

Name Value
gcc-go = 8-alt2:sisyphus+235723.100.1.1

Conflicts

Name Value
gcc4.7-go < 4.7.2-alt11
gcc4.8-go < 4.8.2-alt6
gcc4.9-go < 4.9.2-alt6
gcc5-go < 5.3.1-alt5
gcc6-go < 6.3.1-alt3

Download

Type URL
Mirror ftp.altlinux.org
Binary Package gcc-go-8-alt2.x86_64.rpm
Source Package gcc-defaults-8-alt2.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install gcc-go rpm package:
    # sudo apt-get install gcc-go

Files

Path
/usr/bin/x86_64-alt-linux-gccgo
/usr/share/man/man1/gccgo.1.xz

Changelog

2019-08-07 - Gleb F-Malinovskiy <glebfm@altlinux.org> 8-alt2
- Added ppc64le (ALT#37086) and riscv64 support.
- Added gcc-gdb-plugin subpackage.
2018-10-29 - Gleb F-Malinovskiy <glebfm@altlinux.org> 8-alt1
- Changed default gcc version to 8.
- Dropped libcilkrts-* subpackages.
2018-06-06 - Gleb F-Malinovskiy <glebfm@altlinux.org> 7-alt6
- Fixed installation (with rpm --excludedocs option) of subpackages containing
symlinks on gcc manpages (ALT#34996).
2018-05-13 - Ivan Zakharyaschev <imz@altlinux.org> 7-alt5
- (.spec) Made possible to disable noarch subpkgs.
- More specific Group for gcc-c++. (ALT#34901)
- Filled URL. (ALT#34624)
2018-02-18 - Dmitry V. Levin <ldv@altlinux.org> 7-alt4
- aarch64: packaged liblsan-devel-static and libtsan-devel-static.
2018-02-17 - Dmitry V. Levin <ldv@altlinux.org> 7-alt3
- Upgraded Conflicts tags.
2018-02-17 - Dmitry V. Levin <ldv@altlinux.org> 7-alt2
- gcc-fortran: provide gcc-g77.
- Fixed conditional packaging of subpackages.
- Fixed symlinks.
- Made arch-agnostic dependency packages noarch.
2018-01-17 - Gleb F-Malinovskiy <glebfm@altlinux.org> 7-alt1
- Initial build.

See Also

Package Description
gcc-h8300-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for h8300-linux-gnu
gcc-hppa-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for hppa-linux-gnu
gcc-hppa64-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for hppa64-linux-gnu
gcc-ia64-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for ia64-linux-gnu
gcc-m32r-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for m32r-linux-gnu
gcc-m68k-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for m68k-linux-gnu
gcc-microblaze-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for microblaze-linux-gnu
gcc-mips64-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for mips64-linux-gnu
gcc-mn10300-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for mn10300-linux-gnu
gcc-nios2-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for nios2-linux-gnu
gcc-powerpc64-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for powerpc64-linux-gnu
gcc-powerpc64le-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for powerpc64le-linux-gnu
gcc-ppc64-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for ppc64-linux-gnu
gcc-ppc64le-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for ppc64le-linux-gnu
gcc-riscv64-linux-gnu-8.2.1-alt1_1.1.x86_64.rpm Cross-build binary utilities for riscv64-linux-gnu
Advertisement
Advertisement