gdcm-2.8.4-alt3_11.x86_64.rpm


Advertisement

Description

gdcm - Grassroots DiCoM is a C++ library to parse DICOM medical files

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package filename gdcm-2.8.4-alt3_11.x86_64.rpm
Package name gdcm
Package version 2.8.4
Package release alt3_11
Package architecture x86_64
Package type rpm
Category System/Libraries
Homepage -
License -
Maintainer -
Download size 9.26 MB
Installed size 9.26 MB
Grassroots DiCoM (GDCM) is a C++ library for DICOM medical files.
It supports ACR-NEMA version 1 and 2 (huffman compression is not supported),
RAW, JPEG, JPEG 2000, JPEG-LS, RLE and deflated transfer syntax.
It comes with a super fast scanner implementation to quickly scan hundreds of
DICOM files. It supports SCU network operations (C-ECHO, C-FIND, C-STORE,
C-MOVE). PS 3.3 & 3.6 are distributed as XML files.
It also provides PS 3.15 certificates and password based mechanism to
anonymize and de-identify DICOM datasets.

Alternatives

Package Version Architecture Repository
gdcm-2.8.4-alt3_11.i586.rpm 2.8.4 i586 Classic
gdcm - - -

Requires

Name Value
libCharLS.so.1()(64bit) -
libc.so.6(GLIBC_2.11)(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.15)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.7)(64bit) -
libcrypto.so.1.1()(64bit) -
libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libexpat.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libjson-c.so.4()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libm.so.6(GLIBC_2.27)(64bit) -
libopenjp2.so.7()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.1)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libuuid.so.1()(64bit) -
libuuid.so.1(UUID_1.0)(64bit) -
libz.so.1()(64bit) -
rpmlib(PayloadIsLzma) -
rpmlib(SetVersions) -
rtld(GNU_HASH) -
rtld(GNU_UNIQUE) -

Provides

Name Value
gdcm = 2.8.4-alt3_11:sisyphus+226468.700.9.1
libgdcmCommon.so.2.8()(64bit) -
libgdcmDICT.so.2.8()(64bit) -
libgdcmDSED.so.2.8()(64bit) -
libgdcmIOD.so.2.8()(64bit) -
libgdcmMEXD.so.2.8()(64bit) -
libgdcmMSFF.so.2.8()(64bit) -
libgdcmjpeg12.so.2.8()(64bit) -
libgdcmjpeg16.so.2.8()(64bit) -
libgdcmjpeg8.so.2.8()(64bit) -
libgdcmmd5.so.2.8()(64bit) -
libsocketxx.so.1.2()(64bit) -

Download

Type URL
Mirror ftp.altlinux.org
Binary Package gdcm-2.8.4-alt3_11.x86_64.rpm
Source Package gdcm-2.8.4-alt3_11.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install gdcm rpm package:
    # sudo apt-get install gdcm

Files

Path
/usr/lib64/libgdcmCommon.so.2.8
/usr/lib64/libgdcmCommon.so.2.8.4
/usr/lib64/libgdcmDICT.so.2.8
/usr/lib64/libgdcmDICT.so.2.8.4
/usr/lib64/libgdcmDSED.so.2.8
/usr/lib64/libgdcmDSED.so.2.8.4
/usr/lib64/libgdcmIOD.so.2.8
/usr/lib64/libgdcmIOD.so.2.8.4
/usr/lib64/libgdcmMEXD.so.2.8
/usr/lib64/libgdcmMEXD.so.2.8.4
/usr/lib64/libgdcmMSFF.so.2.8
/usr/lib64/libgdcmMSFF.so.2.8.4
/usr/lib64/libgdcmjpeg12.so.2.8
/usr/lib64/libgdcmjpeg12.so.2.8.4
/usr/lib64/libgdcmjpeg16.so.2.8
/usr/lib64/libgdcmjpeg16.so.2.8.4
/usr/lib64/libgdcmjpeg8.so.2.8
/usr/lib64/libgdcmjpeg8.so.2.8.4
/usr/lib64/libgdcmmd5.so.2.8
/usr/lib64/libgdcmmd5.so.2.8.4
/usr/lib64/libsocketxx.so.1.2
/usr/lib64/libsocketxx.so.1.2.0
/usr/share/doc/gdcm-2.8.4/AUTHORS
/usr/share/doc/gdcm-2.8.4/Copyright.txt
/usr/share/doc/gdcm-2.8.4/README.Copyright.txt
/usr/share/doc/gdcm-2.8.4/README.txt
/usr/share/gdcm/
/usr/share/gdcm/XML/CSAHeader.xml
/usr/share/gdcm/XML/Part3.xml
/usr/share/gdcm/XML/Part4.xml
/usr/share/gdcm/XML/Part6.xml
/usr/share/gdcm/XML/Part7a.xml
/usr/share/gdcm/XML/Part7b.xml
/usr/share/gdcm/XML/UIDs.xml
/usr/share/gdcm/XML/cp699.xml

Changelog

2019-02-13 - Igor Vlasenko <viy@altlinux.ru> 2.8.4-alt3_11
- fixed build
2019-01-09 - Igor Vlasenko <viy@altlinux.ru> 2.8.4-alt2_11
- fixed build
2018-08-29 - Grigory Ustinov <grenka@altlinux.org> 2.8.4-alt2_8.1
- NMU: Rebuild with new openssl 1.1.0.
2018-08-03 - Aleksei Nikiforov <darktemplar@altlinux.org> 2.8.4-alt2_8
- Fixed build.
2018-07-14 - Igor Vlasenko <viy@altlinux.ru> 2.8.4-alt1_8
- applied repocop patch
- update to new release by fcimport
2018-05-07 - Igor Vlasenko <viy@altlinux.ru> 2.8.4-alt1_7
- update to new release by fcimport
2018-03-22 - Aleksei Nikiforov <darktemplar@altlinux.org> 2.6.5-alt1_19.1
- (NMU) Rebuilt with python-3.6.4.
2018-01-30 - Igor Vlasenko <viy@altlinux.ru> 2.6.5-alt1_19
- new version
2013-11-21 - Sergey V Turchin <zerg@altlinux.org> 2.2.3-alt2.M70P.1
- Rebuild for poppler
2013-04-23 - Slava Dubrovskiy <dubrsl@altlinux.org> 2.2.3-alt2
- Rebuild for poppler

See Also

Package Description
gdcm-applications-2.8.4-alt3_11.x86_64.rpm Includes command line programs for GDCM
gdcm-devel-2.8.4-alt3_11.x86_64.rpm Libraries and headers for GDCM
gdcm-examples-2.8.4-alt3_11.x86_64.rpm CSharp, C++, Java, PHP and Python example programs for GDCM
gddccontrol-0.4.2-alt17.20140603git9d89d8c.x86_64.rpm GUI for controlling your monitor using the DDC/CI protocol
gdesklets-0.36.3-alt4.qa1.x86_64.rpm gDesklets - an advanced architecture for desktop applets
gdisk-1.0.1-alt1.x86_64.rpm An fdisk-like partitioning tool for GPT disks
gdm-3.32.0-alt1.x86_64.rpm The GNOME Display Manager
gdm-libs-3.32.0-alt1.x86_64.rpm GDM libraries
gdm-libs-devel-3.32.0-alt1.x86_64.rpm Development files for GDM libraries
gdm-libs-gir-3.32.0-alt1.x86_64.rpm GObject introspection data for the GDM
gdm2.20-2.20.8-alt12.x86_64.rpm The GNOME Display Manager
geany-1.35-alt2.x86_64.rpm A fast and lightweight IDE using GTK2
geany-devel-1.35-alt2.x86_64.rpm Header files for building Geany plug-ins
geany-plugins-1.35-alt1.x86_64.rpm Plugins for Geany
geany-plugins-vc-1.35-alt1.x86_64.rpm Geany VC integration plugin
Advertisement
Advertisement