libEMF-1.0.9-alt1.x86_64.rpm


Advertisement

Description

libEMF - A library for generating Enhanced Metafiles

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package name libEMF
Package version 1.0.9
Package release alt1
Package architecture x86_64
Package type rpm
Installed size 266.19 KB
Download size 266.19 KB
Official Mirror ftp.altlinux.org
libEMF is a library for generating Enhanced Metafiles on systems which
don't natively support the ECMA-234 Graphics Device Interface
(GDI). The library is intended to be used as a driver for other
graphics programs such as Grace or gnuplot. Therefore, it implements a
very limited subset of the GDI.

Alternatives

Package Version Architecture Repository
libEMF-1.0.9-alt1.i586.rpm 1.0.9 i586 Classic
libEMF - - -

Requires

Name Value
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
rpmlib(PayloadIsLzma) -
rtld(GNU_HASH) -

Provides

Name Value
libEMF = 1.0.9-alt1
libEMF.so.1()(64bit) -

Download

Type URL
Binary Package libEMF-1.0.9-alt1.x86_64.rpm
Source Package libEMF-1.0.9-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libEMF rpm package:
    # sudo apt-get install libEMF

Files

Path
/usr/lib64/libEMF.so.1
/usr/lib64/libEMF.so.1.0.0
/usr/share/doc/libEMF-1.0.9/AUTHORS
/usr/share/doc/libEMF-1.0.9/COPYING
/usr/share/doc/libEMF-1.0.9/COPYING.LIB
/usr/share/doc/libEMF-1.0.9/ChangeLog
/usr/share/doc/libEMF-1.0.9/NEWS
/usr/share/doc/libEMF-1.0.9/README

Changelog

2017-05-29 - Michael Shigorin <mike@altlinux.org> 1.0.9-alt1
- 1.0.9
2014-08-05 - Michael Shigorin <mike@altlinux.org> 1.0.7-alt1
- added watch file
- new version (watch file uupdate)
+ dropped patches
+ added fedora aarch64 patch while at that
2013-02-27 - Sergey Bolshakov <sbolshakov@altlinux.ru> 1.0.4-alt2
- fixed build on arm
2010-11-27 - Igor Vlasenko <viy@altlinux.ru> 1.0.4-alt1.qa1
- rebuild using girar-nmu to require/provide setversion 
by request of mithraen@
2009-12-13 - Michael Shigorin <mike@altlinux.org> 1.0.4-alt1
- built for ALT Linux
+ spec adapted from Fedora
- where it got adapted from PLD
- heavy spec cleanup
- refined subpackages (added utils and optional devel-static)

See Also

Package Description
libEMF-devel-1.0.9-alt1.x86_64.rpm libEMF header files
libEMF-utils-1.0.9-alt1.x86_64.rpm libEMF utilities
libFS-1.0.6-alt1.x86_64.rpm Library Interface to the X Font Server
libFS-devel-1.0.6-alt1.x86_64.rpm X Font Server Library and Header Files
libGConf-3.2.6-alt3.x86_64.rpm Gnome Config System library package
libGConf-devel-3.2.6-alt3.x86_64.rpm Gnome Config System development package
libGConf-gir-3.2.6-alt3.x86_64.rpm GObject introspection data for the GConf library
libGL-18.1.1-alt1.S1.x86_64.rpm OpenGL 1.3 compatible 3D graphics library for X Window server
libGL-devel-18.1.1-alt1.S1.x86_64.rpm Development files for Mesa Library
libGLES-18.1.1-alt1.S1.x86_64.rpm Mesa OpenGL ES library
libGLES-devel-18.1.1-alt1.S1.x86_64.rpm Mesa libGLES development package
libGLEW-devel-2.1.0-alt2.S1.x86_64.rpm The OpenGL Extension Wrangler library development files
libGLEW1.13-1.13.0-alt4.x86_64.rpm The OpenGL Extension Wrangler library
libGLEW2.0-2.0.0-alt3.x86_64.rpm The OpenGL Extension Wrangler library
libGLEW2.1-2.1.0-alt2.S1.x86_64.rpm The OpenGL Extension Wrangler library
Advertisement
Advertisement