libarprec-devel-2.2.19-alt1.x86_64.rpm


Advertisement

Description

libarprec-devel - Development files of ARPREC

Property Value
Distribution ALT Linux Sisyphus
Repository Classic x86_64
Package name libarprec-devel
Package version 2.2.19
Package release alt1
Package architecture x86_64
Package type rpm
Installed size 139.10 KB
Download size 139.10 KB
Official Mirror ftp.altlinux.org
This package supports a flexible, arbitrarily high level of numeric precision --
the equivalent of hundreds or even thousands of decimal digits (up to
approximately ten million digits if needed). Special routines are provided for
extra-high precision (above 1000 digits). The entire library is written in C++.
High-precision real, integer and complex datatypes are supported. Both C++ and
Fortran-90 translation modules modules are also provided that permit one to
convert an existing C++ or Fortran-90 program to use the library with only minor
changes to the source code. In most cases only the type statements and (in the
case of Fortran-90 programs) read/write statements need be changed. Six
implementations of PSLQ (one-, two- and three-level, regular and multi-pair) are
included, as well as three high-precision quadrature programs. New users are
encouraged to use this package, rather than MPFUN90 or MPFUN77 (see below).
This package contains development files of ARPREC.

Alternatives

Package Version Architecture Repository
libarprec-devel-2.2.19-alt1.i586.rpm 2.2.19 i586 Classic
libarprec-devel - - -

Requires

Name Value
coreutils -
libarprec = 2.2.19-alt1
libqd-devel -
rpmlib(PayloadIsLzma) -

Provides

Name Value
libarprec-devel = 2.2.19-alt1

Conflicts

Name Value
libarprec-devel < 2.2.19-alt1

Obsoletes

Name Value
libarprec-devel < 2.2.19-alt1

Download

Type URL
Binary Package libarprec-devel-2.2.19-alt1.x86_64.rpm
Source Package arprec-2.2.19-alt1.src.rpm

Install Howto

  1. Add the following line to /etc/apt/sources.list:
    
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus x86_64 classic
    rpm [Sisyphus] http://ftp.altlinux.org/pub/distributions/ALTLinux/Sisyphus noarch classic
    
  2. Update the package index:
    # sudo apt-get update
  3. Install libarprec-devel rpm package:
    # sudo apt-get install libarprec-devel

Files

Path
/usr/bin/arprec-config
/usr/include/arprec/arprec_config.h
/usr/include/arprec/c_mp.h
/usr/include/arprec/double_inline.h
/usr/include/arprec/fpu.h
/usr/include/arprec/mp.h
/usr/include/arprec/mp_complex.h
/usr/include/arprec/mp_complex_inline.h
/usr/include/arprec/mp_complex_temp.h
/usr/include/arprec/mp_inline.h
/usr/include/arprec/mp_int.h
/usr/include/arprec/mp_int_inline.h
/usr/include/arprec/mp_int_temp.h
/usr/include/arprec/mp_real.h
/usr/include/arprec/mp_real_temp.h
/usr/include/arprec/mpcomplexmod.mod
/usr/include/arprec/mpdefmod.mod
/usr/include/arprec/mpgenmod.mod
/usr/include/arprec/mpintmod.mod
/usr/include/arprec/mpmodule.mod
/usr/include/arprec/mpmodulem.mod
/usr/include/arprec/mpmodulex.mod
/usr/include/arprec/mprealmod.mod
/usr/lib64/libarprec.so
/usr/lib64/libarprec_f_main.so
/usr/lib64/libarprecmod.so

Changelog

See arprec-2.2.19-alt1.x86_64.rpm changelog.

See Also

Package Description
libart_lgpl-2.3.21-alt3.x86_64.rpm Library of graphics routines used by libgnomecanvas
libart_lgpl-devel-2.3.21-alt3.x86_64.rpm Libraries and headers for libart_lgpl
libartikulatecore4-15.12.3-alt7.S1.x86_64.rpm KDE 4 library
libartikulatelearnerprofile4-15.12.3-alt7.S1.x86_64.rpm KDE 4 library
libartikulatesound4-15.12.3-alt7.S1.x86_64.rpm KDE 4 library
libasan-devel-static-8-alt1.x86_64.rpm Dependency package for libasan-devel-static
libasan0-4.8.2-alt6.1.x86_64.rpm The Address Sanitizer runtime library
libasan1-4.9.2-alt6.1.x86_64.rpm The Address Sanitizer runtime library
libasan2-5.3.1-alt5.1.x86_64.rpm The Address Sanitizer runtime library
libasan3-6.3.1-alt3.1.x86_64.rpm The Address Sanitizer runtime library
libasan4-7.3.1-alt7.x86_64.rpm The Address Sanitizer runtime library
libasan4.8-devel-static-4.8.2-alt6.1.x86_64.rpm The Address Sanitizer static library
libasan4.9-devel-static-4.9.2-alt6.1.x86_64.rpm The Address Sanitizer static library
libasan5-8.2.1-alt1.x86_64.rpm The Address Sanitizer runtime library
libasan5-devel-static-5.3.1-alt5.1.x86_64.rpm The Address Sanitizer static library
Advertisement
Advertisement