libevtx - Library and tools to access the Windows XML Event Log (EVTX) format

Distribution: ALT Linux Sisyphus
Repository: Classic x86_64
Package name: libevtx
Package version: 20140323
Package release: alt1
Package architecture: x86_64
Package type: rpm
Installed size: 584.74 KB
Download size: 584.74 KB
Official Mirror:
Library and tools to access the Windows XML Event Log (EVTX) format. For the Windows pre-XML Event Log (EVT) format, see libevt.



  • libevtx = 20140323-alt1


    Install Howto

    1. Add the following line to /etc/apt/sources.list:
      rpm [Sisyphus] x86_64 classic
      rpm [Sisyphus] noarch classic
    2. Update the package index:
      # sudo apt-get update
    3. Install libevtx rpm package:
      # sudo apt-get install libevtx


    • /usr/lib64/
    • /usr/lib64/
    • /usr/share/doc/libevtx-20140323/AUTHORS
    • /usr/share/doc/libevtx-20140323/ChangeLog


    2014-05-11 - Michael Shigorin <> 20140323-alt1 - new version (watch file uupdate)

    2014-05-11 - Michael Shigorin <> 20131013-alt1 - initial build for ALT Linux Sisyphus

    2013-11-26 - - using internal libregf, latest factory update broke libevtx

    2013-11-04 - - update to 20131013 * updated dependencies - using internal libwrc, latest factory update broke libevtx - removed from buildrequires dependencies

    2013-10-02 - - update to 20130923 * updated dependencies * worked on libcthreads build support

    2013-07-31 - - update to 20130727 * updated dependencies * pyevtx - changed event identifier to an unsigned long - fixes for >2G file objects in BFIO glue code - other updates and bug fixes * removed unnecessary restriction in library include headers * worked on tests * improved reading from dirty files with an incorrect number of chunks * fix for encoding special characters in XML output * added support for parsing ProcessingErrorData * worked on improving corruption detection for recovered records * textual changes * fixed codepage 1255 restriction * improvements to message string support - changed to gz compression to simplyfy donwload/convert - used factory version of libyal libraries if possible

    2013-04-08 - - update to 20130329 * bug fix for recent libfdata changes

    2013-04-04 - - Cleanups: Set RPM group, license, summary and description metadata; remove unused %py_requires; do not bloat shlib package with documentation - Use system libraries instead of bundled ones where possible - Name the tools package according to upstream's recommendation - Drop unnecessary -fno-strict-aliasing

    2013-03-27 - - initial package (version 20130319) for